SX170 porting - page 23 - DryOS Development - CHDK Forum  

SX170 porting

  • 266 Replies
  • 79021 Views
*

Offline srsa_4c

  • ******
  • 4450
Re: SX170 porting
« Reply #220 on: 06 / February / 2015, 18:59:44 »
Advertisements
Changes committed: trunk, 1.3

Port is released as alpha. http://chdk.wikia.com/wiki/Downloads

*

Offline TMHKR

  • **
  • 77
  • Canon PowerShot SX170 IS (1.01a firmware)
Re: SX170 porting
« Reply #221 on: 06 / February / 2015, 19:34:09 »
Changes committed: trunk, 1.3

Port is released as alpha. http://chdk.wikia.com/wiki/Downloads

Thanks. I will test it thoroughly tomorrow.

Edit: Everything seems to work so far :)
« Last Edit: 07 / February / 2015, 06:46:13 by TMHKR »

Re: SX170 porting
« Reply #222 on: 09 / February / 2015, 16:00:21 »
canon opening is 3.5 and in the CHDK is 3.6?
I spend with the value of 2.88 CHDK he had in the previous test versions.
low values could place please.  8)

*

Offline TMHKR

  • **
  • 77
  • Canon PowerShot SX170 IS (1.01a firmware)
Re: SX170 porting
« Reply #223 on: 09 / February / 2015, 16:12:34 »
canon opening is 3.5 and in the CHDK is 3.6?
I spend with the value of 2.88 CHDK he had in the previous test versions.
low values could place please.  8)

As waterwingz once said, there is absolutely no way a camera can use Av values lower than its factory hardware value, which is f/3.5 for our model. Older test versions used the values from a wrong model.

He also said that you may use values higher than the upper limit (above f/8.0 for our model), but the photos will look bad.


*

Offline srsa_4c

  • ******
  • 4450
Re: SX170 porting
« Reply #224 on: 09 / February / 2015, 17:45:55 »
It's possible that the aperture values in the previously mentioned table are slightly off. The correct values can be retrieved the following way:

Activate the propcase debug display: Miscellaneous stuff -> Debug parameters -> Debug data display [Props], Propcase/Paramsdata page [2]
Switch the camera to Av or M mode, watch and note the number displayed after "26:" as you set the aperture with the Canon controls.

Something like:
Canon Av, value
3.5,      355
4.0,      391
...


Not sure how much influence this has on the CHDK override in the "Enhanced photo operations" menu. Despite the correct table, I get 3.56 as the lowest selectable Av value on my sx280 (the advertised minimum Av is 3.5 on this cam).

*

Offline TMHKR

  • **
  • 77
  • Canon PowerShot SX170 IS (1.01a firmware)
Re: SX170 porting
« Reply #225 on: 09 / February / 2015, 18:17:20 »
It's possible that the aperture values in the previously mentioned table are slightly off.

Well, I think the values off by some 0.05 (0.10 at max) wouldn't make any particular difference in the resulting photos anyway. So far, the build works good.

*

Offline reyalp

  • ******
  • 13751
Re: SX170 porting
« Reply #226 on: 15 / February / 2015, 16:27:11 »
I noticed the SX160 kbd.c jogdial code was set up for a front dial, but the camera doesn't actually have one. It looks like the SX170 code is the same.

From the manual, it looks like sx170 doesn't actually have a front dial either. If that's true, it should be fixed because the front dial code will probably cause memory corruption.
Don't forget what the H stands for.

*

Offline TMHKR

  • **
  • 77
  • Canon PowerShot SX170 IS (1.01a firmware)
Re: SX170 porting
« Reply #227 on: 15 / February / 2015, 16:59:16 »
I noticed the SX160 kbd.c jogdial code was set up for a front dial, but the camera doesn't actually have one. It looks like the SX170 code is the same.

From the manual, it looks like sx170 doesn't actually have a front dial either. If that's true, it should be fixed because the front dial code will probably cause memory corruption.

What do you refer to as "front dial"?

SX170 has a back dial only. It's direction was inverted in CHDK menus though, but srsa_4c fixed that before the release.


*

Offline reyalp

  • ******
  • 13751
Re: SX170 porting
« Reply #228 on: 15 / February / 2015, 17:11:59 »
What do you refer to as "front dial"?

SX170 has a back dial only.
That's exactly the problem. The code was copied from a camera like g12 that has a second control dial, but sx170 only has one. This might be harmless, or might cause problems elsewhere.

I've checked the fix into the 1.4 trunk, autobuild 4008 and later. If you can confirm the dial still works correctly and nothing else is obviously broken, I'll merge it over to 1.3 as well.
Don't forget what the H stands for.

*

Offline TMHKR

  • **
  • 77
  • Canon PowerShot SX170 IS (1.01a firmware)
Re: SX170 porting
« Reply #229 on: 15 / February / 2015, 18:31:05 »
Quote
I've checked the fix into the 1.4 trunk, autobuild 4008 and later. If you can confirm the dial still works correctly and nothing else is obviously broken, I'll merge it over to 1.3 as well.

1.4.0, autobuild 4010, firmware 1.01a = The dial works fine.

 

Related Topics