supplierdeeply

SX210is long exposure time no workee

  • 3 Replies
  • 564 Views
SX210is long exposure time no workee
« on: 08 / February / 2014, 17:16:47 »
Advertisements
One of my reasons for using CHDK is to enable longer exposure times, for night and star photography. My SX210IS has a maximum of 15 seconds, which ain't enough. So I downloaded CHDK and everything installed smoothly (nice job, fellas). It was straightforward to establish, say, a 2-minute exposure time. Long story short, the camera obeys the desired shutter time but only when running a script. (Well, so far I've only tested shoot and interval). But if I shoot manually, i.e., not via script, the camera behaves as if I hadn't specified the shutter time -- instant-click.

Now I'm not the kind of guy to throw my hands up in despair after just one try. I've tried dozens of times to no effect, so I don't think this is a stupid user error, except of course it always could be. But whenever I try a script, it works as desired. In fact, shooting via a script is probably OK for 95% of my shots, but I'd still like to know why I can't manually run with a delay.

Re: SX210is long exposure time no workee
« Reply #1 on: 08 / February / 2014, 17:26:38 »
So I assume you are trying to use the  Override Tv  menu item in the  Enhanced Photo Operations menu and that's not working?

The default shoot & interval scripts don't give you the option to set the Tv value.  So that kind of confuses me.  Are you running those scripts with the menu selected Tv override values or something ?

Do you have  Disable Overrides set to [ No ] ?

And Disable Overrides on Startup set to  [  ] ?



« Last Edit: 08 / February / 2014, 17:29:17 by waterwingz »
Ported :   A1200    SD940   G10    Powershot N    G16

Re: SX210is long exposure time no workee
« Reply #2 on: 08 / February / 2014, 22:05:04 »
So I assume you are trying to use the  Override Tv  menu item in the  Enhanced Photo Operations menu and that's not working?

The default shoot & interval scripts don't give you the option to set the Tv value.  So that kind of confuses me.  Are you running those scripts with the menu selected Tv override values or something ?

Do you have  Disable Overrides set to [ No ] ?

And Disable Overrides on Startup set to  [  ] ?

Right on target with everything. I set the desired Tv value via Enhanced Photo Operations -> Override Tv -> 00:02:00 (say) with type -> LongExp.

Disable Overrides set to [ No ] ................... Check
Disable Overrides on Startup set to  [  ] ...... Check

If I exit <ALT> mode back to Canon mode and press the shutter, no delay; insta-click. If I stay in <ALT> mode, select shoot, and press the shutter, then a lonnnng delay before the shutter closes.

Is there some other way I'm supposed to do this? I'm all ears...

Re: SX210is long exposure time no workee
« Reply #3 on: 08 / February / 2014, 22:54:05 »
Is there some other way I'm supposed to do this?
Nope - what you describe is pretty much how it's supposed to be.

Which I think leaves a problem with the port - something in the capt_seq.c file most likely.  Or kbd.c maybe.  It will likely take a while to track this down.  Seems a bit strange it has not been noticed before - the porting thread is huge : http://chdk.setepontos.com/index.php?topic=5045 and this post seems to indicate it works :  http://chdk.setepontos.com/index.php?topic=5045.msg99851#msg99851

But I might be missing something obvious.  It would not be the first time.
« Last Edit: 08 / February / 2014, 23:00:33 by waterwingz »
Ported :   A1200    SD940   G10    Powershot N    G16


 

Related Topics