Turn off shutter sounds? (A3400is)

  • 11 Replies
  • 1287 Views
Turn off shutter sounds? (A3400is)
« on: 12 / March / 2014, 20:30:30 »
Advertisements
Hi All,

I am brand new to CHDK and love what you guys have done here!  Anyways, i'm setting up my A3400is to run a intervalometer script that will be running for a LONG time.  The picture taking part of the script seems to be working great for me but i have a couple features I want to add and was hoping someone could  help me out.

I want to turn off the auto-focus sound that is made every time a picture is taken.  This will be very noticeable where i'm taking these pictures so that would be great.

I also want to have the script automatically turn off the LCD so the camera will last a lot longer. 

Are these possible?

Thank you!!

Re: Turn off shutter sounds? (A3400is)
« Reply #1 on: 12 / March / 2014, 20:43:03 »
I want to turn off the auto-focus sound that is made every time a picture is taken.  This will be very noticeable where i'm taking these pictures so that would be great.
set_aflock(1) will just lock the autofocus for you.  To turn off sounds, you need to use the Canon menus.

Quote
I also want to have the script automatically turn off the LCD so the camera will last a lot longer. 
set_lcd_display(1)

You might find this page useful : http://chdk.wikia.com/wiki/CHDK_Scripting_Cross_Reference_Page#All_Scripting_Functions
Ported :   A1200    SD940   G10    Powershot N    G16

Re: Turn off shutter sounds? (A3400is)
« Reply #2 on: 12 / March / 2014, 20:43:34 »
I want to turn off the auto-focus sound that is made every time a picture is taken.  This will be very noticeable where i'm taking these pictures so that would be great.
set_aflock(1)

Quote
I also want to have the script automatically turn off the LCD so the camera will last a lot longer. 
set_lcd_display(1)

You might find this page useful : http://chdk.wikia.com/wiki/CHDK_Scripting_Cross_Reference_Page#All_Scripting_Functions

Thanks!!

Re: Turn off shutter sounds? (A3400is)
« Reply #3 on: 12 / March / 2014, 20:44:37 »
Thanks!!
You answered before I could edit my previous post.  Pretty good considering I got that done in under 30 seconds from the original post.
Ported :   A1200    SD940   G10    Powershot N    G16


Re: Turn off shutter sounds? (A3400is)
« Reply #4 on: 12 / March / 2014, 21:21:31 »
Thanks!!
You answered before I could edit my previous post.  Pretty good considering I got that done in under 30 seconds from the original post.

Thanks for your quick responses!

How do you actually put these in the script?  I added them to the script and nothing much happened.  I've attached the script i'm using here.

Re: Turn off shutter sounds? (A3400is)
« Reply #5 on: 12 / March / 2014, 21:23:43 »
Try
  set_lcd_display 1
rather than
 set_lcd_display 0


Edit :  wrong - see below.
« Last Edit: 12 / March / 2014, 22:14:42 by waterwingz »
Ported :   A1200    SD940   G10    Powershot N    G16

Re: Turn off shutter sounds? (A3400is)
« Reply #6 on: 12 / March / 2014, 21:31:50 »
It looks like the screen turns off for a split second, but it comes right back on to display the picture and is on until the next picture is taken.  Is there anyway to set it to be permanent in the script, until i interrupt it?

Re: Turn off shutter sounds? (A3400is)
« Reply #7 on: 12 / March / 2014, 21:40:44 »
It looks like the screen turns off for a split second, but it comes right back on to display the picture and is on until the next picture is taken.  Is there anyway to set it to be permanent in the script, until i interrupt it?
That should have done it.  Do you have "Review" in the Canon shooting menu set to "Off"?

You could also try moving the set_lcd_display command to just after the shoot command but that really should not be necessary.
Ported :   A1200    SD940   G10    Powershot N    G16


Re: Turn off shutter sounds? (A3400is)
« Reply #8 on: 12 / March / 2014, 21:56:06 »
Tried both of those and they also didn't work. 

"BUSY" comes up when it's processing the photo and it looks like that might be turning the screen back on.  Your help is appreciated, hopefully we can figure this out!

Re: Turn off shutter sounds? (A3400is)
« Reply #9 on: 12 / March / 2014, 22:13:30 »
I misled you earlier (would help if I actually read the web page I pointed you to or tested what I wrote - sorry).

Use :
Code: [Select]
set_lcd_display 0 to turn off the display.

I modified your script and tested it.  The display on my A1200 goes off and stays off (with Canon Review mode disabled).  I've attached the modified version.
Ported :   A1200    SD940   G10    Powershot N    G16

 

Related Topics