SX40 HS newbie help -- how to increase video time limit? (or file size limit)

  • 6 Replies
  • 1943 Views
Advertisements
I downloaded the time_ext.bas and .lua scripts from the wiki and have found that they don't work at all on my camera, i managed to get other scripts like hdr or video exposure to work with no problems at all.. my firmware is 1.00i
and i get errors like this:
***STARTED***
uBASIC: 1 Unk stmt
***TERMINATED*** for the first .bas script

and

***STARTED***
:1 unexpected symbol
near 'char(239)'
***TERMINATED*** for the .lua script

i copy/pasted the scripts from the wiki as they were onto notepad and saved with their respective file extensions in utf-8 coding (guiding me from the Continuous Video thread) so i don't know what could be wrong


thanks in advance

*

Offline reyalp

  • ******
  • 11392
I downloaded the time_ext.bas and .lua scripts from the wiki and have found that they don't work at all on my camera, i managed to get other scripts like hdr or video exposure to work with no problems at all.. my firmware is 1.00i
and i get errors like this:
***STARTED***
uBASIC: 1 Unk stmt
***TERMINATED*** for the first .bas script

and

***STARTED***
:1 unexpected symbol
near 'char(239)'
***TERMINATED*** for the .lua script

i copy/pasted the scripts from the wiki as they were onto notepad and saved with their respective file extensions in utf-8 coding (guiding me from the Continuous Video thread) so i don't know what could be wrong


thanks in advance
Both of these errors mean you did not actually get the file in the right format. I suggest using notepad or equivalent and saving as ANSI or ASCII.

Note they should be ASCII text, NOT UTF-8. UTF-8 will probably work in most cases but some programs may put a BOM at the start which will probably confuse CHDK.
« Last Edit: 28 / March / 2014, 17:25:19 by reyalp »
Don't forget what the H stands for.

I downloaded the time_ext.bas and .lua scripts from the wiki and have found that they don't work at all on my camera, i managed to get other scripts like hdr or video exposure to work with no problems at all.. my firmware is 1.00i
and i get errors like this:
***STARTED***
uBASIC: 1 Unk stmt
***TERMINATED*** for the first .bas script

and

***STARTED***
:1 unexpected symbol
near 'char(239)'
***TERMINATED*** for the .lua script

i copy/pasted the scripts from the wiki as they were onto notepad and saved with their respective file extensions in utf-8 coding (guiding me from the Continuous Video thread) so i don't know what could be wrong


thanks in advance
Both of these errors mean you did not actually get the file in the right format. I suggest using notepad or equivalent and saving as ANSI or ASCII.

Note they should be ASCII text, NOT UTF-8. UTF-8 will probably work in most cases but some programs may put a BOM at the start which will probably confuse CHDK.


wow, i tried what you told me and it worked!!
you are a genius man, thanks a lot!

..and i don't know if you could help me out or something, and i really don't know if this has something to do with the script itself but once i'm using it it seems that i can't use the zoom or any of the other functions of the camera
thanks again!
thanks

..and i don't know if you could help me out or something, and i really don't know if this has something to do with the script itself but once i'm using it it seems that i can't use the zoom or any of the other functions of the camera
When a script is running,  CHDK intercepts all camera button presses for use by the script.  The camera firmware never knows they were pressed.  If the script does not check for button presses and do something when it happens,  then nothing happens when a button is pressed.    For example,  some scripts check if the zoom lever is pressed and move the zoom accordingly while others just ignore the zoom lever.
Ported :   A1200    SD940   G10    Powershot N    G16


..and i don't know if you could help me out or something, and i really don't know if this has something to do with the script itself but once i'm using it it seems that i can't use the zoom or any of the other functions of the camera
When a script is running,  CHDK intercepts all camera button presses for use by the script.  The camera firmware never knows they were pressed.  If the script does not check for button presses and do something when it happens,  then nothing happens when a button is pressed.    For example,  some scripts check if the zoom lever is pressed and move the zoom accordingly while others just ignore the zoom lever.

hmm I see, so there's not a way to use both the camera controls and this script in particular..
thanks man!

hmm I see, so there's not a way to use both the camera controls and this script in particular..
thanks man!
Not at all.  You just need to edit the script such that it passes the camera controls you need through to the camera. 
Ported :   A1200    SD940   G10    Powershot N    G16

*

Offline reyalp

  • ******
  • 11392
hmm I see, so there's not a way to use both the camera controls and this script in particular..
thanks man!
It's possible that you press the "alt" key after starting the script, adjust the zoom, and then press alt again to return to the script when you are done changing the zoom.

The behavior of script when you do this isn't really well defined, but I think if you are just recording video, leaving alt briefly to manipulate canon controls would probably work.

edit:
I'm guessing you are using one of the "continuous video" scripts, if you can link to the specific script you are using, we may be able to provide additional help.
« Last Edit: 29 / March / 2014, 03:05:42 by reyalp »
Don't forget what the H stands for.

 

Related Topics