Powershot N Porting Thread - page 7 - DryOS Development - CHDK Forum

Powershot N Porting Thread

  • 212 Replies
  • 59282 Views
Re: Powershot N Porting Thread
« Reply #60 on: 16 / August / 2014, 18:25:38 »
Advertisements
Okay - this version disables all task including the spy_task.  So it should just boot ( with power LED blinking ) and then let the camera run normally.
Yes that it does. The cam just boots with it on the card and the card door left open.
Thanks for that update.  I think it narrows things down to something the spytask is doing when it sets up all the stuff CHDK needs.  It looks like boot.c is okay.  I'll spend some time looking at it and if I can't find anything we will continue with the "divide and conquer" approach.

Quote
I'm sorry for the delay in this reply. I missed this post. I'm out home and office until Sunday night. I told nafraf by PM but took the N PB cam and a PC netbook for the purpose of testing it a little on evenings. So I didn't PM you. I did check the general "new posts" page of the forum on the smart phone two evenings in a row and was under the impression that this thread had been inactive until today.
"No harm, no foul" - I'm in no hurry here.   
Ported :   A1200    SD940   G10    Powershot N    G16

*

Offline koshy

  • *****
  • 1063
Re: Powershot N Porting Thread
« Reply #61 on: 16 / August / 2014, 18:29:58 »
Thanks for that update.  I think it narrows things down to something the spytask is doing when it sets up all the stuff CHDK needs.  It looks like boot.c is okay.  I'll spend some time looking at it and if I can't find anything we will continue with the "divide and conquer" approach.
Good, thanks. I'll ckeck back on the forum in 10 or 12 hours from now.
Then I could test something again and then another 10 hours later I should be back home where the same applies.
Koshy had a little ELPH which wasn't white as snow but everywhere that Koshy went the ELPH was sure to go. (actually an SD, but that detail ruins the rhyme...)

Re: Powershot N Porting Thread
« Reply #62 on: 16 / August / 2014, 21:01:27 »
Good, thanks. I'll ckeck back on the forum in 10 or 12 hours from now.
Then I could test something again and then another 10 hours later I should be back home where the same applies.
Another DISKBOOT.BIN.  This one enables the spytask but most of what it does is commented out.  On the N, it just loads a washed out version of the CHDK boot logo and then the camera runs as normal.

If you get that far,  you can press the Facebook button and enter <ALT> mode.  Except you won't notice anything other than touch reponse not working.  Press the Facebook button again to exit <ALT> mode.

Let's just see if this version does not crash.
Ported :   A1200    SD940   G10    Powershot N    G16

Re: Powershot N Porting Thread
« Reply #63 on: 17 / August / 2014, 01:46:07 »
Hi,

I think I have a similar Problem.

Powershot N hangs while booting.
But the difference is, that it worked normal before.

After Shooting about 200 photos without enabling CHDK, I opend
sd Card door and after pressing Play button the camera hangs...

I tryed everything (new Formatting of SD Card, new release of CHDK, make SD  Card bootable and not)
Nothing helped...

I definitly does not have the "Facebook" Version, I bought the Camera 2 weeks ago in Austria (Europe)
and CHDK was working at the beginning without any Problems.

It seems that something was changed in the camera itself, maybe there is a Counter for Firmware updates or another Status Byte that is checked by camera during booting.

I have read this tread multiple times an I have tryed all the attached files but no result.

What can I do to give You further Information about this issue?

Regards Andreas.


Re: Powershot N Porting Thread
« Reply #64 on: 17 / August / 2014, 03:11:02 »
Hi,

Here is the description, what my camera exactly does, when I try to activate chdk by normal firm update:
SD Card is not made bootable!
SD Card Door is closed!

After pressing ok in normal Canon mode:

Power led is flashing rapidly an then blinking three times followed by a shorter last blink.
Immediately  after that, the original startup sound is played and the original start screen is on the display.
Sometimes I can see vertical stripes on this screen in difference to normal boot. But these stripes are not always present.
Then booting hangs...
After few second camera shuts down, and normal start is always possible.

Regards, Andreas.


*

Offline srsa_4c

  • ******
  • 4416
Re: Powershot N Porting Thread
« Reply #65 on: 17 / August / 2014, 06:18:29 »
@baumandr

To help diagnosing your problem, you could do these:

- make a romlog: http://chdk.wikia.com/wiki/Canon_Basic/Scripts/Romlog
- dump your firmware: http://chdk.wikia.com/wiki/Canon_Basic/Scripts/Dumper

You'll need to use a "scriptable" SD card to be able to run scripts: http://chdk.wikia.com/wiki/Canon_Basic/Card_Setup
A quote from waterwingz:
Quote
Canon BASIC runs if you start with the playback button and immediately press the zoom ring to the left

Re: Powershot N Porting Thread
« Reply #66 on: 17 / August / 2014, 06:34:49 »
I definitly does not have the "Facebook" Version, I bought the Camera 2 weeks ago in Austria (Europe)
and CHDK was working at the beginning without any Problems.
Very curious that it would work for a while then stop.  How did you install CHDK?  I'm not sure STICK works yet so what install procedure did you follow?

It seems that something was changed in the camera itself, maybe there is a Counter for Firmware updates or another Status Byte that is checked by camera during booting.
I suppose anything is possible.  But in the process of porting the camera,  I've booted & rebooted & crashed many hundreds of times.  And everything still works normally.

Power led is flashing rapidly an then blinking three times followed by a shorter last blink.
Immediately  after that, the original startup sound is played and the original start screen is on the display.
Sometimes I can see vertical stripes on this screen in difference to normal boot. But these stripes are not always present.
Then booting hangs...
After few second camera shuts down, and normal start is always possible.
This is typically what happens when you try to load the wrong firmware version. Did you try checking that with ACID ?  http://www.zenoshrdlu.com/acid/acid.html

As a check,  I downloaded the CHDK 1.3.0 version from the autobuild and installed it.  Both the firmware update and   autoboot methods of loading CHDK work correctly for me.
Ported :   A1200    SD940   G10    Powershot N    G16

*

Offline koshy

  • *****
  • 1063
Re: Powershot N Porting Thread
« Reply #67 on: 17 / August / 2014, 06:39:47 »
Another DISKBOOT.BIN.  This one enables the spytask but most of what it does is commented out.  On the N, it just loads a washed out version of the CHDK boot logo and then the camera runs as normal.
It boots and doesn't crash. The washed out CHDK logo comes up as described.

If you get that far,  you can press the Facebook button and enter <ALT> mode.  Except you won't notice anything other than touch reponse not working.  Press the Facebook button again to exit <ALT> mode.
This I can't confirm. When I press the FB button a while after the washed out CHDK screen disapeared I get to the usual camera FW "give this camera a nickname" screen. Touch screen functions work all the time.
Koshy had a little ELPH which wasn't white as snow but everywhere that Koshy went the ELPH was sure to go. (actually an SD, but that detail ruins the rhyme...)


Re: Powershot N Porting Thread
« Reply #68 on: 17 / August / 2014, 06:58:38 »
It boots and doesn't crash. The washed out CHDK logo comes up as described.
Thanks goodness for that!  I was beginning to despair that there was some weird hardware thing that was going to take forever to find without physically having the camera.  I'll look at next steps (maybe mutiple DISKBOOT.BIN files) to continue this trial & error process of elimination.

Quote
This I can't confirm. When I press the FB button a while after the washed out CHDK screen disapeared I get to the usual camera FW "give this camera a nickname" screen. Touch screen functions work all the time.
Using that button takes just a light touch to activate CHDK.  Hold it a bit longer and you get the wifi screen.  Takes a bit of getting used too - especially as you currently have no visual feedback of when the actual click has been accepted.
Ported :   A1200    SD940   G10    Powershot N    G16

*

Offline koshy

  • *****
  • 1063
Re: Powershot N Porting Thread
« Reply #69 on: 17 / August / 2014, 07:14:12 »
Using that button takes just a light touch to activate CHDK.  Hold it a bit longer and you get the wifi screen.  Takes a bit of getting used too - especially as you currently have no visual feedback of when the actual click has been accepted.
Something else to note: When I hold the power button to boot into shooting mode directly the CHDK logo isn't washed out, I get "NO OVERRIDES", battery meter, clock, temperature and DNG: counter (Camera does not shoot DNG yet of course.) after turning the camera on.

I can short press the FB button and the wifi screen or whatever doesn't come up. Touch still stays normal.
Koshy had a little ELPH which wasn't white as snow but everywhere that Koshy went the ELPH was sure to go. (actually an SD, but that detail ruins the rhyme...)

 

Related Topics