Powershot N Porting Thread - page 10 - DryOS Development - CHDK Forum supplierdeeply

Powershot N Porting Thread

  • 212 Replies
  • 62689 Views
*

Offline koshy

  • *****
  • 1063
Re: Powershot N Porting Thread
« Reply #90 on: 19 / August / 2014, 15:41:40 »
Advertisements
Did the image & colors look correct with DCRAW ?  If so the it should just be a simple header change.
The image looked as expected although the massive geometric distortions Canon favors these days as they feel that they are easier to correct digitally than other optical distortions can be rather bewildering in a RAW capture. The colors are totally unprocessed in what I did but they also looked the way they should.

Short: change the header ;-)
Koshy had a little ELPH which wasn't white as snow but everywhere that Koshy went the ELPH was sure to go. (actually an SD, but that detail ruins the rhyme...)

Re: Powershot N Porting Thread
« Reply #91 on: 19 / August / 2014, 23:55:01 »
Did you try to enable this?
Code: [Select]
// try avoid intermittetant override failues on quick press, not needed?
//"    MOV     R0, #0\n"                          // added
//"    STR     R0, [R5,#0x28]\n"                  // added
"    LDR     R0, [R4, #0x28] \n"
But replace R5 by R4.  ::)
I think that came over from the ixus140.  I'll give it a try and at least fix the spelling.
Ported :   A1200    SD940   G10    Powershot N    G16

Re: Powershot N Porting Thread
« Reply #92 on: 20 / August / 2014, 02:46:03 »
@waterwings

Thanks for providing trial build.
Now everything works OK
No Boot problems anymore.
All the other stuft seems to work...
What exactly was the difference between my camera and all the others that cause stopp booting althow it was OK before...
Regards Andreas.

Re: Powershot N Porting Thread
« Reply #93 on: 20 / August / 2014, 03:59:49 »
Deleted...
« Last Edit: 20 / August / 2014, 04:01:51 by baumandr »


Re: Powershot N Porting Thread
« Reply #94 on: 20 / August / 2014, 07:46:48 »
What exactly was the difference between my camera and all the others that cause stopp booting althow it was OK before...
I would be interested to know whether you can now download the lastest version from the autobuild and test if it also works ?

http://mighty-hoernsche.de/trunk/
Ported :   A1200    SD940   G10    Powershot N    G16

Re: Powershot N Porting Thread
« Reply #95 on: 21 / August / 2014, 04:56:00 »
@waterwingz

I downloaded n-100a-1.3.0-3585-full_BETA.zip from
http://mighty-hoernsche.de/trunk/ and I could not successfuly
boot chdk.
It is the same error as before...

Regards,
Andreas.
« Last Edit: 21 / August / 2014, 05:12:09 by baumandr »

Re: Powershot N Porting Thread
« Reply #96 on: 21 / August / 2014, 08:21:12 »
It is the same error as before...
Thanks - that's the information I need.   Now I just need to find some time to dive into this.
Ported :   A1200    SD940   G10    Powershot N    G16

Re: Powershot N Porting Thread
« Reply #97 on: 22 / August / 2014, 20:36:07 »
Three more test cases for the Powershot N Facebook.

  • Test 4:  should fix the DNG errors when checked with Adobe utility. Also fixes the "no DNG on fast press" problem
  • Test 5 : re-enables the user custom palette (get the colors right) but with a whole lot more robust checking for un-initialized conditions
  • Test 6 : touch testing - prints some debug messages on screen. The important question is whether the "Touch state : " message toggles between Canon and CHDK when you go in and out of <ALT> mode AND touch the screen after you do that.

Test 4 should be a "slam dunk".  I have my fingers crossed for Test 5 - the signatures used match all the other touch camera ports 100% - it has to be initialized pointers.  Which could also explain why my N works and other's don't.   Test 6 won't fix anything put should help point to why the Canon f/w does not ignore touches  in <ALT> mode (I hope).
Ported :   A1200    SD940   G10    Powershot N    G16


*

Offline fe50

  • ******
  • 3132
  • IXUS50 & 860, SX10 Star WARs-Star RAWs
    • fe50
Re: Powershot N Porting Thread
« Reply #98 on: 23 / August / 2014, 05:43:26 »
Added the
  • Powershot N "Facebook ready edition" 1.00A
full 16MB dump provided by koshy from this forum post to the CHDK P&S FW dumps repository.

*

Offline koshy

  • *****
  • 1063
Re: Powershot N Porting Thread
« Reply #99 on: 23 / August / 2014, 08:21:45 »
Test 4:  should fix the DNG errors when checked with Adobe utility. Also fixes the "no DNG on fast press" problem
Works in both aspects.
Test 5 : re-enables the user custom palette (get the colors right) but with a whole lot more robust checking for un-initialized conditions
Doesn't crash. In Shooting mode colors are right while in Play mode CHDK logo (it shows in play mode when not booting directly to shooting mode) and ALT mode buttons are full White. The ALT buttons are also white when toggling from shooting mode back to play mode. Interestingly for Test 6 it works in both play and shooting mode.
Test 6 : touch testing - prints some debug messages on screen. The important question is whether the "Touch state : " message toggles between Canon and CHDK when you go in and out of <ALT> mode AND touch the screen after you do that.
Yes it toggles between Canon and CHDK when doing that. This one has the colors on CHDK logo and ALT mode buttons right no matter what mode you are in / are booting to.
Koshy had a little ELPH which wasn't white as snow but everywhere that Koshy went the ELPH was sure to go. (actually an SD, but that detail ruins the rhyme...)

 

Related Topics