Powershot N Porting Thread - page 5 - DryOS Development - CHDK Forum
supplierdeeply

Powershot N Porting Thread

  • 212 Replies
  • 58877 Views
*

Offline koshy

  • *****
  • 1063
Re: Powershot N Porting Thread
« Reply #40 on: 13 / August / 2014, 17:40:16 »
Advertisements
Then the camera crashed and was off.
Romlogs can be saved from Canon Basic too: http://chdk.wikia.com/wiki/Canon_Basic/Scripts/Romlog
Great hint. Thanks. Tried straight away but the RomLogErr.txt file contained "Log is not Saved."
Might still be useful as we go on...
Koshy had a little ELPH which wasn't white as snow but everywhere that Koshy went the ELPH was sure to go. (actually an SD, but that detail ruins the rhyme...)

Re: Powershot N Porting Thread
« Reply #41 on: 13 / August / 2014, 17:43:32 »
Great hint. Thanks. Tried straight away but the RomLogErr.txt file contained "Log is not Saved."
Might still be useful as we go on...
Agreed.  But at this point, we are not getting cleanly through boot.c so it seems like DryOS might not yet be running enough to save a file.
Ported :   A1200    SD940   G10    Powershot N    G16

Re: Powershot N Porting Thread
« Reply #42 on: 13 / August / 2014, 22:52:18 »
Try replacing the DISKBOOT.BIN file on your SD card with this one and see what happens ?
Ported :   A1200    SD940   G10    Powershot N    G16

*

Offline koshy

  • *****
  • 1063
Re: Powershot N Porting Thread
« Reply #43 on: 14 / August / 2014, 07:55:04 »
Try replacing the DISKBOOT.BIN file on your SD card with this one and see what happens?
After I get the CHDK logo the camera freezes. After some fiddling with quickly skipping the time set screen (I guess I should set the time and be done with that) I got the camera to a state before freezing that would let me obtain a ROMLOG with Canon basic as a second step. It's enclosed.
Koshy had a little ELPH which wasn't white as snow but everywhere that Koshy went the ELPH was sure to go. (actually an SD, but that detail ruins the rhyme...)


Re: Powershot N Porting Thread
« Reply #44 on: 14 / August / 2014, 08:53:43 »
Try replacing the DISKBOOT.BIN file on your SD card with this one and see what happens?
After I get the CHDK logo the camera freezes. After some fiddling with quickly skipping the time set screen (I guess I should set the time and be done with that) I got the camera to a state before freezing that would let me obtain a ROMLOG with Canon basic as a second step. It's enclosed.
Does that clock display come up if you boot without CHDK?

Have you tried starting by pressing the playback button or the WiFi button? I would not expect them to work any better but would be curious to know of they are different than pressing the power button to start?
Ported :   A1200    SD940   G10    Powershot N    G16

*

Offline koshy

  • *****
  • 1063
Re: Powershot N Porting Thread
« Reply #45 on: 14 / August / 2014, 09:32:13 »
Does that clock display come up if you boot without CHDK?
Yes. I just never set the clock thus far ;-) I'll set it and we'll see what happens.
Koshy had a little ELPH which wasn't white as snow but everywhere that Koshy went the ELPH was sure to go. (actually an SD, but that detail ruins the rhyme...)

*

Offline koshy

  • *****
  • 1063
Re: Powershot N Porting Thread
« Reply #46 on: 14 / August / 2014, 10:26:51 »
O.k. I set the clock and since then no matter which route I use to turn on the camera I get to play mode's screen saying no image and the camera is frozen. Once I got to see the CHDK logo but on all other tries not. The attempt to get ROMLOG with Canon basic still produces the one I sent before, so no new data was saved.
Koshy had a little ELPH which wasn't white as snow but everywhere that Koshy went the ELPH was sure to go. (actually an SD, but that detail ruins the rhyme...)

Re: Powershot N Porting Thread
« Reply #47 on: 14 / August / 2014, 12:07:33 »
Try taking a picture  without loading CHDK so that there is one on the SD card? 

I spent time last night trying to reproduce the "digital clock"" error- not having realized that you had not set it up in the first place. Not all bad as it led me to fix the power-up button code in both cameras. But now that I know that was unrelated to the crash I'll look at different things tonight.
Ported :   A1200    SD940   G10    Powershot N    G16


*

Offline koshy

  • *****
  • 1063
Re: Powershot N Porting Thread
« Reply #48 on: 14 / August / 2014, 12:34:43 »
Try taking a picture  without loading CHDK so that there is one on the SD card?
I took a few. Then with CHDK the image is displayed and the camera freezes. That is after short press of power button, press of play or press of FB button to power up the cam.

If I hold down the power button longer it boots through into shooting mode. Live view is there for half a second or a second then the cam freezes.

Still no new ROMLOG to be obtained.

I spent time last night trying to reproduce the "digital clock"" error- not having realized that you had not set it up in the first place. Not all bad as it led me to fix the power-up button code in both cameras. But now that I know that was unrelated to the crash I'll look at different things tonight.
Sorry for that. The explaination is I think that the clock set screen in itself worked. After leavin it I got the same crash /freeze I get now. In some situation that lead to the ROMLOG I shared.
Koshy had a little ELPH which wasn't white as snow but everywhere that Koshy went the ELPH was sure to go. (actually an SD, but that detail ruins the rhyme...)

Re: Powershot N Porting Thread
« Reply #49 on: 14 / August / 2014, 13:17:49 »
I have a pretty good idea where to look next.
Ported :   A1200    SD940   G10    Powershot N    G16

 

Related Topics