Powershot s3is not responding - General Help and Assistance on using CHDK stable releases - CHDK Forum
supplierdeeply

Powershot s3is not responding

  • 4 Replies
  • 1610 Views
Powershot s3is not responding
« on: 04 / May / 2014, 13:43:58 »
Advertisements
I downloaded CHDK for my camera (proper version etc) and decided to try it. It was going to be my first timelapse with CDHK. For testing I used my smallest SD card (512Mb) - I wanted to shoot about 400 small resolution photos. I set my camera and started shooting. When I checked it after few minutes there were about 50 photos taken, but it seems I had RAW option on and there was already not enough space on my SD card. When camera ran out of free space on SD card - it went black and is not responding to this moment. Screen is black, there's orange light next to my on/off button. I can't turn camera off - "off" button is not responding. Actually camera does not respond to any button. I can't open battery... "chamber" (I don't know how it's called in English) and I have no idea what to do next - how to reset or turn it off.

Any help would be greatly appreciated.

*

Offline srsa_4c

  • ******
  • 4302
Re: Powershot s3is not responding
« Reply #1 on: 04 / May / 2014, 13:57:04 »
I can't turn camera off - "off" button is not responding. Actually camera does not respond to any button.
That's rather strange, this camera has 2 independent processors, if the main one (which runs CHDK) crashes, the small one should be able to restart or shut down the camera automatically.
Quote
I can't open battery... "chamber" (I don't know how it's called in English)
I don't understand why, is the door blocked?
Quote
and I have no idea what to do next - how to reset or turn it off.
You can interrupt the battery power if you plug in the external power supply plug. You can also use a toothpick or a similar non-metal object to poke into that external power socket.

Re: Powershot s3is not responding
« Reply #2 on: 04 / May / 2014, 14:10:31 »
Oh my God... I'm so dumb (and maybe panicked a bit because it's the first time this happened to me). First of all - my camera is quite old. And sometimes it's not so easy to open this battery cover. When camera stopped responding it was one of the first things I tried to do - open battery cover and "reset" the camera. When I pushed this little slider camera started to beep and probably cover was stuck again (as it does from time to time) and I assumed it has some kind of a block preventing users from opening it when camera is on.

When you wrote "I don't understand" I immediately realised there's no such block and opened it. Camera turned off and now is working again.

Thanks for your reply - right now I know what may happen and how to fix it so next time I probably won't panic ;) And I'm going to buy at least 8Gb card tomorrow so I won't have any problems with no SD card space anymore. 

Re: Powershot s3is not responding
« Reply #3 on: 04 / May / 2014, 14:25:29 »
And I'm going to buy at least 8Gb card tomorrow so I won't have any problems with no SD card space anymore.
FYI - the s3is will need the SD card setup with a dual partition for cards larger than 4G.  There are many ways to do this (Prepare_your_SD_card ) but the STICK utility is probably the easiest.
Ported :   A1200    SD940   G10    Powershot N    G16


Re: Powershot s3is not responding
« Reply #4 on: 04 / May / 2014, 14:29:18 »
Oh, good to know.

 

Related Topics