Memory card error - SX160 IS, 16 GB card bootable - General Help and Assistance on using CHDK stable releases - CHDK Forum

Memory card error - SX160 IS, 16 GB card bootable

  • 10 Replies
  • 4604 Views
Memory card error - SX160 IS, 16 GB card bootable
« on: 05 / May / 2014, 23:43:37 »
Advertisements
Hi!
I just purchased a new camera, the SX160 IS (CHDK was one of the most important factors to choose it, as a previous A710IS+CHDK happy owner).
First thing was to load CHDK on my 16GB memory card to start playing with the camera, however, after making the card bootable, locking it and powering on the camera, a "Memory card locked" message appears briefly (along with the CHDK logo) and then a "Memory card error" appears on the screen.
I'm able to enter the CHDK menus normally but I can't take pictures. I also can't format the card and CHDK shows 0 MB free.
If I don't lock the card and load CHDK using the firmware upgrade method, everything is OK, however I really want to load CHDK at camera startup.

I have tried with a 2 GB card and CHDK loads at boots flawlessly.

That's what I have tried so far after reviewing several related  posts at the forum:
  • Format the card (FAT32 quick and then complete) on windows, copy the CHDK stable and make it bootable using SICK 1.09, safe eject, lock it, power on (power button and play button).
  • Format the card (quick and low level) on the camera,  copy the CHDK stable and make it bootable using STICK 1.09, safe eject,  lock it, power on(power button and play button).
  • Format the card (quick and low level) an the camera,  copy the CHDK develop and make it bootable using STICK 1.09, safe eject, lock it, power on (power button and play button).
  • Zeroed the card using Minitool Partition Wizard, low level format the card on the camera, copy the CHDK stable and make it bootable using SICK 1.09, safe eject, lock it, power on (power button and play button).
  • Low level format the card on the camera, copy CHDK and make the card bootable using WICKS 1.05 (single partition FAT32), safe eject, lock it, power on (power button and play button).
  • Wipe again the card using Minitool PW, create a 4 GB FAT16 partition, copy CHDK and make the card bootable using WICKS 1.05, lock it, safe eject, lock it, power on (power button and play button).
  • Wipe card, low level format on camera, manually copy latest stable autobuild (sx160is-100a-1.2.0-3428-full_BETA), load CHKD using firmware upgrade method, make card bootable using CHDK, power off, lock the card, power on (power button and play button).
  • Wipe card, create a 2 GB FAT16 partition using Minitool PW,  manually copy latest stable autobuild (sx160is-100a-1.2.0-3428-full_BETA), load CHKD using firmware upgrade method, make card bootable using CHDK, power off, lock the card, power on.

Camera: Canon SX160 IS
Firmware: 100a
CHDK Ver: 1.2.0 rev 3428 and 1.3.0 rev 3435.
Card: 16 GB, SD HC, Class 10, Verbatim Premium and 2GB Kingston SD/2GB

Do I miss something? Could be a bug?

Thanks!
« Last Edit: 06 / May / 2014, 22:12:20 by ectatomma »

Re: Memory card error - SX160 IS, 16 GB card bootable
« Reply #1 on: 06 / May / 2014, 00:22:49 »
Do I miss something? Could be a bug?
Well,  it seems that you've certainly tried almost every possible way to get the 16G card to boot. 

Yet it will work with the "firmware update" method.  And a 2G card boots properly.

Seems unlikely that it is a bug. 

My guess, based on what you've said, is some hardware issue with the SD card.  I know this is not what you want to hear, but if you've really used STICK to format the card, download the appropriate package, install that package, and eject the card then that would seem to be the only option.

Update : As far as hardware errors possible - reading your description makes it sound like maybe the SD card lock tab is not working properly with the SD card slot in your camera.

« Last Edit: 06 / May / 2014, 00:25:17 by waterwingz »
Ported :   A1200    SD940   G10    Powershot N    G16

Re: Memory card error - SX160 IS, 16 GB card bootable
« Reply #2 on: 06 / May / 2014, 08:22:43 »
Thanks waterwingz for your reply!

Quote
I know this is not what you want to hear
Not a big deal, I'll find (or purchase) a new 16GB (or more) card an will post the results.

Quote
maybe the SD card lock tab is not working properly with the SD card slot in your camera
I just raised a little bit the tap sticking tape to it (just cut some masking tape the same size of the tap and tried with 1, 2 an 3 layers). Same result (memory card error).

Also tried with the card locked without CHDK installed on it (unlock the card, low lever format it, lock it again, power up the camera). I had just a normal "Memory card locked" message , no "memory card error" message .

Anyway, I'll test with another card.

*

Offline nafraf

  • *****
  • 1305
Re: Memory card error - SX160 IS, 16 GB card bootable
« Reply #3 on: 06 / May / 2014, 08:40:51 »
The same error was reported by a diybookscanner user, and I reproduced the error using a 4G SD-Card.


Re: Memory card error - SX160 IS, 16 GB card bootable
« Reply #4 on: 06 / May / 2014, 09:37:14 »
The same error was reported by a diybookscanner user, and I reproduced the error using a 4G SD-Card.
Hmmm ... some sort of race condition made worse by larger cards?  Possibly happening before the code in boot.c captures the keyboard task and masks the card lock switch bit?
Ported :   A1200    SD940   G10    Powershot N    G16

Re: Memory card error - SX160 IS, 16 GB card bootable
« Reply #5 on: 06 / May / 2014, 23:11:22 »
That also could explains why the"Memory card locked" message appears a little bit before and when the CHDK logo is displayed.

Please, let me know about any test needed, I'm willingly to collaborate in solving this issue.

Re: Memory card error - SX160 IS, 16 GB card bootable
« Reply #6 on: 07 / May / 2014, 23:38:01 »
OK, I borrowed from a friend an 8GB Panasonic Class 10 card and it worked fine. No "memory card error" nor "memory card locked"  messages.

I low level formatted the card on the camera and installed CHDK using STICK for the test. Tried both, stable and develop releases.

I'm anyway will try to find a 16 GB card to do more testing.

Re: Memory card error - SX160 IS, 16 GB card bootable
« Reply #7 on: 10 / May / 2014, 21:52:17 »
Well, I purchased 16 GB Kingston card (SD10W/16GB), installed CHDK using STICK without reformatting the card (using the factory format that came with the card), locked it and CHDK loaded at boot perfectly fine.

Looks like there is a compatibility problem of CHDK boot routine with certain cards and cameras (apart the "memory card error", the 16 GB Verbatim card worked perfectly fine). Bummer.



Re: Memory card error - SX160 IS, 16 GB card bootable
« Reply #8 on: 10 / May / 2014, 22:24:09 »
Looks like there is a compatibility problem of CHDK boot routine with certain cards and cameras.
That's possible.  I guess it's also possible that some 16G Verbatim cards have their own problems?  Bootleg SD cards are also a common issue unfortunately.  Probably we will have to wait and see how often this occurs.
Ported :   A1200    SD940   G10    Powershot N    G16

Re: Memory card error - SX160 IS, 16 GB card bootable
« Reply #9 on: 10 / May / 2014, 23:29:34 »
Could be a particular problem of this 16 GB Verbatim card,  however I have successfully used this very same card loading CHDK at boot with an A710 IS  (two partitions using WICKS, by the end of 2012). The card was purchased in a big and well renowned store, particularly to avoid bootleg products.
Just to be sure I created a file to fill the whole card using dd reading from the random input, then read the file back again with dd to the null output to test the card for errors or fake capacity. No problems arisen. Anyway, as waterwingz said,  lets see how often the problem occurs.
« Last Edit: 02 / June / 2014, 10:23:37 by ectatomma »

 

Related Topics