A800 Stops as if power unplugged with Ultimate Intervalometer - page 2 - General Help and Assistance on using CHDK stable releases - CHDK Forum

A800 Stops as if power unplugged with Ultimate Intervalometer

  • 33 Replies
  • 6115 Views
Re: A800 Stops as if power unplugged with Ultimate Intervalometer
« Reply #10 on: 13 / May / 2014, 05:46:03 »
Advertisements
Thank you guys. I am going to test each method carefully for a couple of days each and will report back with the results.

Many thanks for your time and assistance.

Re: A800 Stops as if power unplugged with Ultimate Intervalometer
« Reply #11 on: 15 / May / 2014, 17:17:34 »
I have extensively tested the test version from Reyalp and the loader from Waterwingz. The results i obtained were mostly identical with the original version and loading method where the camera appears to lose power after zooming and just at the point of focusing.

I have tried to emulate this problem with several other cameras and i can repeatedly replicate this phenomenon on two A1200's when using cheap non branded batteries.

It appears to be some kind of power issue where the internal voltage drops below a workable level and the camera simply shuts down instantly.

I have tried to replicate this without running a script, ie set a zoom, then 1/2 press to get focus but cannot manually replicate. I think the speed that i am able to perform the tasks if far inferior to the script.

I am thinking that the A800 is possibly so cut down that its own internal circuitry is barely adequate to run the camera and it does not take too much too soon, to just overload it...... Does still seem like it may be a memory issue but i am tending towards power.

I think i will repeat these tests tomorrow with an external display attached so i have no on camera live view (lcd and backlight) ti reduce the on-board power consumption. If this reduces the incidence rate of the problem then its most likely power related and it may be time to data log the voltage and current draws on this camera. (the Digital readout from my bench PSU is probably not fast acting enough to show any spikes).

Unfortunately on this camera you have to use a dummy battery to use external power as it does not have a DC in Jack which may be why the problem exists with both AC adapter or Batteries, and may point to the internal wiring or poorly made connections. (Hmmm, the A1200's use the same dummy battery method...)

Re: A800 Stops as if power unplugged with Ultimate Intervalometer
« Reply #12 on: 15 / May / 2014, 22:05:04 »
I have tried to emulate this problem with several other cameras and i can repeatedly replicate this phenomenon on two A1200's when using cheap non branded batteries.
I have two A1200's as well.  Most of the Ultimate Intervalometer script was built & tested (100's of times) on those using elcheapo NiCad rechargeable batteries. FWIW, I didn't see any shutdown issues until the batteries were good & ready for a recharge cycle.

Quote
I have tried to replicate this without running a script, ie set a zoom, then 1/2 press to get focus but cannot manually replicate. I think the speed that i am able to perform the tasks if far inferior to the script.
Should be pretty easy to write a short script that removes all the complexity of the Ultimate Intervalometer to test this out then.   I'd like to validate that this is not an issue with the actual script.

Ported :   A1200    SD940   G10    Powershot N    G16

Re: A800 Stops as if power unplugged with Ultimate Intervalometer
« Reply #13 on: 16 / May / 2014, 07:48:38 »
Anything i can do to help with this, i would like to assist.

Can offer to test on A470, A800, A1200, A1300, A2300, A2400 and A4000 at present, my others are out in the field working away.


*

Offline reyalp

  • ******
  • 12202
Re: A800 Stops as if power unplugged with Ultimate Intervalometer
« Reply #14 on: 16 / May / 2014, 17:41:20 »
I have extensively tested the test version from Reyalp and the loader from Waterwingz. The results i obtained were mostly identical with the original version and loading method where the camera appears to lose power after zooming and just at the point of focusing.

I have tried to emulate this problem with several other cameras and i can repeatedly replicate this phenomenon on two A1200's when using cheap non branded batteries.

It appears to be some kind of power issue where the internal voltage drops below a workable level and the camera simply shuts down instantly.
This seems plausible to me. Zooming would draw extra current which could cause the battery to sag.

Most software issues (like running out of memory) should usually generate a ROMLOG.

FWIW some of the old AA cameras had problems with the battery contacts, where they would either get corroded or compressed to the point where they no longer make good contact. This resulted in short battery life even when the batteries were good, but would also make voltage sag worse.
Don't forget what the H stands for.

Re: A800 Stops as if power unplugged with Ultimate Intervalometer
« Reply #15 on: 17 / May / 2014, 06:50:53 »
Reyalp, i have just been looking under a 25x magnifier at the battery compartment contacts and the design does indeed lend itself to corrosion and poor contact. The contact points are approx 1mm wide at the widest point and are indented into the tin plated conductors from the rear forming a point, so the tin plate wears through real quick and you then have a thin oxidised layer giving the effect of used batteries due to voltage drop by reducing the current capacity.

Its a pity, but the dummy batteries for the external psu are of similar design. I may think about a mod with 3.5mm plug to bypass the battery compartment, should verify if this is the problem.

The A1200's are of the same design which is why i could probably replicate so easily. All my other cameras either use a 3.5mm power jack or use a dummy battery of the li-ion type so a completely different design.

I will post if i find a definite solution.

Re: A800 Stops as if power unplugged with Ultimate Intervalometer
« Reply #16 on: 17 / May / 2014, 08:18:24 »
Small correction by the way.

I was able to replicate using two A1300's not a1200's as previously stated.

Re: A800 Stops as if power unplugged with Ultimate Intervalometer
« Reply #17 on: 18 / May / 2014, 07:50:03 »
Well its taken some time, but i have managed to get a Romlog as the camera halted this time without powering off. Zoom was set to zero this time.

I have listed it below in the hope that it sheds some light on the problem. I have to confess that i personally cannot find anything useful but then i don't really understand it yet.

ASSERT!! DriverIC.c Line 48
Occured Time  2014:05:13 10:06:07
Task ID: 8716305
Task name: Nd
SP: 0x00280350
StackDump:
0x00000000
0xFFE06590
0x00000030
0x00000001
0x00000105
0x000061A8
0x0000010E
0x19980218
0x19980218
0x19980218
0x19980218
0xFFE06398
0x00008E08
0xFFE074E0
0x002725D0
0x19980218
0x19980218
0x19980218
0x19980218
0xFFC0717C
0x19980218
0x19980218
0x00000808
ShootConDump:
0f 0f 0f 0f 0f 0f 0f 0f 0f 0f
CameraConDump:
07 0a 02 0d 09 01 0f 0f 0f 0f
00018550: UI:ScreenUnLock
00018610: UI:AC:TstEVF:Ok
00018610: SS:ImgSys
00018610: SS:ToRec
00018610: SS:Lens1stP
00018620: SS:   Evf=1
00018620: M:FIRST_S
00018620: M:SH_OPN_S
00018630: M:SH_OPN_E
00018630: M:ND_OFF_S
00018640: M:ND_OFF_E
00018640: M:ZM_RST_S
00018710: SS:InitPTM
00018710: SS:   0053->8004
00018710: SS:   Asp 0001->0001
00018710: SS:ImgSys
00018710: UI:LogicalEvent:0x5004:adr:0,Para:0
00018710: UI:DisplayPhysicalScreenCBR
00018710: UI:DisplayPhysicalScreenCBR
00018710: UI:AC:ShwCaptI
00018710: UI:DSIC:53,0
00018710: UI:ScreenLock
00018710: UI:DSIC:49,1
00018720: UI:Display_CaptInfo
00018730: UI:DSIC:d4,0
00018750: UI:AC:DispSht
00018750: UI:DSIC:8c,0
00018830: M:ZM_RST
00018870: M:FC_RST_S
00019020: M:FC_RST_E
00019020: M:FC_STB_S
00019240: M:ZM_RST_E
00019270: M:FC_STB_E
00019270: M:FIRST_E
00019840: UI:ShootSeqToUI:0x202e:adr:0x3cb8,Para:15544
00019840: UI:ShootSeqToUI:0x201d:adr:0,Para:0
00019840: UI:DispSwCon_TurnOnBackLight
00019840: UI:DispSwCon_MuteOffPhysicalScreen
00019850: UI:AC:SUpShowI
00019850: UI:DSIC:54,0
00019850: UI:ScreenUnLock
00019900: UI:DSIC:53,0
00019900: UI:ScreenLock
00019900: UI:AC:EnryRecBt
00019900: UI:StartRecMode
00019900: UI:DispSwCon_MuteOffPhysicalScreen
00019900: UI:LogicalEvent:0x3110:adr:0,Para:0
00019900: UI:DispSwCon_TurnOnDisplayDevice
00019900: UI:UI_StrobeCon_Start
00019920: UI:LogicalEvent:0x3135:adr:0,Para:0
00019920: UI:_ManagePTMProperty
00019970: SS:ModChg
00019970: SS:   Evf=0
00019970: SS:   0053->8004
00019970: SS:   Asp 0001->0001
00019970: SS:ModChg*
00019970: UI:_DecideCaptureMode
00019970: UI:_StartStill
00019980: UI:DSIC:42,6
00019990: UI:DSIC:25,0
00020000: UI:ScreenUnLock
00020050: UI:TerminateDeliverToZoomController
00020050: UI:ScreenLock
00020060: UI:ScreenUnLock
00020100: UI:OPTICAL_ZOOM_POS
00020100: UI:UnpressZoomLever
00020100: UI:DispSwCon_TurnOnDisplayDevice
00020110: UI:LogicalEvent:0x313d:adr:0,Para:0
00020110: UI:_EnrySRec
00020110: UI:CaptModeChanger_CheckRTCRrepared
00020110: UI:DispSw: Unlock
00020110: UI:DispSwCon_MuteOffPhysicalScreen
00020110: UI:Window MuteOff
00020110: UI:MuteOffPhysicalScreen
00020110: UI:DisplayPhysicalScreenCBR
00020120: UI:DisplayPhysicalScreenCBR
00020120: UI:_DecideModeDial
00020120: UI:DSIC:14,0
00020120: UI:No Change Capture Mode
00020120: UI:LogiEvnt_NotPowerType:0x09a4:adr:0,Para:0
00020120: UI:LogiEvnt_NotPowerType:0x09a2:adr:0,Para:0
00020120: UI:DisplayPhysicalScreenCBR
00021560: UI:DSIC:58,0
00021600: UI:ScreenLock
00021600: UI:ScreenUnLock
00021660: UI:DisplayPhysicalScreenCBR
   


Re: A800 Stops as if power unplugged with Ultimate Intervalometer
« Reply #18 on: 18 / May / 2014, 08:00:36 »
Its getting more interesting now, if i set the zoom to 3 and the camera crashes just after setting the zoom level, i can now save the Romlog.
listed below

ASSERT!! DriverIC.c Line 48
Occured Time  2014:05:13 10:06:07
Task ID: 8716305
Task name: Nd
SP: 0x00280350
StackDump:
0x00000000
0xFFE06590
0x00000030
0x00000001
0x00000105
0x000061A8
0x0000010E
0x19980218
0x19980218
0x19980218
0x19980218
0xFFE06398
0x00008E08
0xFFE074E0
0x002725D0
0x19980218
0x19980218
0x19980218
0x19980218
0xFFC0717C
0x19980218
0x19980218
0x00000808
ShootConDump:
0f 0f 0f 0f 0f 0f 0f 0f 0f 0f
CameraConDump:
07 0a 02 0d 09 01 0f 0f 0f 0f
00018550: UI:ScreenUnLock
00018610: UI:AC:TstEVF:Ok
00018610: SS:ImgSys
00018610: SS:ToRec
00018610: SS:Lens1stP
00018620: SS:   Evf=1
00018620: M:FIRST_S
00018620: M:SH_OPN_S
00018630: M:SH_OPN_E
00018630: M:ND_OFF_S
00018640: M:ND_OFF_E
00018640: M:ZM_RST_S
00018710: SS:InitPTM
00018710: SS:   0053->8004
00018710: SS:   Asp 0001->0001
00018710: SS:ImgSys
00018710: UI:LogicalEvent:0x5004:adr:0,Para:0
00018710: UI:DisplayPhysicalScreenCBR
00018710: UI:DisplayPhysicalScreenCBR
00018710: UI:AC:ShwCaptI
00018710: UI:DSIC:53,0
00018710: UI:ScreenLock
00018710: UI:DSIC:49,1
00018720: UI:Display_CaptInfo
00018730: UI:DSIC:d4,0
00018750: UI:AC:DispSht
00018750: UI:DSIC:8c,0
00018830: M:ZM_RST
00018870: M:FC_RST_S
00019020: M:FC_RST_E
00019020: M:FC_STB_S
00019240: M:ZM_RST_E
00019270: M:FC_STB_E
00019270: M:FIRST_E
00019840: UI:ShootSeqToUI:0x202e:adr:0x3cb8,Para:15544
00019840: UI:ShootSeqToUI:0x201d:adr:0,Para:0
00019840: UI:DispSwCon_TurnOnBackLight
00019840: UI:DispSwCon_MuteOffPhysicalScreen
00019850: UI:AC:SUpShowI
00019850: UI:DSIC:54,0
00019850: UI:ScreenUnLock
00019900: UI:DSIC:53,0
00019900: UI:ScreenLock
00019900: UI:AC:EnryRecBt
00019900: UI:StartRecMode
00019900: UI:DispSwCon_MuteOffPhysicalScreen
00019900: UI:LogicalEvent:0x3110:adr:0,Para:0
00019900: UI:DispSwCon_TurnOnDisplayDevice
00019900: UI:UI_StrobeCon_Start
00019920: UI:LogicalEvent:0x3135:adr:0,Para:0
00019920: UI:_ManagePTMProperty
00019970: SS:ModChg
00019970: SS:   Evf=0
00019970: SS:   0053->8004
00019970: SS:   Asp 0001->0001
00019970: SS:ModChg*
00019970: UI:_DecideCaptureMode
00019970: UI:_StartStill
00019980: UI:DSIC:42,6
00019990: UI:DSIC:25,0
00020000: UI:ScreenUnLock
00020050: UI:TerminateDeliverToZoomController
00020050: UI:ScreenLock
00020060: UI:ScreenUnLock
00020100: UI:OPTICAL_ZOOM_POS
00020100: UI:UnpressZoomLever
00020100: UI:DispSwCon_TurnOnDisplayDevice
00020110: UI:LogicalEvent:0x313d:adr:0,Para:0
00020110: UI:_EnrySRec
00020110: UI:CaptModeChanger_CheckRTCRrepared
00020110: UI:DispSw: Unlock
00020110: UI:DispSwCon_MuteOffPhysicalScreen
00020110: UI:Window MuteOff
00020110: UI:MuteOffPhysicalScreen
00020110: UI:DisplayPhysicalScreenCBR
00020120: UI:DisplayPhysicalScreenCBR
00020120: UI:_DecideModeDial
00020120: UI:DSIC:14,0
00020120: UI:No Change Capture Mode
00020120: UI:LogiEvnt_NotPowerType:0x09a4:adr:0,Para:0
00020120: UI:LogiEvnt_NotPowerType:0x09a2:adr:0,Para:0
00020120: UI:DisplayPhysicalScreenCBR
00021560: UI:DSIC:58,0
00021600: UI:ScreenLock
00021600: UI:ScreenUnLock
00021660: UI:DisplayPhysicalScreenCBR
   


Re: A800 Stops as if power unplugged with Ultimate Intervalometer
« Reply #19 on: 18 / May / 2014, 08:58:52 »
I did a quick scroll through this thread but did not see the version of CHDK you are using.  It would be good to know the release number & version ( e.g.  1.3.0 or 1.2.0,   release 3343 ).


Ported :   A1200    SD940   G10    Powershot N    G16

 

Related Topics