A800 Stops as if power unplugged with Ultimate Intervalometer - page 4 - General Help and Assistance on using CHDK stable releases - CHDK Forum  

A800 Stops as if power unplugged with Ultimate Intervalometer

  • 33 Replies
  • 6466 Views
*

Offline nafraf

  • *****
  • 1308
Re: A800 Stops as if power unplugged with Ultimate Intervalometer
« Reply #30 on: 18 / May / 2014, 15:15:43 »
Advertisements
zoom crash was reported before, but definitions were not modified. http://chdk.setepontos.com/index.php?topic=7409.msg91826#msg91826
Please test version in attachment.

Re: A800 Stops as if power unplugged with Ultimate Intervalometer
« Reply #31 on: 18 / May / 2014, 15:37:04 »
zoom crash was reported before, but definitions were not modified. http://chdk.setepontos.com/index.php?topic=7409.msg91826#msg91826
Please test version in attachment.
Ouch - missed that and it was my own post.  How did you decide which of the three #defines to use?
Ported :   A1200    SD940   G10    Powershot N    G16

*

Offline nafraf

  • *****
  • 1308
Re: A800 Stops as if power unplugged with Ultimate Intervalometer
« Reply #32 on: 18 / May / 2014, 16:04:41 »
I enabled three options, they were required by A810.
I think that it is possible to divide the problem in two and check if they are required:

in platform/generic/wrappers.c:
CAM_USE_ALT_PT_MoveOpticalZoomAt is used to correct lens distortion.
CAM_USE_ALT_PT_MoveOpticalZoomAt depends on CAM_USE_ALT_SET_ZOOM_POINT

In core/gui_osd.c
CAM_USE_OPTICAL_MAX_ZOOM_STATUS is used to fix bug related to change between optical and digital zoom.
Code: [Select]
#if defined(CAM_USE_OPTICAL_MAX_ZOOM_STATUS)
            if (x==0) zoom_status=ZOOM_OPTICAL_MAX; //ERR99: No zoom back from digital to optical zoom possible if set to medium
#else
            if (x==0) zoom_status=ZOOM_OPTICAL_MEDIUM;
#endif

Edit:
This was included too, probably the first to be tested :
#define CAM_NEED_SET_ZOOM_DELAY          300
core/shooting.c
Code: [Select]
void shooting_set_zoom(int v)
{
    int dist;
    if (!camera_info.state.mode_play)
    {
        dist = shooting_get_subject_distance();
        lens_set_zoom_point(v);
#if defined(CAM_NEED_SET_ZOOM_DELAY)
        msleep(CAM_NEED_SET_ZOOM_DELAY);
#endif
        shooting_set_focus(dist, SET_NOW);
    }
}

« Last Edit: 18 / May / 2014, 16:12:57 by nafraf »

Re: A800 Stops as if power unplugged with Ultimate Intervalometer
« Reply #33 on: 19 / May / 2014, 02:50:13 »
Hi, thanks for the responses,
I can report that under A800-100c-1.3.0.3443 the Zoomer2.lua has been working for 30 Minutes without error, i stopped at that point as things were getting a bit warm.

I have now set  running Ultimate Intervalometer with the same script settings that were giving issues before and so far so good. (previously i was getting a total shutdown if setting a zoom level above 0). I will leave this script running overnight to see if the original problem recurs and report back.

I read through the post that was linked above regarding Zoom Crash, and i noticed a spreadsheet which suggested that the A800 and A1300 cameras require info from tests to be submitted. If this is still the case, i have A800 and 2A1300 that i can put to test if still required.

Best regards


 

Related Topics