SX600HS porting thread - page 2 - DryOS Development - CHDK Forum

SX600HS porting thread

  • 55 Replies
  • 19047 Views
Re: SX600HS porting thread
« Reply #10 on: 29 / April / 2023, 12:35:45 »
Advertisements
Oh yay :)
Loading it with the "firmware update" approach makes the screen go blank (no CHDK logo shows up), and the buttons stop working until battery is cycled.

BTW, the included readme file says that the porting thread is https://chdk.setepontos.com/index.php?topic=11597.0, but that seems to be some IXUS thread. Would it be better to continue it here or perhaps in https://chdk.setepontos.com/index.php?topic=12876.0 ?

*

Offline blackhole

  • *****
  • 942
  • A590IS 101b
    • Planetary astrophotography
Re: SX600HS porting thread
« Reply #11 on: 29 / April / 2023, 13:34:30 »
Oh yay :)
Loading it with the "firmware update" approach makes the screen go blank (no CHDK logo shows up), and the buttons stop working until battery is cycled.

BTW, the included readme file says that the porting thread is https://chdk.setepontos.com/index.php?topic=11597.0, but that seems to be some IXUS thread. Would it be better to continue it here or perhaps in https://chdk.setepontos.com/index.php?topic=12876.0 ?

New test build.
We continue here, this is the right thread .
Be sure to erase everything from the SD card so you don't mix up different test versions.

EDIT:test build removed
« Last Edit: 29 / April / 2023, 16:53:06 by blackhole »

Re: SX600HS porting thread
« Reply #12 on: 29 / April / 2023, 13:46:15 »
Thanks, this time the screen goes blank, no CHDK logo - but the buttons now work. No sign of CHDK in camera.

*

Offline blackhole

  • *****
  • 942
  • A590IS 101b
    • Planetary astrophotography
Re: SX600HS porting thread
« Reply #13 on: 29 / April / 2023, 13:56:07 »
Thanks, this time the screen goes blank, no CHDK logo - but the buttons now work. No sign of CHDK in camera.
OK, I need to check boot.c
Are normal camera functions working?


*

Offline blackhole

  • *****
  • 942
  • A590IS 101b
    • Planetary astrophotography
Re: SX600HS porting thread
« Reply #14 on: 29 / April / 2023, 16:53:46 »
I found a few typos.
New test3 build attached.
Can you try the bootable sd card method to load the chdk?
https://chdk.fandom.com/wiki/Prepare_your_SD_card#Bootable_SD_Card_Method

Re: SX600HS porting thread
« Reply #15 on: 30 / April / 2023, 03:11:41 »
Oh yay, this one flashes the CHDK screen and goes in CHDK mode :)
One weird thing - camera seems to shoot in black/white only in the "Program" mode.
Any other tests that would be useful to perform?

I might be able to test the bootable method some time early next week.

*

Offline blackhole

  • *****
  • 942
  • A590IS 101b
    • Planetary astrophotography
Re: SX600HS porting thread
« Reply #16 on: 30 / April / 2023, 04:18:16 »
Oh yay, this one flashes the CHDK screen and goes in CHDK mode :)
OK, that's good news.
Quote
One weird thing - camera seems to shoot in black/white only in the "Program" mode.
I don't think it's chdk related.
Can you capture black/white images in other modes than Program mode if chdk is not loaded?
Quote
Any other tests that would be useful to perform?
Here you can find the usual tests that need to be done for a new port.
https://chdk.fandom.com/wiki/Testing
Quote
I might be able to test the bootable method some time early next week.
You can make the card bootable in the following way:
1. Format the SD card as FAT32 using the card reader and PC
2. Copy all the necessary files to the SD card
3. Insert the unlocked card into the camera and turn it on by pressing the PLAY button
4. Load the CHDK using the firmware update method
5. Go to: Miscellaneous stuff >> SD card >> Make card bootable
6. Remove the SD card from the camera, move the slider on the card to the "LOCKED" position, insert it into your camera, and power up

*

Offline blackhole

  • *****
  • 942
  • A590IS 101b
    • Planetary astrophotography
Re: SX600HS porting thread
« Reply #17 on: 01 / May / 2023, 10:22:21 »
Test build for cameras with 100f firmware version.


*

Offline Caefix

  • *****
  • 946
  • Sorry, busy deleting test shots...
Re: SX600HS porting thread
« Reply #18 on: 01 / May / 2023, 12:33:39 »
Test build for cameras with 100f firmware version.
:D ...
 :blink: Default.lua --> dutch
 :-X spooky zoom_keys: tboxtest.lua z_in is z_in+z_out, moving cursor left and right (releasing z_in=z_out).
 z_out moves lens, not cursor.
All lifetime is a loan from eternity.

*

Offline blackhole

  • *****
  • 942
  • A590IS 101b
    • Planetary astrophotography
Re: SX600HS porting thread
« Reply #19 on: 01 / May / 2023, 13:18:32 »
:D ...
 :blink: Default.lua --> dutch
That's irrelevant, the camera probably needs a new propset just like the sx410, we talked about it here: https://chdk.setepontos.com/index.php?topic=13133.0
Quote
:-X spooky zoom_keys: tboxtest.lua z_in is z_in+z_out, moving cursor left and right (releasing z_in=z_out).
 z_out moves lens, not cursor.
The ZOOM keys are not in the keymap,I guessed the mask for fast speed, the most left and right position of the lever.That's on the TO DO list.

First we need to resolve the modemap. We are currently using a modemap copied from ixus265.
If you forgot how to do it, go to:
Miscellaneous Stuff -> Debug Parameters
set "Debug data display" to [Props] and "Propcase / Param data page" to [4]
Exit CHDK menu, you'll get a list on screen (40...49).
The numeric value of current shooting mode is displayed after ID 49:
Please note the number displayed there as you go through all shooting modes.
You can change shooting modes in the SET menu in rec mode on your camera.

Attached is the currently used modemap that needs to be corrected.


 

Related Topics


SimplePortal 2.3.6 © 2008-2014, SimplePortal