IXUS 1000 HS Porting Thread - page 45 - DryOS Development - CHDK Forum

IXUS 1000 HS Porting Thread

  • 440 Replies
  • 140943 Views
*

Offline Caefix

  • *****
  • 775
  • Sorry, busy deleting test shots...
Re: IXUS 1000 HS Porting Thread
« Reply #440 on: 27 / January / 2022, 14:03:18 »
Advertisements
Quote
;) ... Could be Ixus1000 porting thread, too...

Found in our dark web, https://app.assembla.com/spaces/chdk/subversion/commits/6054
Code: [Select]
int vid_get_viewport_display_xoffset()
{
    if (get_movie_status() > 1){return 0;}
    // TODO: check this???
    // MODE_MASK = 0x300 so mode_get()&MODE_MASK can never equal 100 - probably meant to be 0x100 to test for REC mode
if (shooting_get_prop(PROPCASE_ASPECT_RATIO) == 1  || ((mode_get()&MODE_MASK)== 100 ))
   return 0;
else
       return 60;
}
Ix1000 (100d, PS4) has <Wide> instead of Aspect ratio.
Edit4: (PS4 -> PC300 = 1 in <Wide>, 0 else.

Edit: The yscale related stuff needs some even done extra code ... not yet.

Edit2: Probably bigger problem ...  :(
Quote
chdkptp-r964\lua\gui_live_stats.lua:169: bad argument #4 to 'format' (number expected, got nil)
Code: [Select]
void *vid_get_viewport_live_fb()  { return 0x0; }
Edit3: Appended to lib.c, deleted in /sub/../lib.c, offline fine now ...  :xmas
Code: [Select]

int vid_get_viewport_width()
{
    if (camera_info.state.mode_play) {return 480;}
    if (camera_info.state.mode_video)
return shooting_get_prop(PROPCASE_VIDEO_RESOLUTION)<3 ? 360:480;
    return shooting_get_prop(PROPCASE_ASPECT_RATIO)==1 ? 480:360;
}

int vid_get_viewport_display_xoffset()          { return vid_get_viewport_width()==480 ? 0:60; }

... && the palette is broken, even color editor displays some wrong colors.  ???

Succesfull moved ...  :haha


First contact && Romlog,  <rec> --> lens moves out, Cra... ERROR: I/O error ... :lol
All lifetime is a loan from eternity.

 

Related Topics