SX280 / 275 / 270 porting - page 8 - DryOS Development - CHDK Forum supplierdeeply

SX280 / 275 / 270 porting

  • 365 Replies
  • 224599 Views
*

Offline srsa_4c

  • ******
  • 4451
Re: SX280 / 275 / 270 porting
« Reply #70 on: 22 / August / 2014, 13:12:29 »
Advertisements
It happens when you don't override the exposure with CHDK and instead use the one with the dialer on the  bottom of the display. Seems like this doesn't happen when using CHDK exposure override so basically the problems solved. Using 102c.
Since I can't reproduce this on my 102b camera, it looks like a bug in the 102c port. Thanks for the romlog.

The lockup doesn't happen if I allow the chdk open() function to fail if it can't "take" the fileio_semaphore within 2 seconds.
I don't quite understand it, could you please tell me more?
This is the technical explanation, it is meant to inform those few people who understand it.
What happens basically is that CHDK tries to save the RAW file when the camera is busy saving another file (presumably the movie digest video). The lockup is due to a CHDK bug, which is also causing the other lockup situation:
While I was recording a video then pressed <ALT> and started any script, All buttons stop working.
I think I'll put in a temporary workaround.

Re: SX280 / 275 / 270 porting
« Reply #71 on: 22 / August / 2014, 15:04:37 »
Ich hab schon mal hier was über Video Funktion (Chdk auf sx280/275/270) gefragt nur halt in englisch....und nicht so ganz verstanden
Dürfen wir drauf hoffen das demnächst was raus kommt
Evtl 1fps 5fps wäre sehr interessant also Länger belichten und das vielleicht bei ISO 6400 oder mehr....
.....120fps bei 1280x720 mit höhere Bitraten
 Oder bleiben es einfach träume

*

Offline srsa_4c

  • ******
  • 4451
Re: SX280 / 275 / 270 porting
« Reply #72 on: 22 / August / 2014, 18:10:18 »
Ich hab schon mal hier was über Video Funktion (Chdk auf sx280/275/270) gefragt nur halt in englisch....und nicht so ganz verstanden
Dürfen wir drauf hoffen das demnächst was raus kommt
Evtl 1fps 5fps wäre sehr interessant also Länger belichten und das vielleicht bei ISO 6400 oder mehr....
.....120fps bei 1280x720 mit höhere Bitraten
Ich gehe mal deine Fragen durch:
1) RAW Video: Niemand hat RAW Video auf PowerShot-Kameras implementiert. Leute die das können (und auch Zeit dazu haben) gibt es hier zur Zeit nicht.
2) "High bitrate" Video: CHDK kann die Video-Qualität bei meisten Kameras beeinflussen. Die nötige Unterstützung ist jedoch in diesem Port noch nicht implementiert.
3) Video FPS: Damit hat hier nur ein Forummitglied experimentiert, niemand konnte nachmachen. Die Kamera war ein Modell mit DIGIC 4 Prozessor. Die DIGIC4-Lösung ist wahrscheinlich nicht kompatibel mit DIGIC 6...
4) HD @ 120FPS: Ist wahrscheinlich nicht möglich.
Quote
Oder bleiben es einfach träume
Es sieht leider so aus...

Re: SX280 / 275 / 270 porting
« Reply #73 on: 25 / August / 2014, 04:36:50 »
Gibs Windows  tools wo man bei Portierung (chdk prealpha sx270) mit wirken kann
Evtl. Links dazu


*

Offline srsa_4c

  • ******
  • 4451
Re: SX280 / 275 / 270 porting
« Reply #74 on: 25 / August / 2014, 18:32:24 »
Gibs Windows  tools wo man bei Portierung (chdk prealpha sx270) mit wirken kann
Zur Zeit gibt es leider kaum brauchbare Tools für diese Aufgabe. Ich benutze einige modifizierte Perl-Skripten, die natürlich zusätzliche Programme brauchen (ARM-Toolchain, diverse GNU Tools). Man kann sie wahrscheinlich auch unter Windows zum Laufen zu bringen, ich hab's jedoch nicht probiert. Es gibt auch IDA für Profis, aber es ist ziemlich Teuer.
Programmierkenntnisse (ARM assembly, C) sind aber absolut erforderlich.

Entwicklung für Kameras mit früheren DIGIC Versionen ist viel einfacher: http://chdk.wikia.com/wiki/For_Developers

*

Offline srsa_4c

  • ******
  • 4451
Re: SX280 / 275 / 270 porting
« Reply #75 on: 29 / August / 2014, 18:28:55 »
Long exposure (1.3-15 seconds) with a high override ISO seems to crash the camera.
Can you tell me how to reproduce? Camera mode and settings, relevant CHDK settings. Is your cam 102b or 102c? You can get a romlog too: "miscellaneous stuff" -> "debug parameters" -> "save rom crash log", especially if your cam is 102c.

I shot some pictures earlier with ISO400, 32 sec exposure time (M mode), just tried ISO3200 in Tv mode (4s ... 15s exposures), no problems.

It happens when you don't override the exposure with CHDK and instead use the one with the dialer on the  bottom of the display. Seems like this doesn't happen when using CHDK exposure override so basically the problems solved. Using 102c.
I compared the assembly part of (102c) capt_seq.c to the "original" lines in disassembly and found no differences that could explain the crash. That means the above problem should likely be present in 102b too. If anybody could come up with a way to reproduce the issue, that would be really helpful (I'm not able to crash my camera with long exposures).

Re: SX280 / 275 / 270 porting
« Reply #76 on: 01 / September / 2014, 07:16:05 »
RAW doesn't work on Auto mode. Looks like it's disabled.Is it supposed to be like that?

Long exposure (1.3-15 seconds) with a high override ISO seems to crash the camera.
Can you tell me how to reproduce? Camera mode and settings, relevant CHDK settings. Is your cam 102b or 102c? You can get a romlog too: "miscellaneous stuff" -> "debug parameters" -> "save rom crash log", especially if your cam is 102c.

I shot some pictures earlier with ISO400, 32 sec exposure time (M mode), just tried ISO3200 in Tv mode (4s ... 15s exposures), no problems.

It happens when you don't override the exposure with CHDK and instead use the one with the dialer on the  bottom of the display. Seems like this doesn't happen when using CHDK exposure override so basically the problems solved. Using 102c.
I compared the assembly part of (102c) capt_seq.c to the "original" lines in disassembly and found no differences that could explain the crash. That means the above problem should likely be present in 102b too. If anybody could come up with a way to reproduce the issue, that would be really helpful (I'm not able to crash my camera with long exposures).

Should I make a video?

*

Offline srsa_4c

  • ******
  • 4451
Re: SX280 / 275 / 270 porting
« Reply #77 on: 01 / September / 2014, 14:59:56 »
RAW doesn't work on Auto mode. Looks like it's disabled.Is it supposed to be like that?
Latest cameras usually don't produce valid RAW in specific modes, AUTO is one of those modes.
Quote
Should I make a video?
Seeing the camera crashing is not too informative. Instead, please write down the camera settings and CHDK settings you used when the camera crashed. Camera settings: go into the Canon recording menu (press MENU when the cam is in shooting mode), note every setting; open the shooting menu (SET while in shooting mode), note every setting; note which mode is selected on the mode dial; note the settings which you can adjust by pressing buttons while in shooting mode (up/down/left/right). Note if you have wifi or gps enabled. Reset CHDK settings (CHDK settings -> Reset options to default), note each CHDK setting you set after that.


Re: SX280 / 275 / 270 porting
« Reply #78 on: 03 / September / 2014, 05:34:30 »
Quote
Should I make a video?
Seeing the camera crashing is not too informative. Instead, please write down the camera settings and CHDK settings you used when the camera crashed. Camera settings: go into the Canon recording menu (press MENU when the cam is in shooting mode), note every setting; open the shooting menu (SET while in shooting mode), note every setting; note which mode is selected on the mode dial; note the settings which you can adjust by pressing buttons while in shooting mode (up/down/left/right). Note if you have wifi or gps enabled. Reset CHDK settings (CHDK settings -> Reset options to default), note each CHDK setting you set after that.

OK, here are the settings:

Mode: Manual

AF Frame: Center
AF Frame Size: Normal
Digital Zoom: Off
AF-Point Zoom: On
Servo AF: On
Continuous AF: On
AF-assist Beam: On
MF-Point Zoom On
Flash Settings: Medium, On, On
i-Contrast: Auto
Wind Filter: Auto
Review image after shooting: Quick
Blink Detection: On
Grid Lines: Off
IS Settings: Continuous, 1
Date Stamp: Off
Face ID: Off

Open CHDK Menu>Enhanced Photo Operations>Override ISO: ON 10000
Close Menu
Use the dial to change shutter speed to 1"3
Press the shutter button
Display says 'Busy'
Display goes blank
Lens not retracted

I don't think we can use Wifi when in shooting mode and I don't find it really useful but yes I have configured Wifi to try it out. My camera has no GPS (SX275).
« Last Edit: 03 / September / 2014, 05:44:43 by magmar452 »

*

Offline srsa_4c

  • ******
  • 4451
Re: SX280 / 275 / 270 porting
« Reply #79 on: 03 / September / 2014, 14:45:10 »
OK, here are the settings
Thanks. Still no 'luck' here, my camera is not crashing. I guess I'll have to continue the code review for 102c...

 

Related Topics