supplierdeeply

Canon A810 crash when "shoot_half" after "set_prop(8,1)"

  • 8 Replies
  • 1059 Views
Canon A810 crash when "shoot_half" after "set_prop(8,1)"
« on: 01 / June / 2014, 07:10:21 »
Advertisements
Hi, i using firmware a810-100e-1.3.0-3451-full, PropertyCase for my camera is propset5, so "8" is:

Code: [Select]
AiAF Mode (1=Flexizone, 2=FaceAIAF or Tracking AF)
 I alway got "crash"(shut down) at "shoot_half" after "set_prop(8,1)"  :blink:

 Here is my code:

Code: [Select]
--[[
@title Change AiAF Mode
--]]

sleep(500)
af = get_prop(8)
if af ~= 1 then set_prop(8,1) end

press("shoot_half") --alway crash here
repeat sleep(50) until get_shooting() == true

How to resolve this problem?

Thanks.

P/s: I had tested in Stable 1.2.0

*

Offline srsa_4c

  • ******
  • 3530
Re: Canon A810 crash when "shoot_half" after "set_prop(8,1)"
« Reply #1 on: 01 / June / 2014, 08:38:13 »
I tried this on my same generation a3400 (in P mode), it is working for me. AF mode changes and I get no crash on (half)shoot.
Can you make a romlog ("miscellaneous stuff" -> "debug parameters" -> "save rom crash log") and attach it here?

Re: Canon A810 crash when "shoot_half" after "set_prop(8,1)"
« Reply #2 on: 01 / June / 2014, 09:27:39 »
Thanks for reply, this is what inside my ROMLOG.LOG

Code: [Select]
System Panic: Module = 64, Panic = 4
Occured Time  2014:06:01 20:13:17
StackDump(0x317238 - 0x3172B8):
0x00317238
0x003172A4
0x00317298
0x00317350
0x0031734C
0x00317348
0x00317344
0x003FC904
0x00000000
0x00000000
0xFFFFFF00
0x003FC614
0x00000000
0xFF8CE9D0
0x00000005
0x00000000
0x00000000
0xFF95F0FC
0x00000000
0x00000000
0x00000000
0xFF8CF808
0x00317344
0x00317298
0x01B00480
0x0002000C
0x000004A8
0x00000000
0x00000000
0x00640000
0x0064FFEE
0x00640012



Attachment is the same.

*

Offline srsa_4c

  • ******
  • 3530
Re: Canon A810 crash when "shoot_half" after "set_prop(8,1)"
« Reply #3 on: 01 / June / 2014, 09:48:19 »
Code: [Select]
System Panic: Module = 64, Panic = 4
That's ugly. Memory belonging to the Canon firmware gets corrupted somehow.
Can you reproduce the crash when:
- you change the AF setting in the Canon menu by hand and run a script (without set_prop, just half-shoot)
- you change a different property with set_prop (choose something safe, like compression or image size) within your script


Re: Canon A810 crash when "shoot_half" after "set_prop(8,1)"
« Reply #4 on: 01 / June / 2014, 20:21:24 »
Here's what you require, it's working fine on my camera, no crash:
Code: [Select]
--[[
@title Flash off
--]]
sleep(500)
af = get_prop(143)
if af ~= 2 then set_prop(143,2) end

press("shoot_half")
repeat sleep(50) until get_shooting() == true

Code: [Select]
--[[
@title shoot_half only
--]]
press("shoot_half")
repeat sleep(50) until get_shooting() == true

Only crash after set_prop(8,1).

set_prop(8,2) is fine, no crash but like what i'm seeing, it's still in center mode(1) not FaceAIAF or Tracking AF(2)
« Last Edit: 02 / June / 2014, 04:08:43 by user972611 »

*

Offline srsa_4c

  • ******
  • 3530
Re: Canon A810 crash when "shoot_half" after "set_prop(8,1)"
« Reply #5 on: 03 / June / 2014, 13:54:36 »
Some things you could try:
1) Try compiling CHDK for yourself. If you're using Windows, there's a GUI utility to make that easy: http://chdk.setepontos.com/index.php?topic=845.0 Changing the compiler (GCC) version may make a difference.
2) You can try calling event procedures to set that property (enable native calls in the misc menu):
Code: [Select]
call_event_proc("SS.Create") -- this is only needed once per session
call_event_proc("PT_SetPropertyCaseInt",8,1,4) -- 8=propcase, 1=value, 4=value size in bytes
3) If neither of the above helps, an attempt could be made to make a CHDK build for the camera which doesn't use exmem - if the available RAM is too small, perhaps it could be made a bit larger by reducing the UI memory allocation size (that requires a small camera-specific CHDK modification) + enabling ARAM.

All suggestions above are workarounds: the crash you're experiencing should not be happening.

Re: Canon A810 crash when "shoot_half" after "set_prop(8,1)"
« Reply #6 on: 04 / June / 2014, 01:00:08 »
I borrow another A810, insert same sdcard, run script and it's working FINE  :o

Is that my camera error? Do you have any suggest about this? Should I return my camera?

*

Online reyalp

  • ******
  • 11082
Re: Canon A810 crash when "shoot_half" after "set_prop(8,1)"
« Reply #7 on: 04 / June / 2014, 01:05:33 »
I borrow another A810, insert same sdcard, run script and it's working FINE  :o

Is that my camera error? Do you have any suggest about this? Should I return my camera?
First check very carefully whether any canon firmware settings are different.
Don't forget what the H stands for.


Re: Canon A810 crash when "shoot_half" after "set_prop(8,1)"
« Reply #8 on: 04 / June / 2014, 07:29:51 »
Thanks for all yor help, here my solution, little dirty but work 8)
Code: [Select]
repeat
    checkAF = get_prop(8)
if checkAF ~= 1 then
click("menu")
sleep(100)
click("down")
sleep(100)
click("left")
sleep(100)
click("menu")
sleep(100)
end
until checkAF == 1

 

Related Topics