Building a mult-camera rig - page 16 - Hotwire! Hardware Mods, Accessories and Insights - CHDK Forum

Building a mult-camera rig

  • 244 Replies
  • 35447 Views
*

Offline reyalp

  • ******
  • 11903
Advertisements
Patch discussion moved per request: http://chdk.setepontos.com/index.php?topic=11779.0
Don't forget what the H stands for.

Hi All

1. @ reyalp / waterwings - Shall I continue to post here ? or to move to the new thread (http://chdk.setepontos.com/index.php?topic=11779.0) ?

2. @ Kam_mim / elizabeth.m - sorry for the delay , here is the link for the custom build for A2500 (support the USB Remote & PTP that created by waterwings (thank you again) ) BUT, as waterwings mentioned , he is about to release new build with some modification (I am waiting for it  :) )
link : https://drive.google.com/file/d/0BxzCKpWNPEdWWjk2RDNuZ0V5ZFU/edit?usp=sharing

3. @waterwings - I am using your previous BCAM script (http://chdk.setepontos.com/index.php?topic=11583.msg113999#msg113999 , rather than http://chdk.setepontos.com/index.php?topic=11583.msg114393#msg114393 ) and I am having problem with camera numbering.

I set each camera it's own number (1 to 24) in script menu (I can see the number on screen when the camera in shoot & playback modes) , but when I download the pictures, the order is wrong for several pictures (meaning picture no 1 is really not the picture taken from camera 1 , it is rather taken from camera 5)
just to be clear I am using the following commands
Quote
chdkptp>chdkptp.exe -e"! bc=require('bcamHost') bc:connect() bc:cmdwait('shoot')"

chdkptp>chdkptp.exe -e"! bc=require('bcamHost') bc:connect() bc:download_last()"


I am not sure but I think that the order I connects the cameras to pc (via USB hub of course) is very important, meaning I connect it one by one starting from camera 1 to camera 24.

Is the order of connecting the cameras to pc important ? how the camera number (the one I set in the script menu) is reflects on the picture order?   


Is there anyway to know the camera number in CHDKPTP ?

adding pic from today tests :)

Thx

1. @ reyalp / waterwings - Shall I continue to post here ? or to move to the new thread
Stay here.

Quote
2. @ Kam_mim / elizabeth.m - sorry for the delay , here is the link for the custom build for A2500 (support the USB Remote & PTP that created by waterwings (thank you again) ) BUT, as waterwings mentioned , he is about to release new build with some modification (I am waiting for it  :) )
I sent them a link to the patched version.  Note that when the new version hits the autobuild, there will be an additional line needed in all scripts to enable the patch.

Quote
3. @waterwings - I am using your previous BCAM script (http://chdk.setepontos.com/index.php?topic=11583.msg113999#msg113999 , rather than http://chdk.setepontos.com/index.php?topic=11583.msg114393#msg114393 ) and I am having problem with camera numbering.
Why are you not using the latest version?  I don't remember when I got the camera numbering thing all sorted out but I don't really want to go back through old versions and sort that out if I don't have to.

Incidentally, elizabeth.m found a bug in the zoom code - the latest file linked on box.com has been updated.
Ported :   A1200    SD940   G10    Powershot N    G16

Waterwings , wow u reply fast !!!!!

I tried your new BCAM ( with the 4 command , and I got some error , immediately after I run the first command (the reset ) )

Can you share the link to box? Is the  command order changed?

Thx


I tried your new BCAM ( with the 4 command , and I got some error , immediately after I run the first command (the reset ) )
"some error" is a little vague - can you be more specific ?

Quote
Can you share the link to box?
https://app.box.com/s/hwyvqrldf8uyq9u5phjk

Quote
Is the  command order changed?
No
Ported :   A1200    SD940   G10    Powershot N    G16

Code: [Select]
C:\chdkptp>chdkptp  -e"exec bc=require('bcamHost') bc:reset()"
ERROR: call failed:[string "bc=require('bcamHost') bc:reset()"]:1: attempt to
ll method 'reset' (a nil value)
stack traceback:
        [C]: in function 'xpcall'
        C:\chdkptp\lua\cli.lua:566: in function <C:\chdkptp\lua\cli.lua:561>
        (...tail calls...)
        [C]: in function 'xpcall'
        C:\chdkptp\lua\cli.lua:244: in function 'execute'
        C:\chdkptp\lua\main.lua:194: in function 'do_execute_option'
        C:\chdkptp\lua\main.lua:227: in function 'do_no_gui_startup'
        C:\chdkptp\lua\main.lua:262: in main chunk
        [C]: in function 'require'
        [string "require('main')"]:1: in main chunk



it is 3:30 AM so I will read your answer in the morning

thx

it is 3:30 AM so I will read your answer in the morning
Does it do this with the latest download?
Ported :   A1200    SD940   G10    Powershot N    G16

I haven't tested yet (this error from previous version)

In which mode shall the camera be before I run the four commands?
Is it in shoot mode while bcamrem script runing ? Or playback mode ?

Thx


*

Offline reyalp

  • ******
  • 11903
Code: [Select]
C:\chdkptp>chdkptp  -e"exec bc=require('bcamHost') bc:reset()"
ERROR: call failed:[string "bc=require('bcamHost') bc:reset()"]:1: attempt to
ll method 'reset' (a nil value)
This means that the reset function doesn't exist in whatever require('bcamHost') returned. It has nothing to do with anything on the camera.
Don't forget what the H stands for.

This means that the reset function doesn't exist in whatever require('bcamHost') returned. It has nothing to do with anything on the camera.
See the previous post about him still using an older version of the script.
Ported :   A1200    SD940   G10    Powershot N    G16

 

Related Topics