Building a mult-camera rig - page 8 - Hotwire! Hardware Mods, Accessories and Insights - CHDK Forum

Building a mult-camera rig

  • 244 Replies
  • 36022 Views
*

Offline reyalp

  • ******
  • 11924
Advertisements
it is very simple to shoot but (must be but :) ), the images that are copied to pc are corrupted while it is fine when checking it on SD card . why is that  ? appreciate your assistance 
A good first step to be to try to determine what specifically is wrong with the files. Are the zero size? Assuming they aren't zero size,  look at the contents with a text or hex editor.
Don't forget what the H stands for.

It is zero size file  :(

What shall I do ?

*

Offline reyalp

  • ******
  • 11924
It is zero size file  :(

What shall I do ?
You should try to figure out where specifically it is failing. chdkptp should generate some kind of error message if a download fails.

Waterwingz suggestion before my post is also good (though in chdkptp terminology, he means download, not upload)

As I've said before, you have undertaken a complex technical project. You will need to be able to debug stuff. I'm not saying you shouldn't ask here, but you can't expect us to solve every problem for you.
Don't forget what the H stands for.

Got your point

Can u tell me how to see chdk logs /debug ?

Thx


Can u tell me how to see chdk logs /debug ?
Assuming you are using the command line commands I posted above,  what does it say on the screen when you execute each one ?

FYI : I rebooted into Windows 7,  downloaded the most recent version of chdkptp and retested the two scripts.  From a "DOS Box" command line, where you have changed to the chdkptp directory, copied the bcamHost.lua file to the lua subdirectory, and launched bcamRem.lua on each camera ,  the relevant commands are :

Code: [Select]
chdkptp>chdkptp.exe -e"! bc=require('bcamHost') bc:connect() bc:cmdwait('shoot')"
chdkptp>chdkptp.exe -e"! bc=require('bcamHost') bc:connect() bc:download_last()"
The uploaded images were all valid as well. 

Note that you will need to set the @param value on each of your cameras to a unique number other than zero them if you wish to use the image sorting & filing scheme I'm working on.  The "Unknown" large text area on the screen shot you posted indicates you have not done so yet.
Ported :   A1200    SD940   G10    Powershot N    G16

How to set camera unique name ? U r right it is unknown at the moment

How to set camera unique name ? U r right it is unknown at the moment


Although that is almost certainly not what is causing your images to have zero file length.

Ported :   A1200    SD940   G10    Powershot N    G16

Thx

Another question, inside chdkptp I can see list of cameras connected , serial & parellel ID  ,the issue is all cameras parallel ID is identical

How can I change it ?


Another question, inside chdkptp I can see list of cameras connected , serial & parellel ID  ,the issue is all cameras parallel ID is identical
Where do you think you are seeing serial & parrallel ID's ?   I'm not a low level USB expert but I don't think there is any such thing with USB ports.   I suspect you are looking at the idVendor and idProduct fields - which should all be exactly the same if you are using all the same cameras.

Quote
How can I change it ?
Why do you think you want to?
Ported :   A1200    SD940   G10    Powershot N    G16

waterwings -

I think the problem might be related to win8 (attached pic with the error "GENERAL ERROR") (even when using single camera)

Quote
C:\chdkptp2>chdkptp.exe -e"! bc=require('bcamHost') bc:connect() bc:download_las
t()"
Connecting...
  1:Canon PowerShot A2500  = bus:\\.\libusb0-0003--0x04a9-0x3271 dev:bus-0 sn:26
0A8C4B8E0944929A0D1EAAE7EBC28E
Downloading last image ...
  1:Canon PowerShot A2500  = A/DCIM/149___07/ETC_1401.TMP/IMG_1401.JPG
ERROR: General Error


I am downloading win7 iso and hope to run it with vmware workstation to verify it is win8 issue

regarding the serial / parallel ,
Quote
C:\chdkptp2>chdkptp -i
___> list
___> list
___> list
-1:Canon PowerShot A2500  b=bus-0 d=\\.\libusb0-0003--0x04a9-0x3271 v=0x4a9 p=0x
3271 s=260A8C4B8E0944929A0D1EAAE7EBC28E

Serial - s=260A8C4B8E0944929A0D1EAAE7EBC28E
Parallel - p=0x3271

All camera share the same Parallel ID (p=0x3271) , i would like to change the parallel ID
I saw some post from HH each he modifided something in the registry to overcome this ,
but I dont know if it related or not



 

Related Topics