Building a mult-camera rig - page 11 - Hotwire! Hardware Mods, Accessories and Insights - CHDK Forum supplierdeeply

Building a mult-camera rig

  • 244 Replies
  • 35442 Views
Advertisements
I made couple of tests

1. Default script (USB Remote + Enable sync enable) - When connecting the USB cable it goes into playback mode
2. Bcam script (no need to set it since the script handle it by itself, am I right ? USB Remote + Enable sync enable) -  When connecting the USB cable it goes into playback mode
3. Delayed shoot script (USB Remote + Enable sync enable) - When connecting USB cable camera remain in rec mode (as should be) , when disconnecting USB cable camera shoot picture

It looks that the custom FW & Delayed shoot script are working properly , therefor need to copy parts of the code from it and implement into bcam(multicam) script

Thank you all for the amazing assistance


3. Delayed shoot script (USB Remote + Enable sync enable) - When connecting USB cable camera remain in rec mode (as should be) , when disconnecting USB cable camera shoot picture
What script is the "delayed shoot script" ?  Please provide a link or simply attach the script to your response.

There should be no need to modify the bcamRem.lua script.  I've tested it using the same modified code that I sent to you.

« Last Edit: 06 / July / 2014, 07:13:40 by waterwingz »
Ported :   A1200    SD940   G10    Powershot N    G16

this script come with the CHDK fw you send me
When loading it , I get message (Delay shoot )

Quote
There should be no need to modify the bcamRem.lua script.  I've tested it using the same modified code that I sent to you.

missed your point ...
At the moment when I load bcamRem.lua script on camera , enable script (Alt mode), press shoot button to go to live(rec) mode , see red & blue screen (camera ID , Shoot No) , when connecting the USB cable , camera go to playback mode.
When sending shoot command from pc . the cam shoot immediately

hope you understand my meaning




this script come with the CHDK fw you send me
When loading it , I get message (Delay shoot )
Okay - that's understood now.

In the bcamRem.lua script parameters ( the ones you see at the bottom of the Script menu),  did you set Remote Sync [ * ] ?

additional note :  to halt the script or shutdown the camera when the script is running,  simply press the shutter button.  Or issue this command :
Code: [Select]
chdkptp -e"exec bc=require('multicam') bc:connect() bc:cmd('shutdown')"
« Last Edit: 06 / July / 2014, 08:16:06 by waterwingz »
Ported :   A1200    SD940   G10    Powershot N    G16


Quote
In the bcamRem.lua script parameters ( the ones you see at the bottom of the Script menu),  did you set Remote Sync [ * ] ?

I think you told me that bcamRem.lua set it by itself.
when shall i need to set it ? in playback mode before the script load ? on live (rec ) mode ? in CHDK Remote menu ? script menu ? 

Quote
In the bcamRem.lua script parameters ( the ones you see at the bottom of the Script menu),  did you set Remote Sync [ * ] ?

I think you told me that bcamRem.lua set it by itself.
when shall i need to set it ? in playback mode before the script load ? on live (rec ) mode ? in CHDK Remote menu ? script menu ?

"In the bcamRem.lua script parameters ( the ones you see at the bottom of the Script menu)

For convenience,  I set this up as a script option (useful if you want to test without needing to open the red wire.
Ported :   A1200    SD940   G10    Powershot N    G16

will check later (left the cam at home )

r u referring to "Remote Sync ? "
http://chdk.setepontos.com/index.php?topic=11583.msg114152#msg114152

Ported :   A1200    SD940   G10    Powershot N    G16


thx , will update later

Great News - It is working !!!!!!!!!

Thank for everyone involved especially waterwings !!!!

I created small batch file which
1. Connect to cameras, shoot & download images to PC ( using waterwings bcamRem.lua script)
2. Check and create new folder (last folder + 1) according to last folder used (single folder for all pictures)
3. Copy and rename pictures (from multiple cameras folder) file name according to cameras number

I am planing to test all procedure , especially after finishing the electric sync board

It seems that after all I must use relays to control the 5 volt  for USB remote sync

Still hard work ahead of me but I defiantly on the right way !!!!!!! 

Thank again


Hope to upload new pics after finish electric board

 

Related Topics