Bug report: || won't fix: A550,A560,I75 || fixed: SX20,I200,I960,I970,SD870 - page 6 - General Discussion and Assistance - CHDK Forum  

Bug report: || won't fix: A550,A560,I75 || fixed: SX20,I200,I960,I970,SD870

  • 82 Replies
  • 11606 Views
*

Offline koshy

  • *****
  • 1055
Advertisements
Hooks did not work on previous files. Please test this new version.
OK, long exposure works with 00:01:31
DNGs get written both on full and after half shutter button press.
CRWs also get written, RAW folder gets created if chosen.

Does this require other tests?
Koshy had a little ELPH which wasn't white as snow but everywhere that Koshy went the ELPH was sure to go. (actually an SD, but that detail ruins the rhyme...)

*

Offline nafraf

  • *****
  • 1308
Does this require other tests?
Filewrite task was added. It means that captured image can be saved directly to PC, without saving it on SD-card. To test it, chdkptp is required. We can test it now, or let that change to be tested and included later.

*

Offline koshy

  • *****
  • 1055
]Filewrite task was added. It means that captured image can be saved directly to PC, without saving it on SD-card. To test it, chdkptp is required. We can test it now, or let that change to be tested and included later.

Downloaded chdkptp, added the required libusb0.dll from source fourge. Instruct what to test please.
Koshy had a little ELPH which wasn't white as snow but everywhere that Koshy went the ELPH was sure to go. (actually an SD, but that detail ruins the rhyme...)

*

Offline nafraf

  • *****
  • 1308
To test remote capture:
1 - Run chdkptp and connect to camera ( Click on connect button or type "connect" in console)
2 - go to rec mode (Click on REC button or type "rec" in console)
3 - To test remote capture, use buttons in "User" tab. Or type in console:
    remoteshot -jpg local_destination_directory
     remoteshot -dng local_destination_directory

To get more help, type: help rs
Check if captured images are fine. Thanks


*

Offline koshy

  • *****
  • 1055
I'm trying to connect the camera to chdkptp Win32 running on Win7 64.
Thus far I can't find the camera. "ERROR: no matching device"
Do I have to set anything on the camera, or should I try on an old XP box?
Koshy had a little ELPH which wasn't white as snow but everywhere that Koshy went the ELPH was sure to go. (actually an SD, but that detail ruins the rhyme...)

*

Offline nafraf

  • *****
  • 1308
Two things to check:
- PC does not recognize the camera if USB Remote is enable.
- Driver should be installed as an INF Driver, NOT a Filter Driver.   More information about driver: http://chdk.wikia.com/wiki/PTP_Extension#LibUSB_Driver_for_Windows
« Last Edit: 24 / July / 2014, 11:00:50 by nafraf »

*

Offline koshy

  • *****
  • 1055
- Driver should be installed as an INF Driver, NOT a Filter Driver.

Thanks, was being stupid - didn't install driver at all just copied the dll the chdkptp asked for in the same dir and it stopped complaining  ;)

This works on SD870 tested both JPEG and DNG capture and opened the files transferred to the PC.
Koshy had a little ELPH which wasn't white as snow but everywhere that Koshy went the ELPH was sure to go. (actually an SD, but that detail ruins the rhyme...)

*

Offline koshy

  • *****
  • 1055
I also performed the USB remote test from our other thread and marked the camera as processed there since that worked, too.
Koshy had a little ELPH which wasn't white as snow but everywhere that Koshy went the ELPH was sure to go. (actually an SD, but that detail ruins the rhyme...)


I also performed the USB remote test from our other thread and marked the camera as processed there since that worked, too.
The current USB remote code was all done "blind" for older cameras way back when the conversion between the old USB remote code in 1.0.0 and the new code USB remote code in 1.1.0 was released.   It's good to see this finally being tested.
Ported :   A1200    SD940   G10    Powershot N    G16

*

Offline nafraf

  • *****
  • 1308
@koshy
In ixus860 test version, movie_rec.c was modified. Please test if video quality control works.
http://chdk.wikia.com/wiki/CHDK_1.2.0_User_Manual#Video_Parameters
Test video recording with low quality (~5) and high quality (~70) and verify the results.
Thanks

 

Related Topics