s110 chdkptp connect - Hello, I'm a NEWBIE - HELP!! (Newbies assistance, User Guides and thank you notes) - CHDK Forum

s110 chdkptp connect

  • 8 Replies
  • 2507 Views
s110 chdkptp connect
« on: 08 / July / 2014, 06:59:46 »
Advertisements
i connect s110 usb to linux pc for use chdkptp

but pc cant find my s110 when I turn on chdk mode

firmware 1.2

sorry for my very bad english


how to find port to connect camera ?

Re: s110 chdkptp connect
« Reply #1 on: 08 / July / 2014, 11:45:23 »
With Linux, this is often an issue with some other software connecting to the camera automatically between when you plug in the USB cable and before you start chdkptp.  On my Linux system it's part of the gphoto package and I have to disable that driver in my Linux config files (or just rename it so it can't be found).
Ported :   A1200    SD940   G10    Powershot N    G16

Re: s110 chdkptp connect
« Reply #2 on: 08 / July / 2014, 23:18:03 »
With Linux, this is often an issue with some other software connecting to the camera automatically between when you plug in the USB cable and before you start chdkptp.  On my Linux system it's part of the gphoto package and I have to disable that driver in my Linux config files (or just rename it so it can't be found).

I test gphoto2 --auto-detect but it cant find usb port

Re: s110 chdkptp connect
« Reply #3 on: 08 / July / 2014, 23:51:09 »
I test gphoto2 --auto-detect but it cant find usb port
I think that I see in the first photo the CHDK OSD icon that indicates you have the USB Remote enabled? 

You need to disable that if you want to communicate over PTP between camera and PC.

Update :  link > Enabling USB Remote operation
« Last Edit: 09 / July / 2014, 00:11:37 by waterwingz »
Ported :   A1200    SD940   G10    Powershot N    G16


Re: s110 chdkptp connect
« Reply #4 on: 09 / July / 2014, 00:58:06 »
I test gphoto2 --auto-detect but it cant find usb port
I think that I see in the first photo the CHDK OSD icon that indicates you have the USB Remote enabled? 

You need to disable that if you want to communicate over PTP between camera and PC.

Update :  link > Enabling USB Remote operation


i disable remote  and then i connect usb to my linux(ubuntu) pc

i can find usb port but my s110 alway sleep mode 


usb_ptp_get_device_status(): Device or resource busy
« Last Edit: 09 / July / 2014, 01:28:07 by dsljj »

Re: s110 chdkptp connect
« Reply #5 on: 09 / July / 2014, 20:11:52 »
i can find usb port but my s110 alway sleep mode 
That is what normally happens when you connect a USB cable between a Canon P&S camera and a computer.  It is not sleeping - it has entered a mode where it will transfer pictures.  The LCD turns off in that mode.

Looking at your attached pictures, you have chdkptp running and communicating with the camera.  Does this mean that means this problem is solved and the issue is closed?
Ported :   A1200    SD940   G10    Powershot N    G16

Re: s110 chdkptp connect
« Reply #6 on: 09 / July / 2014, 22:50:10 »
i can find usb port but my s110 alway sleep mode 
That is what normally happens when you connect a USB cable between a Canon P&S camera and a computer.  It is not sleeping - it has entered a mode where it will transfer pictures.  The LCD turns off in that mode.

Looking at your attached pictures, you have chdkptp running and communicating with the camera.  Does this mean that means this problem is solved and the issue is closed?

how to disable this mode or shoot while i'm in this mode  ?

Re: s110 chdkptp connect
« Reply #7 on: 09 / July / 2014, 23:33:40 »
how to disable this mode or shoot while i'm in this mode  ?
You do not need to disable this mode.  And you do not want to disable this mode.  It is the mode you need to use to communicate with the camera and shoot.   Just click on the buttons marked below from your image :
Ported :   A1200    SD940   G10    Powershot N    G16


*

Offline reyalp

  • ******
  • 12074
Re: s110 chdkptp connect
« Reply #8 on: 09 / July / 2014, 23:47:05 »
If the camera has already gone into PTP sleep mode, it probably won't be able to switch to record.

As I mentioned in PM, this usually happens because some other software has tried to talk to the camera before chdkptp. The "Device or resource busy" confirms this.

How to disable the other software connecting to the camera depends on your specific distro.

This is discussed in the posts I linked http://chdk.setepontos.com/index.php?topic=6231.msg100671#msg100671
Don't forget what the H stands for.

 

Related Topics