Multi-camera setup project. - page 45 - Creative Uses of CHDK - CHDK Forum  

Multi-camera setup project.

  • 462 Replies
  • 108216 Views
*

Online reyalp

  • ******
  • 12440
Re: Multi-camera setup project.
« Reply #440 on: 07 / February / 2017, 22:13:26 »
Advertisements
Ah yes my bad , when i say "preview mode", i mean the "play" mode.
Thanks, I understand now.
Quote
So the sequence of calls is "preshoot" + "shoot_burst" (the number of shoot_burst used is irrelevant , the problem occurs even with one shoot_burst) and then issuing "play" command (you know so you can review the photo taken on camera's display).
Does the camera crash (shut down) or just stop responding to chdkptp?
At what point does the problem happen, immediately after switching to play mode, or subsequently when you try to switch back to rec or try to shoot again?
If it crashes, please get a ROMLOG from one camera. See http://chdk.wikia.com/wiki/Debugging#Camera_crash_logs_.28romlog.29
Don't forget what the H stands for.

*

Offline mphx

  • ***
  • 210
Re: Multi-camera setup project.
« Reply #441 on: 08 / February / 2017, 05:11:26 »
Does the camera crash (shut down) or just stop responding to chdkptp?
At what point does the problem happen, immediately after switching to play mode, or subsequently when you try to switch back to rec or try to shoot again?
If it crashes, please get a ROMLOG from one camera. See http://chdk.wikia.com/wiki/Debugging#Camera_crash_logs_.28romlog.29

I believe they shut down.If i reconnect cameras , the turned off cameras dont show up anymore...i have to power them on again .
So i guess they are shutting down.

The problem happens when i issue play command (after preshoot+shoot_burst) .Camera tries to go into play mode ...display turns off and stays off..never displays the last photo taken.Display off , led off..The End :)

I will try to get a crash log later today...
« Last Edit: 08 / February / 2017, 05:13:56 by mphx »

*

Offline mphx

  • ***
  • 210
Re: Multi-camera setup project.
« Reply #442 on: 08 / February / 2017, 06:20:08 »
@reyalp

Ok , i turned on one camera i know it crashes.I repeated the steps (preshoot+2x shoot_burst+play mode).
It turned off as expected (the bus id on chdkptp dissapeared...i believe that means camera is off for sure :) )
I then turned it on again , went to chdk menu , misc-debugging-save romlog , download it to pc and here it is.

https://www.dropbox.com/s/pz7filk9y2d0ezx/ROMLOG.LOG?dl=0

Have in mind , that some cameras are not affected or it seems that they are not affected...maybe cameras turn off randomly .
So maybe there is a hardware incompatibility or something..
All cameras are running chdk 1.5.0 4740

*

Online reyalp

  • ******
  • 12440
Re: Multi-camera setup project.
« Reply #443 on: 08 / February / 2017, 23:11:00 »
Can you check if the clock is approximately correct on the camera?
The romlog says
Quote
Occured Time  2015:06:21 23:08:31
So unless the clock is a couple years off, it's not related to the crash.
Don't forget what the H stands for.


*

Offline mphx

  • ***
  • 210
Re: Multi-camera setup project.
« Reply #444 on: 09 / February / 2017, 07:56:02 »
Can you check if the clock is approximately correct on the camera?
The romlog says
Quote
Occured Time  2015:06:21 23:08:31
So unless the clock is a couple years off, it's not related to the crash.

Some cameras (if not all) don't have the correct date and we know that.When we first set up the whole thing , some cameras kept losing the date setting (probably something to do with the fact that they operate with dummy battery-external power source or something like that).
So we got tired setting up date every time and we left it as is.It didn't bother us so we left it be.

The romlog i attached was created exactly after the crash.I don't know if it contains anything related to the crash but having a past date is normal.

*

Online reyalp

  • ******
  • 12440
Re: Multi-camera setup project.
« Reply #445 on: 09 / February / 2017, 13:13:46 »
The romlog i attached was created exactly after the crash.I don't know if it contains anything related to the crash but having a past date is normal.
The romlog is saved to internal flash memory by the canon firmware when the crash occurs. The CHDK romlog just copies the most recent saved romlog to the SD card so you can download it. It is possible that the problem you have with switching to playback doesn't generate a romlog.

I am asking whether that specific cameras clock is set to 2015. YES or NO. I don't want to spend time trying to debug a log that has nothing to do with the problem you reported.

Also, please tell me which camera model and firmware version this came from.
Don't forget what the H stands for.

*

Offline mphx

  • ***
  • 210
Re: Multi-camera setup project.
« Reply #446 on: 09 / February / 2017, 19:02:56 »
The romlog is saved to internal flash memory by the canon firmware when the crash occurs. The CHDK romlog just copies the most recent saved romlog to the SD card so you can download it. It is possible that the problem you have with switching to playback doesn't generate a romlog.

I am asking whether that specific cameras clock is set to 2015. YES or NO. I don't want to spend time trying to debug a log that has nothing to do with the problem you reported.

Also, please tell me which camera model and firmware version this came from.

This specific camera is one of many that when is turned on drops you to date/time set up screen...so its very possible that this specific camera's clock is set to 2015.
As i said we stopped setting up date/time to some cameras from very beginning and the beginning was like 1-1,5 years ago.So yes date of 2015 is very very possible.
I can't check it out for sure right now. I will be at studio Saturday and check then to be sure.

But what you said and i put in bold is what i suspected from the beginning (after checking romlog with my near to zero knowledge of these things).That maybe this problem isn't actually a crash and no romlog is generated at all.

Camera is Canon A2500 , firmware : 100a , chdk : 1.5.0 4740

EDIT : An easy way to find out if a romlog is generated by the problem is to set date to current date , repeat the process , use chdk romlog thing and see what date is referred in that log.If chdk copies the latest and the romlog still has 2015 in it , then no romlog was generated.But if it has 2016 on it , its a newly generated one.
Gonna do it when i will be at studio.
« Last Edit: 09 / February / 2017, 19:07:30 by mphx »

Re: Multi-camera setup project.
« Reply #447 on: 02 / April / 2017, 04:46:02 »
Hi mphx:
     I have 8 cameras and it's make me crazy to charger them everytime,so i bought a DC 12V power supplies and some DC-DC converters tried to power the cameras,but it's failed at the beginning with one camera,when i try to zoom in ,camera died, i think maybe because of the length of the DC12 power and the camera.The length I need is 4 meters.
Could you help me with your experience?
Thanks.

通过我的 MX5 上的 Tapatalk发言



Re: Multi-camera setup project.
« Reply #448 on: 02 / April / 2017, 07:01:54 »
so i bought a DC 12V power supplies and some DC-DC converters
Digital cameras need a lot of current when running motors, charging flash capacitors, and writing to the SD card. So your power supplies need to be able to handle high current bursts.  What are the ratings of your 12 V supply and the DC-DC converters? Did you mount a converter at each camera so that the lowest voltage / highest current wire runs are the shortest?

A wiring diagram and photos showing your complete setup would be useful to see here.
Ported :   A1200    SD940   G10    Powershot N    G16

*

Offline cdg

  • **
  • 53
Re: Multi-camera setup project.
« Reply #449 on: 02 / April / 2017, 07:29:14 »
A wiring diagram and photos showing your complete setup would be useful to see here.
Here is the diagram.

 

Related Topics