Bug Report: || fixed for: TX1, IXUS 60, 65, 75, 100 - page 2 - General Discussion and Assistance - CHDK Forum
supplierdeeply

Bug Report: || fixed for: TX1, IXUS 60, 65, 75, 100

  • 27 Replies
  • 6196 Views
*

Offline nafraf

  • *****
  • 1308
Re: Bug Report? IXUS 100, Powershot TX1, IXUS 75, IXUS 60 & 65
« Reply #10 on: 21 / July / 2014, 21:09:34 »
Advertisements
Test version for ixus65_sd630 100a
Changes:
- Simpler loader
- capt_seq.c rewritten using code_gen.

exp_drv_task was added, please test if long exposure (time > 64s) works.

*

Offline koshy

  • *****
  • 1054
Re: Bug Report? IXUS 100, Powershot TX1, IXUS 75, IXUS 60 & 65
« Reply #11 on: 22 / July / 2014, 06:54:20 »
Test version for ixus65_sd630 100a

Very good thank you.

- capt_seq.c rewritten using code_gen.
exp_drv_task was added, please test if long exposure (time > 64s) works.

I tested it and the cam powers on just fine.
Fully pressing the shutter now generates a DNG each time.
I also took a 00:01:31 long exposure in the closet and can confirm that that works, too.

That leaves TX1 and IXUS 60 open.
« Last Edit: 22 / July / 2014, 06:58:38 by koshy »
Koshy had a little ELPH which wasn't white as snow but everywhere that Koshy went the ELPH was sure to go. (actually an SD, but that detail ruins the rhyme...)

*

Offline nafraf

  • *****
  • 1308
Re: Bug Report? IXUS 100, Powershot TX1, IXUS 75, IXUS 60 & 65
« Reply #12 on: 22 / July / 2014, 09:01:17 »
Thanks for the report. Changes included in trunk. Changeset 3528
I tested it and the cam powers on just fine.
I was not expecting any change in power button behavior. boot.c was not modified.

Test version for tx1 101b in attachment.
- capt_seq.c was rewritten using code_gen.
- exp_drv_task was added, please test it.


*

Offline koshy

  • *****
  • 1054
Re: Bug Report: Powershot TX1, IXUS 60 || fixed for: IXUS 65, 75, 100
« Reply #13 on: 22 / July / 2014, 09:49:15 »
I was not expecting any change in power button behavior. boot.c was not modified.
Didn't know what the effect of "Simpler loader" would be.
Thought it would fail to power up if that had gone wrong.

Test version for tx1 101b in attachment.
- capt_seq.c was rewritten using code_gen.
- exp_drv_task was added, please test it.
Fully pressing the shutter now generates a DNG each time.
I also took a 00:01:31 long exposure in the closet and can confirm that that works, too.

So the TX1 is also fixed. Ixus 60 to go.
Koshy had a little ELPH which wasn't white as snow but everywhere that Koshy went the ELPH was sure to go. (actually an SD, but that detail ruins the rhyme...)


*

Offline nafraf

  • *****
  • 1308
Re: Bug Report: IXUS 60 || fixed for: TX1, IXUS 65, 75, 100
« Reply #14 on: 22 / July / 2014, 09:57:36 »
Test version for ixus60_sd600 100a:
-  capt_seq.c was rewritten using code_gen.

*

Offline koshy

  • *****
  • 1054
Re: Bug Report: IXUS 60 || fixed for: TX1, IXUS 65, 75, 100
« Reply #15 on: 22 / July / 2014, 10:16:23 »
Test version for ixus60_sd600 100a:
-  capt_seq.c was rewritten using code_gen.

Thanks. I tested it and it works, too. DNG every time.
Didn't test exp_drv_task as you didn't mention it.

Are these fixes FW version specific or do they fix a camera model in general?

I have a dozen or so cameras I didn't shoot with yet.
If the problem surfaces elsewhere I'll revive the thread.
Koshy had a little ELPH which wasn't white as snow but everywhere that Koshy went the ELPH was sure to go. (actually an SD, but that detail ruins the rhyme...)

*

Offline nafraf

  • *****
  • 1308
Re: Bug Report: || fixed for: TX1, IXUS 60, 65, 75, 100
« Reply #16 on: 22 / July / 2014, 10:25:06 »
Didn't test exp_drv_task as you didn't mention it.
I forgot to mention it. Please test it.

Quote
Are these fixes FW version specific or do they fix a camera model in general?
Patch is created using code_gen, patch should works for other firmware versions.  Commonly, I compare files of firmware tested with the other versions and apply the patch to all of them.

*

Offline koshy

  • *****
  • 1054
Re: Bug Report: || fixed for: TX1, IXUS 60, 65, 75, 100
« Reply #17 on: 22 / July / 2014, 10:38:29 »
Didn't test exp_drv_task as you didn't mention it.
I forgot to mention it. Please test it.
I tested the usual 00:01:31 and it worked.

How many more cams do need this tested?
« Last Edit: 22 / July / 2014, 11:39:50 by koshy »
Koshy had a little ELPH which wasn't white as snow but everywhere that Koshy went the ELPH was sure to go. (actually an SD, but that detail ruins the rhyme...)


*

Offline nafraf

  • *****
  • 1308
Re: Bug Report: || fixed for: TX1, IXUS 60, 65, 75, 100
« Reply #18 on: 22 / July / 2014, 13:10:39 »
How many more cams do need this tested?
Camera features and a CHDK functions ported are listed in this table: http://chdk.wikia.com/wiki/CameraFeatureTable

For long exposure time, check the "Extended TV Range" (ETR) column.

tx1 and ixus60 were updated in trunk. Changeset 3529 - 3531

*

Offline koshy

  • *****
  • 1054
Re: Bug Report: || fixed for: TX1, IXUS 60, 65, 75, 100
« Reply #19 on: 22 / July / 2014, 16:02:16 »
How many more cams do need this tested?
Camera features and a CHDK functions ported are listed in this table: http://chdk.wikia.com/wiki/CameraFeatureTable
For long exposure time, check the "Extended TV Range" (ETR) column.
25 cams hmmm? If you're up to it I'll try to be, too.
Moved that to its own thread here: http://chdk.setepontos.com/index.php?topic=11723
Koshy had a little ELPH which wasn't white as snow but everywhere that Koshy went the ELPH was sure to go. (actually an SD, but that detail ruins the rhyme...)

 

Related Topics