Bug Report: || fixed for: TX1, IXUS 60, 65, 75, 100 - page 3 - General Discussion and Assistance - CHDK Forum
supplierdeeply

Bug Report: || fixed for: TX1, IXUS 60, 65, 75, 100

  • 27 Replies
  • 13464 Views
*

Offline msl

  • *****
  • 1280
  • A720 IS, SX220 HS 1.01a
    • CHDK-DE links
Re: Bug Report: || fixed for: TX1, IXUS 60, 65, 75, 100
« Reply #20 on: 30 / July / 2014, 07:04:35 »
Advertisements
Maybe here is a good place for this note:

ixus75/sd750 101.a

In the German CHDK forum it was reported, that switching to shooting mode via PTP is not working.

set_record(1) without PTP works.

Can this bug be confirmed?

msl
CHDK-DE:  CHDK-DE links

*

Offline koshy

  • *****
  • 1096
Re: Bug Report: || fixed for: TX1, IXUS 60, 65, 75, 100
« Reply #21 on: 30 / July / 2014, 07:32:32 »
In the German CHDK forum it was reported, that switching to shooting mode via PTP is not working.
I dug out the I75 and connected to it via CHDKPTP. The connection works, I get the viewfinder transferred in play mode but as reported I could not switch to rec mode. I'll leave it on my desk so I'll be ready to test.
Koshy had a little ELPH which wasn't white as snow but everywhere that Koshy went the ELPH was sure to go. (actually an SD, but that detail ruins the rhyme...)

*

Offline srsa_4c

  • ******
  • 4451
Re: Bug Report: || fixed for: TX1, IXUS 60, 65, 75, 100
« Reply #22 on: 30 / July / 2014, 10:37:10 »
ixus75/sd750 101.a

In the German CHDK forum it was reported, that switching to shooting mode via PTP is not working.

set_record(1) without PTP works.
Possible solution:
http://trac.assembla.com/chdk/changeset/3100/trunk
The event ID for this cam seems to be 0x10a5.
See also http://chdk.setepontos.com/index.php?topic=10664

*

Offline msl

  • *****
  • 1280
  • A720 IS, SX220 HS 1.01a
    • CHDK-DE links
Re: Bug Report: || fixed for: TX1, IXUS 60, 65, 75, 100
« Reply #23 on: 30 / July / 2014, 11:27:38 »
Possible solution...
Thanks for the hints. I have compiled a test version for the German forum. We will see.

msl
CHDK-DE:  CHDK-DE links


*

Offline nafraf

  • *****
  • 1308
Re: Bug Report: || fixed for: TX1, IXUS 60, 65, 75, 100
« Reply #24 on: 30 / July / 2014, 12:37:38 »
Thanks for the hints. I have compiled a test version for the German forum. We will see.
Thanks.

@koshy, file was posted to this thread.

*

Offline koshy

  • *****
  • 1096
Re: Bug Report: || fixed for: TX1, IXUS 60, 65, 75, 100
« Reply #25 on: 30 / July / 2014, 13:22:51 »
@koshy, file was posted to this thread.
OK I downloaded it.

It fixes something but not all of it.

Upon connecting CHDKPTP it sais:

ERROR: :80: module 'capmode' not found:
   no field package.preload['capmode']
   no file 'A/CHDK/SCRIPTS/capmode.lua'
   no file 'A/CHDK/LUALIB/capmode.lua'
user code: 1

Going to Rec mode brings up a similar error (numbers are 84 and 5 instead of 80 and 1) but works

Shooting JPEG fails: ERROR: unsupported format
Shooting DNG works

Koshy had a little ELPH which wasn't white as snow but everywhere that Koshy went the ELPH was sure to go. (actually an SD, but that detail ruins the rhyme...)

*

Offline reyalp

  • ******
  • 14086
Re: Bug Report: || fixed for: TX1, IXUS 60, 65, 75, 100
« Reply #26 on: 30 / July / 2014, 17:13:16 »
It fixes something but not all of it.

Upon connecting CHDKPTP it sais:

ERROR: :80: module 'capmode' not found:
   no field package.preload['capmode']
   no file 'A/CHDK/SCRIPTS/capmode.lua'
   no file 'A/CHDK/LUALIB/capmode.lua'
user code: 1
Make sure you have the full CHDK package installed, A/CHDK/LUALIB/capmode.lua should exist.
Don't forget what the H stands for.

*

Offline koshy

  • *****
  • 1096
Re: Bug Report: || fixed for: TX1, IXUS 60, 65, 75, 100
« Reply #27 on: 30 / July / 2014, 17:23:13 »
Make sure you have the full CHDK package installed, A/CHDK/LUALIB/capmode.lua should exist.
Thank you. You're right. Putting the German CHDK onto a clean card was not the best idea. I re-tested it. The error messages I quoted are gone, the "ERROR: unsupported format" when shooting JPEG remains.
Koshy had a little ELPH which wasn't white as snow but everywhere that Koshy went the ELPH was sure to go. (actually an SD, but that detail ruins the rhyme...)


 

Related Topics


SimplePortal 2.3.6 © 2008-2014, SimplePortal