Adding feature support "Extended TV Range" (ETR): 30 Cams || 0 to go :-) - page 9 - General Discussion and Assistance - CHDK Forum

Adding feature support "Extended TV Range" (ETR): 30 Cams || 0 to go :-)

  • 184 Replies
  • 28957 Views
*

Offline koshy

  • *****
  • 1053
Advertisements
Test version for ixus750_sd550 100g
Also tested CHDKPTP on this one, both JPEG and DNG could be shot just fine.
Koshy had a little ELPH which wasn't white as snow but everywhere that Koshy went the ELPH was sure to go. (actually an SD, but that detail ruins the rhyme...)

*

Offline nafraf

  • *****
  • 1308
Test version for s2is 100f.
filewritetask() was not implemented, then remoteshoot -jpg does not work.
EDIT: New version with simpler loader code
« Last Edit: 10 / August / 2014, 11:36:52 by nafraf »

*

Offline koshy

  • *****
  • 1053
Quote from: nafraf
Test version for s2is 100f
- Verify long exposure
Done, 00:01:31 worked just fine

Quote from: nafraf
- Verify that a DNG is saved when you press the shutter quickly without waiting for auto-focus
Yes, that works. 5 full and half presses => 5 DNGs

Quote from: nafraf
- Verify USB remote switch operation
This also works on the S2 IS.


filewritetask() was not implemented, then remoteshoot -jpg does not work.
O.k. Didn't test CHDKPTP at all.

EDIT: New version with simpler loader code
Yes, that's the version I used.
Koshy had a little ELPH which wasn't white as snow but everywhere that Koshy went the ELPH was sure to go. (actually an SD, but that detail ruins the rhyme...)

*

Offline nafraf

  • *****
  • 1308
Thanks.
ixus700_sd500, ixus750_sd550, and s2is updated in trunk. Changeset 35593560, 3561


*

Offline nafraf

  • *****
  • 1308
Test version for ixus55_sd450 100d.
- filewritetask() was not implemented.
- modemap table is not complete. To fix it, please tell me the value of property 0 for each capture mode.
« Last Edit: 10 / August / 2014, 11:37:04 by nafraf »

*

Offline nafraf

  • *****
  • 1308
Test version for ixus50_sd400 101b
- filewritetask() was not implemented.
« Last Edit: 05 / October / 2014, 00:49:55 by nafraf »

*

Offline koshy

  • *****
  • 1053
Test version for ixus55_sd450 100d.
- modemap table is not complete. To fix it, please tell me the value of property 0 for each capture mode.
Here is the Table:

Manual 0
Digital Macro 2
My Colors 3
Stitching Assist 4
Auto 5
Portrait 6
Foliage 7
Snow 8
Beach 9
Underwater 10
Indoor 11
Night Snapshot 12
Kids&Pets 13
Fireworks 14
Video 15

I set all in camera modes I'm aware of. Mode 1 is missing on the list.

I use CHDKPTP to set the following:
=set_prop(0,1)
=set_prop(0,16)
I shot a JPEG manually with each setting active. An exif dump of the two JPEGs is enclosed.
Koshy had a little ELPH which wasn't white as snow but everywhere that Koshy went the ELPH was sure to go. (actually an SD, but that detail ruins the rhyme...)

*

Offline koshy

  • *****
  • 1053
Quote from: nafraf
Test version for ixus55_sd450 100d
- Verify long exposure
Done, 00:01:31 worked just fine

Quote from: nafraf
- Verify that a DNG is saved when you press the shutter quickly without waiting for auto-focus
Yes, that works. 7 full and half presses => 7 DNGs

Quote from: nafraf
- Verify USB remote switch operation
This currently does not work. The mask seems to be wrong.

Without USB cable: PS1: 0x24340f82
With USB cable plugged in: PS1: 0x24340fc2
Koshy had a little ELPH which wasn't white as snow but everywhere that Koshy went the ELPH was sure to go. (actually an SD, but that detail ruins the rhyme...)


*

Offline koshy

  • *****
  • 1053
Quote from: nafraf
Test version for ixus50_sd400 101b
- Verify long exposure
Done, 00:01:31 worked fine

Quote from: nafraf
- Verify that a DNG is saved when you press the shutter quickly without waiting for auto-focus
Yes, that works. 5 full and half presses => 5 DNGs

Quote from: nafraf
- Verify USB remote switch operation
This does not work. In fact it gives the same behavior as IXUS 700.
That is when in one of the shooting modes USB plug-in / unplug does not have any effect on the Misc Debug Values.

In shooting mode this value stays constant: PS1: 0x0000affe

In play mode: PS1: 0x0000affe => PS1: 0x0000aefe

Note that even the hex values are identical as on IXUS 700.


- filewritetask() was not implemented.
O.k. CHDKPTP not tested at all.

Note: I found that IXUS 50 also suffers from a bug detailed in another thread.
Koshy had a little ELPH which wasn't white as snow but everywhere that Koshy went the ELPH was sure to go. (actually an SD, but that detail ruins the rhyme...)

*

Offline nafraf

  • *****
  • 1308
Without USB cable: PS1: 0x24340f82
With USB cable plugged in: PS1: 0x24340fc2
:-[ On ixus55_sd450 get_usb_bit() just returned 0. Please test version in attachment.
« Last Edit: 10 / August / 2014, 11:37:20 by nafraf »

 

Related Topics