supplierdeeply

Bug report: motion detection during night

  • 3 Replies
  • 623 Views
Bug report: motion detection during night
« on: 04 / August / 2014, 13:22:37 »
Advertisements
I noticed a problem with motion detection during the night when e.g. capturing lightnings.

a) I manually set a low ISO mode such as 100 and start a motion detection script. The screen/preview is usually very dark at this point.
b) Camera waits for motion detection
c) Camera takes photo
d) Camera prepares for new photo, sometimes by ramping up the ISO mode for the screen/preview
e) Step d takes too long or happens so late that motion detection already started and md funtion identifies the change from dark to slightly less dark on screen as motion. Proceed with step c.

Step e doesn't happen always but usually occurs after a few image capturing cycles. And if it occurs the script/camera repeats the cycle indefinitely or until it is stopped manually. This is quite annoying because this means that the camera needs constant supervision to prevent random images being taken :(
Is this a bug/feature of the A4000 release or a general problem? Thanks in advance.

Re: Bug report: motion detection during night
« Reply #1 on: 04 / August / 2014, 13:27:34 »
Ok, I found a thread from 2008 describing the same problem but no solution to it. Meh.

Re: Bug report: motion detection during night
« Reply #2 on: 04 / August / 2014, 15:58:29 »
Did you try adjusting the delay parameter (usually designated "p")? 

http://chdk.wikia.com/wiki/Motion_Detection#Performance_Tuning_.28Sensitivity.29
Ported :   A1200    SD940   G10    Powershot N    G16

Re: Bug report: motion detection during night
« Reply #3 on: 05 / August / 2014, 15:54:59 »
I guess the parameter is what I was looking for. Hadn't seen it before  :-[ Thank you!


 

Related Topics