I still think the menu entry could have a better wording, and perhaps the code could be improved some way, so suggestions are welcome.
Flash hot shoe . I think that the Auto/On/Off labels make that self explanatory - or at least no less clear than when the word occupied in added.
I'd put it on the Enhanced Photo Operations menu right with the other Flash related overrides and above ND filter state.
Quote from: koshy on 27 / September / 2014, 12:23:30I'd put it on the Enhanced Photo Operations menu right with the other Flash related overrides and above ND filter state.The reason I put it elsewhere is that this isn't strictly a photo related option. I agree though that having all flash related settings in one place is good.
Quote from: koshy on 23 / September / 2014, 20:41:02I tested it and G7 also works correctly when 'Flash hot shoe occupied' is set to 'Off'.Thx for that too.Since there are now a handful of tested cameras, should this feature be made official? I still think the menu entry could have a better wording, and perhaps the code could be improved some way, so suggestions are welcome.Somebody with an sx20 could experiment with this, otherwise this override alone won't work on that model.
I tested it and G7 also works correctly when 'Flash hot shoe occupied' is set to 'Off'.
For example, I recently discovered the CHDK GPS menu for my S100 and (with all due respect to the author) I realized I'm going to have to read the code to figure out what it does. Staring at the menu entries does not tell me a lot.
I'd suggest 'Hotshoe switch override' for the menu text, and move it to the 'Extra Photo Operations' menu (with the other flash overrides). Having both 'flash' and 'hotshoe' in the text seems redundant (what other hotshoe is there?).
I'm not sure about the menu text for the various options - the current values are confusing to me in that they don't really reflect what is happening (IMO).
I'm now considering the usage of localized strings for the options...
Another suggestion that might make it easier to understand would be to use two-variable (bool for override enable / disable and an int for the forced state). The menu entry could then be a MENUITEM_STATE_VAL_PAIR so it shows with both the checkbox and value in the menu.
Current wording isHotshoe override [Off/Empty/In use]
Started by cantain
Hotwire! Hardware Mods, Accessories and Insights
Started by NaveedESahar
General Help and Assistance on using CHDK stable releases
Started by jairbj
Started by jairbj
Completed and Working Scripts