Corrupted DNG images from ELPH 110HS

  • 9 Replies
  • 1815 Views
*

Offline Vor

  • *
  • 5
Corrupted DNG images from ELPH 110HS
« on: 20 / September / 2014, 10:34:08 »
Advertisements
Hello I've tried firmware 1.2 (all sub-versions) and 1.3 (AFAIK) and I always get corrupted DNG images from my 110HS.
This was not always the case. It used to put out excellent RAW photos, and I don't know what has changed alas.
Can someone advise what can be done to fix this problem?

*

Offline srsa_4c

  • ******
  • 3686
Re: Corrupted DNG images from ELPH 110HS
« Reply #1 on: 20 / September / 2014, 11:51:12 »
Hello I've tried firmware 1.2 (all sub-versions) and 1.3 (AFAIK) and I always get corrupted DNG images from my 110HS.
This was not always the case. It used to put out excellent RAW photos, and I don't know what has changed alas.
Some questions.
- Did you upgrade CHDK before you started getting corrupted images, or it started to happen with an older installation you were using for a long time?
- Are the corresponding JPEGs also corrupted?
- How often do you get these corruptions?

Your 1st image consists of two recognizable parts which clearly don't belong to the same photo.
Can you upload a damaged dng somewhere along with its JPEG pair?

BTW,
(all sub-versions)
always use the release which corresponds to your firmware version, for example 101a is not "better" than 100e.

edit:
fabri22's advice makes sense, so only upload a DNG if you were using P mode for the corrupted photos.
« Last Edit: 20 / September / 2014, 19:30:47 by srsa_4c »

Re: Corrupted DNG images from ELPH 110HS
« Reply #2 on: 20 / September / 2014, 17:33:34 »
Can someone advise what can be done to fix this problem?
Same camera here and RAWs are fine (thanks CHDK guys !).
Just switch to P mode.
 ;)

*

Offline Vor

  • *
  • 5
Re: Corrupted DNG images from ELPH 110HS
« Reply #3 on: 21 / September / 2014, 22:31:16 »
- Did you upgrade CHDK before you started getting corrupted images, or it started to happen with an older installation you were using for a long time?
- Are the corresponding JPEGs also corrupted?
- How often do you get these corruptions?
Your 1st image consists of two recognizable parts which clearly don't belong to the same photo.
Can you upload a damaged dng somewhere along with its JPEG pair?
Hi, the JPEGs are not usually corrupted but sometimes they are. The DNGs now are always corrupted. When the problem started, some DNGs were not corrupted and some were. As for upgrades, I recall several phases:
First I used a CHDK that did not allow DNGs at all because I assume of my  lacking the badpixels file.
Then I  upgraded and things were fine for a while.
Then I may have reinstalled after an accidental reformat of the SD card and everything was awful.
Then I reformatted and reinstalled onto the SD and everything remained awful.
I did a reformat and installed ixus125_elph110hs-101a-1.3.0-3620-full_ALPHA.zip on the SD.
« Last Edit: 21 / September / 2014, 23:05:34 by Vor »


*

Offline Vor

  • *
  • 5
Re: Corrupted DNG images from ELPH 110HS
« Reply #4 on: 21 / September / 2014, 23:07:35 »
- Did you upgrade CHDK before you started getting corrupted images, or it started to happen with an older installation you were using for a long time?
- Are the corresponding JPEGs also corrupted?
- How often do you get these corruptions?
Your 1st image consists of two recognizable parts which clearly don't belong to the same photo.
Can you upload a damaged dng somewhere along with its JPEG pair?
Hi, the JPEGs are not usually corrupted but sometimes they are. The DNGs now are always corrupted. When the problem started, some DNGs were not corrupted and some were. As for upgrades, I recall several phases:
First I used a CHDK that did not allow DNGs at all because I assume of my  lacking the badpixels file.
Then I  upgraded and things were fine for a while.
Then I may have reinstalled after an accidental reformat of the SD card and everything was awful.
Then I reformatted and reinstalled onto the SD and everything remained awful.
I did a reformat and installed ixus125_elph110hs-101a-1.3.0-3620-full_ALPHA.zip on the SD.

*

Offline Vor

  • *
  • 5
Re: Corrupted DNG images from ELPH 110HS
« Reply #5 on: 21 / September / 2014, 23:16:40 »
Just switch to P mode.

I tried that; it doesn't work. What did appear to work however was setting "DNG Crop Size" to Full.

No idea why that worked, or if it will last. But I now have several good CRW files. Thanks folks.

Here's a crop from one of them.
« Last Edit: 21 / September / 2014, 23:21:58 by Vor »

*

Online reyalp

  • ******
  • 11486
Re: Corrupted DNG images from ELPH 110HS
« Reply #6 on: 22 / September / 2014, 01:12:49 »
I tried that; it doesn't work. What did appear to work however was setting "DNG Crop Size" to Full.

No idea why that worked, or if it will last. But I now have several good CRW files. Thanks folks.
Very unlikely this would affect the kind of image corruption in you earlier posts, it should only change some values stored in the DNG header. So it's more likely the problem is just intermittent or depends on some other factor.
Don't forget what the H stands for.

*

Offline Vor

  • *
  • 5
Re: Corrupted DNG images from ELPH 110HS
« Reply #7 on: 27 / September / 2014, 12:21:10 »
Very unlikely this would affect the kind of image corruption in you earlier posts, it should only change some values stored in the DNG header. So it's more likely the problem is just intermittent or depends on some other factor.

It's not been an intermittent problem at all. Once it took hold, it happened 100% of the time. Initially it was maybe 50%. Several reinstalls of CHDK didn't fix the problem.

Then, I changed that one setting and it worked again. I'll test it some more, but as Sherlock Holmes says "when you have eliminated the impossible, whatever remains, however improbable, must be the truth".

I think you're assuming that CHDK has no bugs, which is unrealistic.


Re: Corrupted DNG images from ELPH 110HS
« Reply #8 on: 27 / September / 2014, 14:10:14 »
I think you're assuming that CHDK has no bugs, which is unrealistic.
Maybe it is unrealistic that nothing might be wrong with you. No offense!.
I've your same camera with the same firmware and RAWs are fine in P mode.
Below my CHDK RAW configs    ("DNG Crop Size" to JPEG)



Try these things:

1. Reset CHDK from its menu (CHDK Settings -> Reset Options to default) or (delete the CCHDK4.CFG file)
2. Set only the above config values

if still issues with RAWs:

3. Format your SD and reinstall the last CHDK 1.3 release and repeat #2

your last hope:

4. try with another sdhc

 ;)

*

Online reyalp

  • ******
  • 11486
Re: Corrupted DNG images from ELPH 110HS
« Reply #9 on: 28 / September / 2014, 00:19:21 »
I think you're assuming that CHDK has no bugs, which is unrealistic.
:lol No, having been a CHDK developer for the last ~6 years, I'm very well aware that there are many bugs. In that time I think I've managed to get a pretty good grasp of which things are likely to affect each other.

It's not completely impossible that setting could be responsible, but it seems unlikely to me.

@fabri:
Just because it works for you doesn't mean it isn't broken.

edit:
This issue with the sx170 http://chdk.setepontos.com/index.php?topic=11164.msg116923#msg116923 suggests there could be timing issues with some ports.
« Last Edit: 28 / September / 2014, 01:00:36 by reyalp »
Don't forget what the H stands for.

 

Related Topics