sx700 porting - page 7 - DryOS Development - CHDK Forum

sx700 porting

  • 153 Replies
  • 65321 Views
Re: sx700 porting
« Reply #60 on: 01 / January / 2018, 07:18:01 »
Advertisements
In my case, I appear to be getting a grid which is confined only to the top left quarter of the screen.
AFAIK what your are seeing is normal for a D6 port. It's not specific to your camera - the G16 does the exact same thing too.

The thread that I linked mostly talks about general issues with grids. That code is quite old, dating back to that early days of CHDK, and has not been maintained as Canon added new display sizes.
Ported :   A1200    SD940   G10    Powershot N    G16

*

Offline ftm

  • *
  • 43
Re: sx700 porting
« Reply #61 on: 01 / January / 2018, 11:31:33 »
waterwingz - Thanks.   It looks like the grid files have hard coded values for a smaller display. 320x240. Once I made a new grid file, it worked fine.

Re: sx700 porting
« Reply #62 on: 01 / January / 2018, 12:26:10 »
waterwingz - Thanks.   It looks like the grid files have hard coded values for a smaller display. 320x240. Once I made a new grid file, it worked fine.
One of the things on my "roundtuit" list is to update the grid code to scale the files to the actual display size (centered appropriately). Either that or allow CHDK to pick only appropriate grid files for the camera display size from an expanded set included with the build.

It's not a high priority as anyone who cares about this can simply edit their favorite grid file to suit their display.
Ported :   A1200    SD940   G10    Powershot N    G16

Re: sx700 porting
« Reply #63 on: 01 / January / 2018, 16:24:51 »
Here are some examples.
A good dng: JPG - DNG
and a bad: JPG - DNG
plus the covered text.
(A 410), SX 200, (SX 280), SX 700


*

Offline ftm

  • *
  • 43
Re: sx700 porting
« Reply #64 on: 01 / January / 2018, 17:46:33 »
Here are some examples.
A good dng: JPG - DNG
and a bad: JPG - DNG
plus the covered text.
Many thanks. It was a buffer issue. An updated version of the port is on the same post.

https://chdk.setepontos.com/index.php?topic=11927.msg135752#msg135752

Please let me know if this works for you.

Re: sx700 porting
« Reply #65 on: 01 / January / 2018, 18:31:01 »
plus the covered text.
The "covered text" is just several CHDK OSD elements all positioned in the same place on the LCD.  Go to the CHDK Settings menu, select OSD Layout Editor and move them apart.

Full instructions are here :  CHDK User Manual : OSD Layout Editor
Ported :   A1200    SD940   G10    Powershot N    G16

Re: sx700 porting
« Reply #66 on: 02 / January / 2018, 15:47:14 »
I can confirm that dng files are OK! Thank you for your quick improvement.
Actually I can move the covered text, but it would be much easier for the user, if this port would contain the right setting of OSD text for this camera.
And on its left side is still not perfectly visible, that is uncorrectable with the OSD layout editor. (but its just a minor cosmetic issue)
There is an option for startup sound. I can not activate. Is there any in this camera?
If I set CHDKSettings/OSD settings "Hide in ?" (don't need the SPACE) for "Don't", the text with red characters disappear on half-press. Why? Bug or feature?

And one more thing... the flickering is over!  :D
(A 410), SX 200, (SX 280), SX 700

*

Offline ftm

  • *
  • 43
Re: sx700 porting
« Reply #67 on: 02 / January / 2018, 16:14:50 »
I can confirm that dng files are OK! Thank you for your quick improvement.
Actually I can move the covered text, but it would be much easier for the user, if this port would contain the right setting of OSD text for this camera.
And on its left side is still not perfectly visible, that is uncorrectable with the OSD layout editor. (but its just a minor cosmetic issue)
There is an option for startup sound. I can not activate. Is there any in this camera?
If I set CHDKSettings/OSD settings "Hide in ?" (don't need the SPACE) for "Don't", the text with red characters disappear on half-press. Why? Bug or feature?

And one more thing... the flickering is over!  :D
Thank you for your testing report. Glad that the DNG issue is fixed.

I will check on the startup sound. Check your camera Menu setting. Mine was in Mute mode.

Thanks also for confirming that the flickering is over. It is also gone on mine as well. I cleaned up some of the unidentified stubs. Maybe one of those fixed it.

Also, not sure if the OSD screen setting can be easily changed. Can you post another picture of the Left side OSD setting  that is not fixable?

The OVERRIDE Display (Red characters) disappears for me as well on half-press. I do not see any menu option of keeping it on.  (Edit: Other items on the OSD such as RAW state etc., also disappear on Half-press while items like Time, Battery, Space remain. Also, if you change the color of the OVERRIDE text to white, the visibility appears to be improved. I don't know if that is what you mean. )

If there are any other tests that you do please do post in this thread. It will help in improving this port and then we can include it as an autobuild.
« Last Edit: 02 / January / 2018, 19:36:20 by ftm »


*

Offline reyalp

  • ******
  • 11919
Re: sx700 porting
« Reply #68 on: 03 / January / 2018, 00:55:19 »
SX700 100e is in the autobuild as of 4970

I made some cosmetic changes from the github code in 4969 https://app.assembla.com/spaces/chdk/subversion/commits/4969

I also removed bin_comp_fix.h in the original commit, the autogenerated one should be functionality equivalent.

Additional comments:
Modes 16943 and 16945 are probably "wink self timer" and "face self timer" (not necessarily in that order)
On SX710, these are accessed from the "smile detection" mode by pressing disp.

Has anyone tested set_led? If AF LED control is working, you should be able to check MD_Tune http://chdk.wikia.com/wiki/Testing#MD_tune.bas

If filewrite, the logging stuff should be under an ifdef, like g7x/sx710. I try not to leave these enabled by default in autobuilds because it leaves a permanent trace of CHDK if there's a romlog (OTOH, the existence of a romlog is a pretty strong clue)

The aspect ratio stuff ( vp_xo etc) in lib.c has a TODO on it. I would expect this is the same as sx710, but can be easily checked using chdkptp GUI live view and going through the available aspect ratios in the the func menu.
Don't forget what the H stands for.

Re: sx700 porting
« Reply #69 on: 03 / January / 2018, 01:16:30 »
Yep, mine was in mute mode too. Sound is OK! :)
(A 410), SX 200, (SX 280), SX 700

 

Related Topics