Remote Zoom Strange Behavior w/A4000 - page 2 - Hello, I'm a NEWBIE - HELP!! (Newbies assistance, User Guides and thank you notes) - CHDK Forum supplierdeeply

Remote Zoom Strange Behavior w/A4000

  • 20 Replies
  • 2863 Views
Re: Remote Zoom Strange Behavior w/A4000
« Reply #10 on: 04 / October / 2014, 13:24:53 »
Advertisements
I used CHDK (Show build info) to get the version numbers. I have both 101a and 101b, one per camera.
Good grief, I expected refurbs that come directly from Canon would have the latest version!

Now what do I do?
Thanks.

Re: Remote Zoom Strange Behavior w/A4000
« Reply #11 on: 04 / October / 2014, 13:31:52 »
I used CHDK (Show build info) to get the version numbers. I have both 101a and 101b, one per camera.
Good grief, I expected refurbs that come directly from Canon would have the latest version! Now what do I do?
Don't panic  - load them separately.   Here's both versions   (1.3.0 release - SD card lock loading only).

Just unzip each version (with full directory structure expanded) to the correct card.  STICK will have set everything else up correctly - you just need to replace the CHDK files.
Ported :   A1200    SD940   G10    Powershot N    G16

Re: Remote Zoom Strange Behavior w/A4000
« Reply #12 on: 04 / October / 2014, 14:28:21 »
Thanks. I only updated the 101a camera so far.

I get to zoom level 10, then the same problems occur. Can't step in further, can only step out one level.
Your folder name says 1.3.0-3638,  but on bootup the camera says 1.2.0-3598.

Should I try the b version?

Update:
Just tried the 101b camera. Results are identical to above.
« Last Edit: 04 / October / 2014, 14:38:11 by VinzVideo »

Re: Remote Zoom Strange Behavior w/A4000
« Reply #13 on: 04 / October / 2014, 15:07:28 »
Thanks. I only updated the 101a camera so far.

I get to zoom level 10, then the same problems occur. Can't step in further, can only step out one level.
Your folder name says 1.3.0-3638,  but on bootup the camera says 1.2.0-3598.

Should I try the b version?

Update:
Just tried the 101b camera. Results are identical to above.
If the camera says 1.2.0-3598 then you are still running the old code.  I'm guessing that you did not unzip the 1.3.0-3638 version correctly to the SD card? Note that you have to unzip that rather than just copying the zip file to the card.

Ported :   A1200    SD940   G10    Powershot N    G16


Re: Remote Zoom Strange Behavior w/A4000
« Reply #14 on: 04 / October / 2014, 15:31:02 »
I unzipped the files into their own folders on the PC.
Then I deleted the "old" CHDK folders on the cards, and copied the new ones in their place. You mentioned that the CHDK folder was the only thing that needed to be replaced.
I definitely unzipped the files, that's how I was able to copy just the CHDK folder.

I didn't know unzipping directly to the card would make a difference, but I will try.

Thanks.

Re: Remote Zoom Strange Behavior w/A4000
« Reply #15 on: 04 / October / 2014, 15:49:48 »
You mentioned that the CHDK folder was the only thing that needed to be replaced.
Sorry - that was confusing.   You need the files in the root directory too - especially the one called DISKBOOT.BIN

Ported :   A1200    SD940   G10    Powershot N    G16

Re: Remote Zoom Strange Behavior w/A4000
« Reply #16 on: 04 / October / 2014, 16:11:53 »
YESSSSS !!

Zooms in by steps of 12 - perfect. Zooms out perfectly too.
Now I have a clear mind and can finish building the rig.

Seriously, I have both Mac and PC experience (lots!), but I didn't know that unzipping to the card itself would make a difference. I appreciate your efforts! I'm curious - is this patch just for me and the other megazoom cameras, or will become part of the next release?

This has been a terrific experience...I spent a lot of time going over the design of my controller, thinking it was the problem. But it wasn't. I use a 9v battery (out of convenience) and a simple voltage divider to get the 4.5v USB trigger.

Thank you for coming to the rescue!


Just saw your last reply.......the first time, I replaced ONLY the CHDK folder on the card with the new unzipped one. I never changed any root-level files on the card.
Don't worry, It's looking good now.


Re: Remote Zoom Strange Behavior w/A4000
« Reply #17 on: 04 / October / 2014, 16:23:59 »
I'm curious - is this patch just for me and the other megazoom cameras, or will become part of the next release?
I'll submit patches for all cameras on 1.2.0 & 1.3.0 . 

I think this passes the sniff test as a bug fix rather than a new feature.
Ported :   A1200    SD940   G10    Powershot N    G16


Re: Remote Zoom Strange Behavior w/A4000
« Reply #18 on: 04 / October / 2014, 16:31:42 »
Hmmm, does that mean there are other patches I might be interested in - or does what I downloaded have the latest patches?

Re: Remote Zoom Strange Behavior w/A4000
« Reply #19 on: 04 / October / 2014, 16:34:09 »
Hmmm, does that mean there are other patches I might be interested in - or does what I downloaded have the latest patches?
What I sent you is the most recent of everything.  By tomorrow, the autobuild should have the same thing.
Ported :   A1200    SD940   G10    Powershot N    G16

 

Related Topics