supplierdeeply

Adding custom colors, getting APB values, checking palettes for numerous cameras

  • 32 Replies
  • 3452 Views
*

Offline koshy

  • *****
  • 799
Advertisements
After seeing that is is difficult to follow post of palettes bugs on each model porting thread, I think that it is better to centralize the work :)
So that's what we'll do.

Starting with the easy models, cameras where active_palette_buffer was autodetected by finsig. For those I got APBs and palette screen shots:

A1100 worked on here (needs to be revisited as described on that thread)
A2100
A3200
D10
IXUS 100
IXUS 105
IXUS 110
IXUS 125
IXUS 200
IXUS 95 worked on here
IXUS 980 worked on here
IXUS 1000
SX20
SX30
SX120
« Last Edit: 07 / November / 2014, 18:13:13 by koshy »

*

Offline koshy

  • *****
  • 799
I tried compiling the APB patch nafraf made for 35 cameras. Many failed to compile with an error of this general nature:

Code: [Select]
../platform/a1000/sub/100b/libplatformsub.a(gui_osd.thm.o): In function `gui_draw_debug_vals_osd':
gui_osd.c:(.text+0x2054): undefined reference to `active_palette_buffer'

*

Offline koshy

  • *****
  • 799
A3200 APB: Rec 0, Play 4

DONE
« Last Edit: 31 / October / 2014, 20:25:56 by koshy »

*

Offline koshy

  • *****
  • 799
D10 APB: Rec 0, Play 1


*

Offline koshy

  • *****
  • 799
I100 Disp to enter Alt, APB: Rec 0, Play 1

DONE
« Last Edit: 31 / October / 2014, 20:25:39 by koshy »

*

Offline koshy

  • *****
  • 799
I110 APB: Rec 0, Play 2

DONE
« Last Edit: 31 / October / 2014, 20:25:25 by koshy »

*

Offline koshy

  • *****
  • 799
I125 APB: Rec 0, Play 5

DONE
« Last Edit: 31 / October / 2014, 20:52:48 by koshy »

*

Offline koshy

  • *****
  • 799
I200 APB: Rec 0, Play 6


*

Offline koshy

  • *****
  • 799
SX120 Face to enter Alt, APB: Rec 0, Play 5

*

Offline koshy

  • *****
  • 799
SX20 APB: Rec 0, Play 5

 

Related Topics