A3300 after zooming is not portprocessed properly

  • 2 Replies
  • 882 Views
A3300 after zooming is not portprocessed properly
« on: 03 / December / 2014, 05:44:38 »
Advertisements
Hi,

I'm using an A3300 camera with 1.0.0d, CHDK 1.3.0 Rev 3757.
when shooting a picture like:
Quote
con 4> shoot -tv=0.04 -sv=52.0 -dng=0 -rm -dl
A/DCIM/108___12/IMG_0070.JPG->IMG_0070.JPG
A/DCIM/108___12/IMG_0070.JPG: OK
The image is correct, when doing it like zooming on it:
Quote
con 8> lua set_zoom(4)
con 9>  shoot -tv=0.04 -sv=52.0 -dng=0 -rm -dl
A/DCIM/108___12/IMG_0071.JPG->IMG_0071.JPG
A/DCIM/108___12/IMG_0071.JPG: OK
The image will be curved on the sides, and such I cannot use it for OCR or other purposes.
I attached both images, after resizing to smaller resolution so it can be attached.

Is this a bug in CHDK or I missed some setting?
Thanks,
aladar

*

Offline philmoz

  • *****
  • 3070
    • Photos
Re: A3300 after zooming is not portprocessed properly
« Reply #1 on: 03 / December / 2014, 06:32:39 »
Try the attached version.

This uses an alternate version of the zoom code that has fixed similar issues on other cameras.

Phil.
CHDK ports:
  sx30is (1.00c, 1.00h, 1.00l, 1.00n & 1.00p)
  g12 (1.00c, 1.00e, 1.00f & 1.00g)
  sx130is (1.01d & 1.01f)
  ixus310hs (1.00a & 1.01a)
  sx40hs (1.00d, 1.00g & 1.00i)
  g1x (1.00e, 1.00f & 1.00g)

Re: A3300 after zooming is not portprocessed properly
« Reply #2 on: 03 / December / 2014, 07:10:27 »
Perfect, it works fine with it, see attached image, just captured after zooming. No spreads is complaining about a lua file. Let me discuss that with Jbaiter.

Thanks for the superfast resolution.
aladar

 

Related Topics