A1100 IS Porting thread - page 65 - DryOS Development - CHDK Forum supplierdeeply

A1100 IS Porting thread

  • 646 Replies
  • 142016 Views
*

Offline srsa_4c

  • ******
  • 4105
Re: A1100 IS Porting thread
« Reply #640 on: 31 / January / 2016, 12:13:33 »
Advertisements
I am not sure which card I used the last time, are these sdhc-problems normal for this cam?
If you have problems with the card, try formatting it in camera (low level), then use STICK (or your favourite method from here) again to set it up. Make sure the CHDK folder and its content is on the big partition.

If the card is a slower one or it's filled with pictures, the camera might need longer time to scan it after start.
That initial scan may also cause the palette issue you're experiencing - CHDK only manipulates the palette in certain known camera states (and the initial card scan may be one of the unsupported states).

Once the card scan is over (the LED stops blinking), do you get proper colors for the CHDK screen elements (clock, battery, etc) with the 4285 build?

*

Offline brett stevens

  • *
  • 2
  • Interested in infrared and macro photography
Re: A1100 IS Porting thread
« Reply #641 on: 20 / May / 2017, 14:08:43 »
I have succesfully installed a1100-100a-1.4.0-4285-full.zip on a A1100 and taen a picture with the DNG enabled.  I sometimes have the issue of the  CHDK graphics being white on a white background but it is not all the time.  Is there anything else I can test to help the development?

Re: A1100 IS Porting thread
« Reply #642 on: 20 / May / 2017, 14:17:03 »
I sometimes have the issue of the  CHDK graphics being white on a white background but it is not all the time.  Is there anything else I can test to help the development?
Can you be a little more specific about what you mean by "graphics"?

For example, do you mean the CHDK menus?  Or the CHDK OSD elements (like clock, temperature, shots left etc)?  Or the functions like edge overlay, histogram, zebra?
Ported :   A1200    SD940   G10    Powershot N    G16

*

Offline brett stevens

  • *
  • 2
  • Interested in infrared and macro photography
Re: A1100 IS Porting thread
« Reply #643 on: 20 / May / 2017, 16:26:10 »
I sometimes have the issue of the  CHDK graphics being white on a white background but it is not all the time.  Is there anything else I can test to help the development?
Can you be a little more specific about what you mean by "graphics"?


It was the OSD: the "<ALT>", "Default Script", the clock and temperature.  But it has not happened the last two times I have turned the camera on.  I have just checked the histogram, zebra and edge overlay and they are all fine (but so is everything right now)

Is there something else I can test to help this port?


Re: A1100 IS Porting thread
« Reply #644 on: 20 / May / 2017, 17:54:09 »
It was the OSD: the "<ALT>", "Default Script", the clock and temperature.  But it has not happened the last two times I have turned the camera on.  I have just checked the histogram, zebra and edge overlay and they are all fine (but so is everything right now)
You may see "funny" CHDK colors if you activate <ALT> mode in anything other than playback or shooting modes.  (e.g. open the Canon menus and then enter <ALT>).  It's technically possible to detect and fix that but AFAIK nobody has bothered as it's kind of a rare edge case.

Quote
Is there something else I can test to help this port?
The port was released more than five years ago.  Feel free to look for problems but nobody is doing any active work on it these days.
Ported :   A1200    SD940   G10    Powershot N    G16

*

Offline nafraf

  • *****
  • 1308
Re: A1100 IS Porting thread
« Reply #645 on: 20 / May / 2017, 19:00:58 »
The port was released more than five years ago.  Feel free to look for problems but nobody is doing any active work on it these days.
100a firmware has not been included in svn. :blink:

I think that brett stevens used the last compiled version posted by srsa_4c.
« Last Edit: 20 / May / 2017, 19:03:53 by nafraf »

Re: A1100 IS Porting thread
« Reply #646 on: 20 / May / 2017, 19:20:33 »
The port was released more than five years ago.  Feel free to look for problems but nobody is doing any active work on it these days.
100a firmware has not been included in svn. :blink:

I think that brett stevens used the last compiled version posted by srsa_4c.

In that case, running the port through the tests on this page and reporting the results would be useful : CHDK Testing
Ported :   A1200    SD940   G10    Powershot N    G16

 

Related Topics