supplierdeeply

Measuring exposure performance (was Re: proposal - script shooting hooks)

  • 79 Replies
  • 14398 Views
*

Offline reyalp

  • ******
  • 10966
Advertisements
This method has one big disadvantage for timelapse. I this mode (which I use in my script) the camera always open the aperture for measure.
Understood, I'm not suggesting using it for timelapse, I'm just trying to understand the behavior of the G1x.
Don't forget what the H stands for.

*

Offline philmoz

  • *****
  • 3049
    • Photos
This method has one big disadvantage for timelapse. I this mode (which I use in my script) the camera always open the aperture for measure.
Understood, I'm not suggesting using it for timelapse, I'm just trying to understand the behavior of the G1x.

I've done a bit more experimenting.

When Tv >= 1.3s and ISO > 320:
    - If ISO set manually in Canon settings
        - black point = 2048 (in DNG, CR2 has black = 512)
        - camera shoots at selected ISO
        - max raw image value in DNG = 16384, in CR2 = 14847
        - raw image values in CR2 file = raw image values in DNG - 1536 (2048 - 512)
    - If ISO set using AUTO mode (Canon setting or CHDK override)
        - black point = 2048 (in DNG, CR2 has black = 512)
        - camera shoots at 1/2 selected ISO
        - max raw image value in DNG = 16384, in CR2 = 16384
        - raw image values in CR2 file = raw image values in DNG - 1536, then scaled up by some factor

So Canon is setting the sensor/ADC to a higher black point; but then fudging the raw data in the CR2 file to pretend the black is actually 512. When AUTO ISO is selected it also shoots at 1/2 the selected ISO and scales the raw image data to get the max value back to 16384.

I haven't found a point in the code where the raw buffer data has been changed - it's probably being on the Digic processor as the file is being saved.

It may be possible to 'compensate' for this behaviour in the raw meter - e.g. detect if camera is G1X, Tv >= 1.3s and ISO > 320, then adjust meter calculation. It would also need to take the calculated black point into account.

I have also seen some cases where the camera shoots at 1/2 ISO but with a black point of 512 - I have not determined the cases where this occurs yet.

Phil.
CHDK ports:
  sx30is (1.00c, 1.00h, 1.00l, 1.00n & 1.00p)
  g12 (1.00c, 1.00e, 1.00f & 1.00g)
  sx130is (1.01d & 1.01f)
  ixus310hs (1.00a & 1.01a)
  sx40hs (1.00d, 1.00g & 1.00i)
  g1x (1.00e, 1.00f & 1.00g)

*

Offline reyalp

  • ******
  • 10966
I have also seen some cases where the camera shoots at 1/2 ISO but with a black point of 512 - I have not determined the cases where this occurs yet.
This is seen in a couple of c_joerg's posts earlier:
http://chdk.setepontos.com/index.php?topic=12165.msg122608#msg122608
http://chdk.setepontos.com/index.php?topic=12165.msg122627#msg122627

In both of the above, Tv was 1.8 sec

The other kink in this is that the transitions don't seem to be at the same point: The 1/2 ISO seems to kick in at 400, while the black point does at 320.  (edit: in the samples I've seen any way)

« Last Edit: 08 / June / 2015, 01:13:15 by reyalp »
Don't forget what the H stands for.

Made just a run on G1X with R4191 in continues mode and ISO set mode Script.
The run looks simular to r4138 (EXIF ISO OK, JPG OK).
EOS M3 101a, 2*G1x (101a,100e), S110 (103a), SX50 (100c), SX230 (101a), IXUS160 (100a), IXUS30 (100k), 2*S45,
Flickr https://www.flickr.com/photos/[email protected]/albums
YouTube https://www.youtube.com/channel/UCrTH0tHy9OYTVDzWIvXEMlw/videos?shelf_id=0&view=0&sort=dd


*

Offline reyalp

  • ******
  • 10966
Made just a run on G1X with R4191 in continues mode and ISO set mode Script.
The run looks simular to r4138 (EXIF ISO OK, JPG OK).
Yeah, I think it's not really affected. It appears that the blacklevel jump at ISO 320 doesn't happen at all with these settings (it didn't happen in the r4138 run either). The ISO drop at 400 (compensated in jpeg) is still there, and would still cause problems for rawopint because even though the jpeg is OK, the raw meter value changes suddenly. It's possible a G1x specific workaround could be implemented in rawopint.
Don't forget what the H stands for.

*

Offline reyalp

  • ******
  • 10966
Here's an updated isoinc.lua for trunk r4193.

Other changes:
* Added "ISO input type" If set to ISO, the start and end values are interpreted as Canon UI ISO. If set to SV96, they are interpreted as "real" SV96 values as in previous versions.
* More detailed logging.
Don't forget what the H stands for.

A new run on G1X with R4193 in continues mode and ISO set mode Script would be useful?
EOS M3 101a, 2*G1x (101a,100e), S110 (103a), SX50 (100c), SX230 (101a), IXUS160 (100a), IXUS30 (100k), 2*S45,
Flickr https://www.flickr.com/photos/[email protected]/albums
YouTube https://www.youtube.com/channel/UCrTH0tHy9OYTVDzWIvXEMlw/videos?shelf_id=0&view=0&sort=dd

*

Offline reyalp

  • ******
  • 10966
A new run on G1X with R4193 in continues mode and ISO set mode Script would be useful?
Both "script" and "CHDK" modes might be helpful. Thanks.
Don't forget what the H stands for.


I’m getting more and more confused about stuff with G1X ;)
What about philmoz change in r4153? The still have an effect on this runs?
I make 3 runs with isoinc r4193 from sv96=520 until 740.
I’m not sure, if we had the combination quick/script before…

1) shoot_mode=cont  / iso_method=script
2) shoot_mode=cont  / iso_method=chdk
3) shoot_mode=quick / iso_method=script

I put ‘*’ for ISO320 and ‘o’ for ISO400 in the plot from meter96.
Interesting is the run quick/script. There is an offset from around 16 which I have not seen before…
EOS M3 101a, 2*G1x (101a,100e), S110 (103a), SX50 (100c), SX230 (101a), IXUS160 (100a), IXUS30 (100k), 2*S45,
Flickr https://www.flickr.com/photos/[email protected]/albums
YouTube https://www.youtube.com/channel/UCrTH0tHy9OYTVDzWIvXEMlw/videos?shelf_id=0&view=0&sort=dd

I’m wondering that EXIF ISO is for all runs OK.
I thought it must be wrong on the combination cont/chdk.
But the combination cont/chdk shows still the ½ ISO kick on JPG data which I expect.
EOS M3 101a, 2*G1x (101a,100e), S110 (103a), SX50 (100c), SX230 (101a), IXUS160 (100a), IXUS30 (100k), 2*S45,
Flickr https://www.flickr.com/photos/[email protected]/albums
YouTube https://www.youtube.com/channel/UCrTH0tHy9OYTVDzWIvXEMlw/videos?shelf_id=0&view=0&sort=dd

 

Related Topics