Ixus300 / SD4000 - Still BETA, can I still find and download CHDK 1.1? - page 2 - CHDK Releases - CHDK Forum supplierdeeply

Ixus300 / SD4000 - Still BETA, can I still find and download CHDK 1.1?

  • 38 Replies
  • 8017 Views
*

Offline I2k4

  • *
  • 28
Re: Ixus300 / SD4000 - Still BETA, can I still find and download CHDK 1.1?
« Reply #10 on: 19 / January / 2015, 11:35:56 »
Advertisements
I managed to give Phil's REMIX a "college try" on the problems I'm aware of.  I thought it best to compare what he did with the current stable CHDK 1.3 from the download page.

PREPARATION

I tried using "Stick" installation software, but it refused to recognize any Ixus300 JPEG saying "No official build is available for this camera". So the Stick process didn't get to the point of selecting any CHDK file or the SD Card - it simply won't identify Ixus300 images.  Not sure what this indicates.

I then tried the old "CardTricks" 144 software which worked normally on an old 2gb card (it is limited to 4gb cards, but still installs these current versions of CHDK on older cameras.)

CURRENT STABLE CHDK 1.3 v3920: 

CHDK 1.3 boots normally and most functions work normally, including the screen display of menus and OSD icons.  I tested the problem settings I know of, in sequence:
. Zebra Blink 2 flashes beween the normal screen with no Zebra and a full screen blowout (covering both black sidebars).  About 2/3 of the left is a large block of orange and 1/3 of the right side is a black block with speckles.
. Histogram set to blend, stays in its box but readings flash back and forth between one with peaks at edges and the other with peaks in the middle.  It fails on both "Always" and "Shoot" settings.  (Note that it works properly in CHDK 1.1)
. ND filter freezes and shuts down the camera except on "Off".  (Also borks CHDK 1.1, but does work in CHDK 1.2)
. Grids are the right size and form, but not centered properly in the image display.  They are pushed left in the black sidebar where the settings icons are.  I recall thinking this off-center Grid behavior might be related to the Zebra screen issues.

PHILMOZ REMIX from IXUS310 on CHDK 1.3 v3930:

REMIX boots and most functions appear normal. Problem settings:
. Zebra  Blink 2 orange area is not a block now but seems to shape to proper Zebra readings, but this display is off-center crowding into the left black sidebar.  The right 1/3 of the screen is still a black block with colored speckles, covering part of the image area and the right sidebar.
. Histogram (Blend) now appears to work correctly.
. ND Filter "In" or "Out" Appears to function correctly for one shot, but then freezes the camera with lens extended - have to use the Playback button to properly shut it down.
. Grids are still proper size and shape but off-center into the left black icon bar.

I hope this is useful - shows progress.  If Philmoz or anyone else wants me to try out another iteration or do something more with this one, I'm willing, but can't guarantee such quick turnaround. 

Again my thanks for all the effort on CHDK in general, and I'm looking forward to configuring and trying out 1.3 on my other cameras.
« Last Edit: 19 / January / 2015, 12:14:37 by I2k4 »
Appreciative end-user for several years:  S5is, SX10is, and SD4000is.

*

Offline philmoz

  • *****
  • 3136
    • Photos
Re: Ixus300 / SD4000 - Still BETA, can I still find and download CHDK 1.1?
« Reply #11 on: 19 / January / 2015, 16:27:22 »
REMIX boots and most functions appear normal. Problem settings:
. Zebra  Blink 2 orange area is not a block now but seems to shape to proper Zebra readings, but this display is off-center crowding into the left black sidebar.  The right 1/3 of the screen is still a black block with colored speckles, covering part of the image area and the right sidebar.
. Histogram (Blend) now appears to work correctly.
. ND Filter "In" or "Out" Appears to function correctly for one shot, but then freezes the camera with lens extended - have to use the Playback button to properly shut it down.
. Grids are still proper size and shape but off-center into the left black icon bar.

That's good, at least the viewport buffers are working better - now we just need to get the offsets working correctly.

I will need to add some diagnostic displays to the next version, to work out the correct offsets - hopefully I'll be able to get something later tonight or tomorrow.

Not sure about the ND filter - the functions being used are not the same as the ones found by the signature finder, I will have to check the firmware.

The grid display is working as expected; the problem is that the supplied grids assume a 4:3 aspect ratio LCD and the co-ordinates in the grids are not adjusted to cater for a widescreen display.

Phil.
CHDK ports:
  sx30is (1.00c, 1.00h, 1.00l, 1.00n & 1.00p)
  g12 (1.00c, 1.00e, 1.00f & 1.00g)
  sx130is (1.01d & 1.01f)
  ixus310hs (1.00a & 1.01a)
  sx40hs (1.00d, 1.00g & 1.00i)
  g1x (1.00e, 1.00f & 1.00g)
  g5x (1.00c, 1.01a, 1.01b)

*

Offline philmoz

  • *****
  • 3136
    • Photos
Re: Ixus300 / SD4000 - Still BETA, can I still find and download CHDK 1.1?
« Reply #12 on: 20 / January / 2015, 02:54:45 »
Attached is a new build for the IXUS 300.

This uses different firmware functions for the ND filter, so please retest that.

It does not yet fix the zebra display; but adds three numbers displayed at the top left of the LCD that should help me fix the zebra function.

I need to know the values displayed for the three numbers for each of the following modes:
- playback mode
- record mode, Large image size
- record mode, Medium 1 image size
- record mode, Medium 2 image size
- record mode, Medium 3 image size
- record mode, Small image size
- record mode, Widescreen image size
- video mode, 1280 x 720 movie size
- video mode, 640 x 480 movie size
- video mode, 320 x 240 movie size

Phil.
CHDK ports:
  sx30is (1.00c, 1.00h, 1.00l, 1.00n & 1.00p)
  g12 (1.00c, 1.00e, 1.00f & 1.00g)
  sx130is (1.01d & 1.01f)
  ixus310hs (1.00a & 1.01a)
  sx40hs (1.00d, 1.00g & 1.00i)
  g1x (1.00e, 1.00f & 1.00g)
  g5x (1.00c, 1.01a, 1.01b)

*

Offline I2k4

  • *
  • 28
Re: Ixus300 / SD4000 - Still BETA, can I still find and download CHDK 1.1?
« Reply #13 on: 20 / January / 2015, 07:44:13 »
REMIX 2 RESULTS

I was able to try it out this morning.  After one test of the 3 Digit readout I rebooted and retested to confirm, but the readings changed (?) After several tries including a couple removing and reinserting the card, it keeps coming up with inconsistent readings.   I've shown the first and the two that repeated, but there were a couple of other different ones as well.   

3 Digits Boot #1
. Playback Mode - 211
. Record L - 811
. Record M1 - 111
. Record M2 - 211
. Record M3 - 311
. Record S - 411
. Record WS - 811
. Video 1280 - 840
. Video 640 - 820
. Video 320 - 810

3 Digits Boots #2, #4 and #5
. Playback - 041
. Record L - 041
. Record M1 - 141
. Record M2 - 241
. Record M3 - 341
. Record S - 441
. Record WS - 841
. Video 1280 - 040
. Video 640 - 020
. Video 320 - 010

3 Digits Boot #3 and #6
. Playback - 011
. Record L - 011
. Record M1 - 111
. Record M2 - 211
. Record M3 - 311
. Record S - 411
. Record WS - 811
. Video 1280 - 040
. Video 640 - 020
. Video 320 - 010

ND Filter - is working properly now.
« Last Edit: 20 / January / 2015, 10:42:44 by I2k4 »
Appreciative end-user for several years:  S5is, SX10is, and SD4000is.


*

Offline philmoz

  • *****
  • 3136
    • Photos
Re: Ixus300 / SD4000 - Still BETA, can I still find and download CHDK 1.1?
« Reply #14 on: 20 / January / 2015, 13:59:46 »
REMIX 2 RESULTS

I was able to try it out this morning.  After one test of the 3 Digit readout I rebooted and retested to confirm, but the readings changed (?) After several tries including a couple removing and reinserting the card, it keeps coming up with inconsistent readings.   I've shown the first and the two that repeated, but there were a couple of other different ones as well.   

Thanks for testing, I think that gives me enough info.

Attached is a new version that will (hopefully) fix the zebra display position.

If it is still not correct, then it would help if you could take photos of the LCD display on the camera and post them here. They don't have to be perfect, a camera phone image will do so long as it's readable.

Phil.
CHDK ports:
  sx30is (1.00c, 1.00h, 1.00l, 1.00n & 1.00p)
  g12 (1.00c, 1.00e, 1.00f & 1.00g)
  sx130is (1.01d & 1.01f)
  ixus310hs (1.00a & 1.01a)
  sx40hs (1.00d, 1.00g & 1.00i)
  g1x (1.00e, 1.00f & 1.00g)
  g5x (1.00c, 1.01a, 1.01b)

*

Offline I2k4

  • *
  • 28
Re: Ixus300 / SD4000 - Still BETA, can I still find and download CHDK 1.1?
« Reply #15 on: 20 / January / 2015, 18:06:38 »
REMIX 3 RESULTS

Zebra is properly centered in the image frame now.  Set to
. Blink 2
. over/under both increased to 10 (my normal setting on other cameras - I've never had Zebra working on the Ixus to optimize it)
. Set Restore Original and Restore OSD
. Draw Over set to Nothing
. and I changed Color Settings to differentiate over (green) and under (orange) exposure. 

Zebra mostly seems to shape correctly to over / under exposed areas, but depending on lighting gets very erratic.  It will blink over / under exposed Zebra displays rather than blinking Zebra / clean OSD, and in one location it shows a large orange (underexposed) horizontal block covering the bottom third of the image area, with a lot of green and white stripes.

Several times after a few shots it freezes the camera black screen with lens out. I have to hold the on/off button for a long time before it shows Error 26 and shuts down. 

(I can't think how to capture all these unpredictable behaviors in any sensible way in JPEGs or even in video since it changes wherever you point the camera and likely with Zebra settings.  Mounting the Ixus on a tripod I shot a .MOV video using another camera's SuperMacro video and it captured a freeze/Error 26 shutdown - it's 89mb - I'm not experienced with video or file size reduction.)

. ND Filter "In" setting now flashes between dim and normal instead of staying dim, and reverts to normal lighting on shutter half-press.  Also (with Zebra disabled) the camera froze again, required about 20 seconds on the power button before Error 26 and shutdown.  (Note that it was working on Remix 2)

Histogram still seems fine and as you predicted the Grids are still off center, irrelevant to me.

I've never had any freeze / Error 26 problem with the camera using CHDK 1.1 for a couple of years now.  Odd that it happened both with Zebra alone and with ND Filter alone.  I don't know if the cause is either of those settings or something else about the build.

I've done what I can today.  I'll try to followup up on anything further from you.
Appreciative end-user for several years:  S5is, SX10is, and SD4000is.

*

Offline philmoz

  • *****
  • 3136
    • Photos
Re: Ixus300 / SD4000 - Still BETA, can I still find and download CHDK 1.1?
« Reply #16 on: 20 / January / 2015, 20:14:13 »
REMIX 3 RESULTS

Zebra is properly centered in the image frame now.  Set to
. Blink 2
. over/under both increased to 10 (my normal setting on other cameras - I've never had Zebra working on the Ixus to optimize it)
. Set Restore Original and Restore OSD
. Draw Over set to Nothing
. and I changed Color Settings to differentiate over (green) and under (orange) exposure. 

Zebra mostly seems to shape correctly to over / under exposed areas, but depending on lighting gets very erratic.  It will blink over / under exposed Zebra displays rather than blinking Zebra / clean OSD, and in one location it shows a large orange (underexposed) horizontal block covering the bottom third of the image area, with a lot of green and white stripes.

Several times after a few shots it freezes the camera black screen with lens out. I have to hold the on/off button for a long time before it shows Error 26 and shuts down. 

(I can't think how to capture all these unpredictable behaviors in any sensible way in JPEGs or even in video since it changes wherever you point the camera and likely with Zebra settings.  Mounting the Ixus on a tripod I shot a .MOV video using another camera's SuperMacro video and it captured a freeze/Error 26 shutdown - it's 89mb - I'm not experienced with video or file size reduction.)

. ND Filter "In" setting now flashes between dim and normal instead of staying dim, and reverts to normal lighting on shutter half-press.  Also (with Zebra disabled) the camera froze again, required about 20 seconds on the power button before Error 26 and shutdown.  (Note that it was working on Remix 2)

Histogram still seems fine and as you predicted the Grids are still off center, irrelevant to me.

I've never had any freeze / Error 26 problem with the camera using CHDK 1.1 for a couple of years now.  Odd that it happened both with Zebra alone and with ND Filter alone.  I don't know if the cause is either of those settings or something else about the build.

I've done what I can today.  I'll try to followup up on anything further from you.

Having looked at the code I am surprised that 1.3 would behave very differently from 1.1, unless you were using a custom version of 1.1 that had other changes not in our source.

Anyway here's a build of the last release of 1.1 with the latest zebra and ND filter changes.

If the camera crashes it would help to get a ROMLOG dump from the crash.
To do this:
- go to the Miscellanous stuff --> Debug Parameters menu and select the 'Save ROM crash log' option
- copy the ROMLOG.LOG file from the SD card and upload it here as an attachment.

When uploading the ROMLOG.LOG file please note in the post which CHDK version it was from (1.1 or 1.3).

Phil.
CHDK ports:
  sx30is (1.00c, 1.00h, 1.00l, 1.00n & 1.00p)
  g12 (1.00c, 1.00e, 1.00f & 1.00g)
  sx130is (1.01d & 1.01f)
  ixus310hs (1.00a & 1.01a)
  sx40hs (1.00d, 1.00g & 1.00i)
  g1x (1.00e, 1.00f & 1.00g)
  g5x (1.00c, 1.01a, 1.01b)

*

Offline I2k4

  • *
  • 28
Re: Ixus300 / SD4000 - Still BETA, can I still find and download CHDK 1.1?
« Reply #17 on: 20 / January / 2015, 20:37:05 »
Thanks, I'll get to this in the next day or two. 

To be clear, I've been happily running the standard download of CHDK 1.1 as Beta these years without either Zebra or the ND, but with a working Histogram.  That still adds a whole lot to the little camera.  The following 1.2 Beta fixed the ND, but not Zebra and the Histogram went wonky.  When I saw the new 1.3 was no longer labeled Beta I hoped somebody had managed to finish it, but not so as you've seen.   
Appreciative end-user for several years:  S5is, SX10is, and SD4000is.


*

Offline zeno

  • *****
  • 887
Re: Ixus300 / SD4000 - Still BETA, can I still find and download CHDK 1.1?
« Reply #18 on: 21 / January / 2015, 04:53:35 »
I've only just seen this thread so I wasn't aware there were problems with STICK and your Ixus 300. I say 'your Ixus 300' because the tables I manage that STICK and ACID use have an entry for the ixus300 firmware 100d and the only way that entry got there is because I downloaded a photo taken with an ixus300 from one of the camera review websites and used its EXIF data to construct the table entry.

It's possible that I made a mistake though. Could you email an unmodified photo taken with your camera to me for analysis? If there's a problem I'd like to fix it.

daveATzenoshrdluDOTcom

 
A570, S100, Ixus 127
Author of ASSIST, STICK, WASP, ACID, SDMInst, LICKS, WICKS, MacBoot, UBDB, CFGEdit

*

Offline I2k4

  • *
  • 28
Re: Ixus300 / SD4000 - Still BETA, can I still find and download CHDK 1.1?
« Reply #19 on: 21 / January / 2015, 09:54:52 »
Zeno,  Thanks for noticing.  Would be great to use Stick for larger cards.  Image sent - please let me know here if it doesn't show up.  File is a little larger than normal because I have the SuperFine override set - just now considered that might be a problem for Stick and sent a second image without any CHDK processing.
« Last Edit: 21 / January / 2015, 10:46:01 by I2k4 »
Appreciative end-user for several years:  S5is, SX10is, and SD4000is.

 

Related Topics