supplierdeeply

merges not being recorded in some commits

  • 5 Replies
  • 1314 Views
*

Offline reyalp

  • ******
  • 11496
merges not being recorded in some commits
« on: 21 / February / 2015, 16:48:44 »
Advertisements
I noticed that some merges I've done form trunk to 1.3 have not updated the merge info, meaning that the revisions still show as eligible to merge.

I don't understand why this is happening. srsa's merges appear to be recorded correctly.  It looks like philmoz aren't be recorded either. This seems to go back before the creation of 1.3. The last change I see with merginfo in the root directory updated is 3524 in the release-1_2 branch. It looks like Phil's stopped recording earlier than that.

It seems like an svn client change could be a factor, if we updated at different times.

This isn't a huge deal in our workflow, but it's nice to be able to immediately see which changes have been merged and which haven't. I'm using tortoise 1.8.10, Build 26129 on win 7. I do the merge the same way I have always done (merge, "range of revisions", "specific range"), and it just doesn't modify the merginfo.

If I do a "record only" merge of one of the already merged revisions, it succeeds and doesn't change the merginfo.
If I re-do one of the merges, it also succeeds, without making any changes.

I get the same results using the command line client (1.8.9-SlikSvn-1.8.9-X64) .

I guess it's possible that this is expected behavior with some server / client version combination, though I don't see any obvious explanation for it in http://svnbook.red-bean.com/en/1.8/svn.branchmerge.advanced.html

Merges are recorded correctly in other repositories I use with svn 1.8 servers.

edit:
To be clear, this is not something that should stop checking in or merging, just a puzzle.
« Last Edit: 21 / February / 2015, 17:11:35 by reyalp »
Don't forget what the H stands for.

*

Offline srsa_4c

  • ******
  • 3689
Re: merges not being recorded in some commits
« Reply #1 on: 21 / February / 2015, 17:18:44 »
FWIW I have svn 1.7.8 installed (Linux), all my commits are done with kdesvn.
Does relocating the repo (to somewhere else on assembla) have an influence on the issue?
edit: What I meant is, does backing up and restoring the whole repo somewhere else on assembla fix the issue? Either there's a problem with the repo's meta-data or with assembla's server...
« Last Edit: 21 / February / 2015, 17:29:14 by srsa_4c »

*

Offline reyalp

  • ******
  • 11496
Re: merges not being recorded in some commits
« Reply #2 on: 21 / February / 2015, 19:34:05 »
Good idea. I did a dump from the assembla project and load into a local repo (with the same cli svn and tortoise mentioned above), and the merginfo gets updated if I do the same merges.

I haven't tried doing it into a new space on assembla
Don't forget what the H stands for.

*

Offline srsa_4c

  • ******
  • 3689
Re: merges not being recorded in some commits
« Reply #3 on: 28 / May / 2015, 18:14:57 »
An update:
I now have svn 1.8.13 installed, and this is what I get when merging from trunk to a branch:
Code: [Select]
[...]/release-1_3> svn merge -c 4160 ^/trunk
--- Merging r4160 into '.':
U    tools/finsig_dryos.c
U    tools/firmware_load.c
Mergeinfo is not mentioned and not updated. I guess I should just go ahead since no-one else is able to record mergeinfo anyway...?


*

Offline reyalp

  • ******
  • 11496
Re: merges not being recorded in some commits
« Reply #4 on: 28 / May / 2015, 21:29:56 »
An update:
I now have svn 1.8.13 installed, and this is what I get when merging from trunk to a branch:
Code: [Select]
[...]/release-1_3> svn merge -c 4160 ^/trunk
--- Merging r4160 into '.':
U    tools/finsig_dryos.c
U    tools/firmware_load.c
Mergeinfo is not mentioned and not updated. I guess I should just go ahead since no-one else is able to record mergeinfo anyway...?
Yeah, it's been broken for so long I wouldn't worry about having a few more unrecorded. Try to put the merged revision in the commit log.
Don't forget what the H stands for.

*

Offline reyalp

  • ******
  • 11496
Re: merges not being recorded in some commits
« Reply #5 on: 04 / October / 2015, 23:36:01 »
I noticed my merge for r4272 was recorded correctly, so maybe this problem was fixed by something they did to fix other other svn problems recently.
Don't forget what the H stands for.

 

Related Topics