supplierdeeply

PowerShot SX200 IS shoots RAW images with too much noise

  • 6 Replies
  • 2260 Views
PowerShot SX200 IS shoots RAW images with too much noise
« on: 08 / March / 2015, 08:07:42 »
Advertisements
Hi all,

I'm using Canon PowerShot SX200 IS and just found this CHDK hack. I tried to install it on my camera, it was just fine, but the RAW images are super noisy. The noise is unacceptable, compared to the JPEG version. What did happen to my images? Is this common issue or anything went wrong?

Thanks.

Re: PowerShot SX200 IS shoots RAW images with too much noise
« Reply #1 on: 08 / March / 2015, 10:24:51 »
Are you saving RAW or DNG files?   What computer software are you using to view them? You might actually be seeing a "thumbnail" rather that the actual image if you are using DNG format.

Please upload a sample image  (both the jpg & dng file) to a file sharing site (e.g. box.com ) and post a link here so that we can take a look.
Ported :   A1200    SD940   G10    Powershot N    G16

Re: PowerShot SX200 IS shoots RAW images with too much noise
« Reply #2 on: 08 / March / 2015, 10:53:30 »
Are you saving RAW or DNG files?   What computer software are you using to view them? You might actually be seeing a "thumbnail" rather that the actual image if you are using DNG format.

Please upload a sample image  (both the jpg & dng file) to a file sharing site (e.g. box.com ) and post a link here so that we can take a look.

Yes, I'm using DNG. I use Apple Aperture to view and edit my images. And I'm not talking about thumbnail.

Here are my examples, JPEG and DNG versions of the same image (original, untouched):

JPEG:


DNG:

Re: PowerShot SX200 IS shoots RAW images with too much noise
« Reply #3 on: 08 / March / 2015, 11:13:00 »
Here are my examples, JPEG and DNG versions of the same image (original, untouched):
I'd still like to see the original images rather than screen shots please.
Ported :   A1200    SD940   G10    Powershot N    G16



Re: PowerShot SX200 IS shoots RAW images with too much noise
« Reply #5 on: 08 / March / 2015, 11:56:56 »
The noise is unacceptable, compared to the JPEG version. What did happen to my images? Is this common issue or anything went wrong?
The JPG & DNG images look pretty normal to me.   

Don't forget that the DNG image is exactly what come from the sensor while the JPG has been heavily processed by the Canon firmware ( white balance, color tweaking, lens aberation removal, and bad pixels masking / removal, image compression ).   

That being said - there seem to be a lot of bad pixels in the DNG file.   The exif info for the DNG file tells me that you are using DNG version 1.3 images rather than 1.1.  If you select 1.1 in the CHDK RAW/DNG menu,  then CHDK will attempt to fix those for you.  Otherwise,  you need to use PC software that understands Adobe's DNG 1.3 opcodes for bad pixel removal.  More info on this can be found here :

http://chdk.setepontos.com/index.php?topic=8982.msg93528#msg93528

If you come back later,  others with more detailed knowledge about CHDK DNG might respond as well.
Ported :   A1200    SD940   G10    Powershot N    G16

*

Offline reyalp

  • ******
  • 11514
Re: PowerShot SX200 IS shoots RAW images with too much noise
« Reply #6 on: 08 / March / 2015, 15:58:12 »
This seems normal to me. According to the exif, the shot was taken at ISO 400, so you can expect a lot of noise. The Canon firmware does a bunch of noise reduction, and you would need to do the same in your raw processing software to get equivalent results.

In this case, the shutter speed was 1/2000th, so a lower ISO could have been used.
Don't forget what the H stands for.

 

Related Topics