supplierdeeply

DNG file issues with SX240

  • 6 Replies
  • 1442 Views
DNG file issues with SX240
« on: 05 / May / 2015, 16:09:31 »
Advertisements
Hello all, I have an SX240HS-101a with CHDK_DE_sx240hs-101a-1.3.0-4152-full.zip
I configured saving RAW with DNG ver 1.1 as well as 1.3 and made pictures in different modes M, Av, Tv (not Auto, because of known issues)
CHDK stores files of 19M with DNG extension e. g.
 19M -rw-r--r-- 1 xxx yyy 19M  5. Mai 21:00 CRW_0011.DNG
When opening these DNG files in Gimp or XnView, both progs recognize and display the picuture with 128 x 96 px only. EXIF data is fine.
The file size of the DNGs indicates that they should have full resolution from the sensor. Could there be an issue with the DNG format ?
I appreciate very much your advise how to make DNG work on SX240 ... many thanks!
« Last Edit: 05 / May / 2015, 16:24:00 by Hagen »

*

Offline reyalp

  • ******
  • 11271
Re: DNG file issues with SX240
« Reply #1 on: 05 / May / 2015, 16:20:08 »
When opening these DNG files in Gimp or XnView, both progs recognize and display the picuture with 128 x 96 px only. EXIF data is fine.
The file size of the DNGs indicates that they should have full resolution from the sensor. Could there be an issue with the DNG format ?
It's almost certainly an issue with the software you are trying to use. DNG is an extension of the TIFF format, so programs that understand regular TIFF but not DNG often just show you the thumbnail.

For gimp, you should be able to use ufraw to load DNG files, but I'd suggest using a dedicated raw processing program like raw therapee or darktable.
Don't forget what the H stands for.

Re: DNG file issues with SX240
« Reply #2 on: 05 / May / 2015, 17:31:17 »
Thanks for your fast response and your advise reyalp !
XnView claims it can read DNG, but that seem to be wrong.
Gimp & UFRaw under Win is a mess, but I could get it work under Linux
RawTherapee was simple to install and worked right away.

So I can open and process the DNG files from SX240 now. Many thanks for your help !
« Last Edit: 05 / May / 2015, 17:33:02 by Hagen »

*

Offline reyalp

  • ******
  • 11271
Re: DNG file issues with SX240
« Reply #3 on: 05 / May / 2015, 22:04:03 »
XnView claims it can read DNG, but that seem to be wrong.
If you can upload a sample DNG somewhere (a file hosting site like dropbox, google drive etc), I can check for problems.

You can also run the dng_validate program that comes with the DNG sdk.
Don't forget what the H stands for.


Re: DNG file issues with SX240
« Reply #4 on: 06 / May / 2015, 07:47:55 »
I have uploaded a DNG ver 1.1 file from the SX240 to https://www.dropbox.com/s/s1426s43y7qky0w/CRW_0038.DNG?dl=0. Can you please check if this shows any format issues.

I made one other observation which may be related. I created the badpixel.bin using the menu option "Create badpixel.bin".
The message at the end says "Badpixel Count = 0" and the resulting file in the CHDK directory has size 0.
-rw-r--r-- 1 xxx yyy 0  6. Mai 13:16 badpixel.bin
Seems very unlikely that the SX240 has really ZERO bad pixels.

*

Offline msl

  • *****
  • 1235
  • A720 IS, SX220 HS 1.01a
    • CHDK inside
Re: DNG file issues with SX240
« Reply #5 on: 06 / May / 2015, 09:18:32 »
Your DNG file is fine, tested in xnview (an older portable version) and with the adobe DNG codec as explorer extension. Maybe you have a local problem with your software.

Badpixel Count = 0 is a known issue. Your camera has more than one bad pixel table for different exposure times. This makes it difficult to read the correct values.

Activate DNG version 1.3 in the CHDK RAW/DNG menu.

msl
German CHDK pages:  CHDK forum | CHDK inside | CHDK Twitter News by msl | Download CHDK-DE (Autobuild)
Note: SDM violates the GPL rules!

Re: DNG file issues with SX240
« Reply #6 on: 06 / May / 2015, 10:56:13 »
Thanks for your feedback ... very interesting !

I double-checked with an old XnView portable 1.99 from Dec-12. It detects the DNG as 4080 x 3036 px in RGB 48 bit and displays it correctly.
The latest XnViewMP detects the DNG as 128 x 96 px in RGB 24 bit and displays it in that low resolution. So there is an issue with DNG in XnViewMP.

Reg. badpixel.bin ... will switch to DNG ver 1.3

Many thanks for your help !!

 

Related Topics