Testing cameras after kbd.c change: 27 tested | 2 with minor bugs - page 4 - General Discussion and Assistance - CHDK Forum  

Testing cameras after kbd.c change: 27 tested | 2 with minor bugs

  • 89 Replies
  • 25339 Views
*

Offline reyalp

  • ******
  • 13434
Advertisements
I checked in a change for ixus950_sd850 in trunk 4164 that should hopefully fix the problem. Not bothering with a patch since the existing code was non-functional.
Don't forget what the H stands for.

*

Offline koshy

  • *****
  • 1065
I checked in a change for ixus950_sd850 in trunk 4164 that should hopefully fix the problem. Not bothering with a patch since the existing code was non-functional.
Very good, I tested that today.

- I950 boots a current CHDK 1.4 (4164)
- FW doesn't show "card locked" message
- keys outside of alt mode work
- there is a "touch control dial"
- keys in ALT mode work fine
- "touch control dial" does not interfere in ALT mode
- shooting RAW / JPEG was fine
- USB remote was fine
- CHDKPTP spot check of buttons including wheel buttons was fine

Unrelated Bugs:
- Palette problem in CHDKPTP (see attached screenshot what's displayed alternates between odd and even button presses, that is many items are not visible every second time and generally the color is off)
- Shooting JPEG from CHDKPTP fails as I950 is missing FWT implementation
« Last Edit: 07 / June / 2015, 18:10:53 by koshy »
Koshy had a little ELPH which wasn't white as snow but everywhere that Koshy went the ELPH was sure to go. (actually an SD, but that detail ruins the rhyme...)

*

Offline koshy

  • *****
  • 1065
IXUS 860

- I860 boots a current CHDK 1.4
- FW doesn't show "card locked" message
- keys outside of alt mode work
- there is a "touch control dial"
- keys in ALT mode work fine
- "touch control dial" does not interfere in ALT mode
- shooting RAW / JPEG was fine
- USB remote was fine
- CHDKPTP spot check of buttons including wheel buttons was fine

Using CHDKPTP I found the same even / odd set button press display problem as reported for I950.
« Last Edit: 05 / June / 2015, 19:06:43 by koshy »
Koshy had a little ELPH which wasn't white as snow but everywhere that Koshy went the ELPH was sure to go. (actually an SD, but that detail ruins the rhyme...)

*

Offline koshy

  • *****
  • 1065
IXUS 850

- I850 boots a current CHDK 1.4
- FW doesn't show "card locked" message
- keys outside of alt mode work
- has no dial
- keys in ALT mode work fine
- shooting RAW / JPEG was fine
- USB remote was fine
- CHDKPTP spot check of buttons was fine by function but UI overlay didn't work

Using CHDKPTP Left Right Up Down worked on the camera but the UI Overlay did not update to show any of that. Pressing SET once brings the settings onto the UI overlay but pressing SET again does not hide them from it while it affects the camera just normally. So the functions still show although they are not open.

Also I think there is a palette problem (on all cams where I said that I used the reset all colors entry on the CHDK menu to be sure I had nothing lingering on there).
« Last Edit: 06 / June / 2015, 11:47:44 by koshy »
Koshy had a little ELPH which wasn't white as snow but everywhere that Koshy went the ELPH was sure to go. (actually an SD, but that detail ruins the rhyme...)


*

Offline koshy

  • *****
  • 1065
IXUS 800

- I800 boots a current CHDK 1.4
- FW doesn't show "card locked" message
- keys outside of alt mode work
- has no dial
- keys in ALT mode work fine
- shooting RAW / JPEG was fine
- USB remote was fine
- CHDKPTP spot check of buttons was fine, UI overlay worked except for SET where items always stayed invisible like on the right hand side photo for I950. Same blue appearance as on the others.
« Last Edit: 06 / June / 2015, 11:47:23 by koshy »
Koshy had a little ELPH which wasn't white as snow but everywhere that Koshy went the ELPH was sure to go. (actually an SD, but that detail ruins the rhyme...)

*

Offline reyalp

  • ******
  • 13434
Using CHDKPTP Left Right Up Down worked on the camera but the UI Overlay did not update to show any of that. Pressing SET once brings the settings onto the UI overlay but pressing SET again does not hide them from it while it affects the camera just normally. So the functions still show although they are not open.

Also I think there is a palette problem (on all cams where I said that I used the reset all colors entry on the CHDK menu to be sure I had nothing lingering on there).
Both of these are normal on cameras that don't have a full PTP live view implementation. The first happens when vid_get_bitmap_active_buffer is not implemented: The camera swaps bitmap buffers when it updates the UI, but the PTP code isn't aware of it and so shows you stale info.

The second is usually because vid_get_palette_type is not defined, so the PTP code just uses a hard coded default palette.

IXUS 800, IXUS 850, IXUS 860 and IXUS 900 are all missing both functions.

Again, I appreciate the reports and will try to fix things where I can, just trying to explain what's happening. If you recognize these symptoms, you shouldn't need to spend more time investigating the details. You can also check if the above mentioned functions appear in the cameras platform lib.c or sub/lib.c
Don't forget what the H stands for.

*

Offline koshy

  • *****
  • 1065
Again, I appreciate the reports and will try to fix things where I can, just trying to explain what's happening. If you recognize these symptoms, you shouldn't need to spend more time investigating the details. You can also check if the above mentioned functions appear in the cameras platform lib.c or sub/lib.c
Thanks, that's useful. Something that isn't implemented and can be seen easily from the code does not need to be collected as a bug report.

As a general question: Is it relavant that on some cameras without a jogdial or "touch control dial" the "wheel l" and "wheel r" buttons work in executing left / right movement while for some others they just don't do anything? I didn't mention where they don't work if the camera has no dial but just noticed on the I750 that the buttons worked so I was wondering that.
Koshy had a little ELPH which wasn't white as snow but everywhere that Koshy went the ELPH was sure to go. (actually an SD, but that detail ruins the rhyme...)

*

Offline koshy

  • *****
  • 1065
IXUS 750

- I750 boots a current CHDK 1.4
- FW doesn't show "card locked" message
- keys outside of alt mode work
- has no dial
- keys in ALT mode work fine
- shooting RAW / JPEG was fine
- USB remote was fine
- CHDKPTP spot check of buttons was fine

Another camera that doesn't have a full PTP live view implementation.
« Last Edit: 06 / June / 2015, 11:47:03 by koshy »
Koshy had a little ELPH which wasn't white as snow but everywhere that Koshy went the ELPH was sure to go. (actually an SD, but that detail ruins the rhyme...)


*

Offline koshy

  • *****
  • 1065
IXUS 700

- I700 boots a current CHDK 1.4
- FW doesn't show "card locked" message
- keys outside of alt mode work
- has no dial
- keys in ALT mode work fine
- shooting RAW / JPEG was fine
- USB remote was fine
- CHDKPTP spot check of buttons was fine

Another camera that doesn't have a full PTP live view implementation.
Also doesn't shoot JPEG remotely (as it's missing FWT implementation)
Wheel buttons in CHDKPTP cause error message on camera.
« Last Edit: 07 / June / 2015, 18:09:48 by koshy »
Koshy had a little ELPH which wasn't white as snow but everywhere that Koshy went the ELPH was sure to go. (actually an SD, but that detail ruins the rhyme...)

*

Offline koshy

  • *****
  • 1065
IXUS WiFi

- IW boots a current CHDK 1.4
- FW doesn't show "card locked" message
- keys outside of alt mode work
- has no dial
- keys in ALT mode work fine
- shooting RAW / JPEG was fine
- USB remote was fine
- CHDKPTP spot check of buttons was fine

everything CHDKPTP looked fine, wheel buttons also work here.
Koshy had a little ELPH which wasn't white as snow but everywhere that Koshy went the ELPH was sure to go. (actually an SD, but that detail ruins the rhyme...)

 

Related Topics