Porting a camera sx530hs - page 22 - DryOS Development - CHDK Forum  

Porting a camera sx530hs

  • 288 Replies
  • 80802 Views
*

Offline blackhole

  • *****
  • 684
  • A590IS 101b
    • Planetary astrophotography
Re: Porting a camera sx530hs
« Reply #210 on: 01 / June / 2016, 04:32:32 »
Advertisements
Quote
There's one issue with cameras that have 'ECO mode': none of the Canon powersave modes activate until CHDK ALT mode is entered (and left) at least once. (Can somebody confirm this? I see this happening on my DIGIC 4+ and 6 cameras.)
I see what you mean, ECO mode does not function before entering and leaving the ALT mode.

*

Offline reyalp

  • ******
  • 12074
Re: Porting a camera sx530hs
« Reply #211 on: 01 / June / 2016, 16:21:33 »
I see what you mean, ECO mode does not function before entering and leaving the ALT mode.
Presumably this is due to the "disable screen off in alt mode" setting somehow.

A hacky workaround would be to either toggle alt mode briefly at boot-up, or call the underlying functions.

Toggling alt mode might interact with auto-start scripts.
Don't forget what the H stands for.

*

Offline srsa_4c

  • ******
  • 3979
Re: Porting a camera sx530hs
« Reply #212 on: 01 / June / 2016, 20:33:21 »
I see what you mean, ECO mode does not function before entering and leaving the ALT mode.
Presumably this is due to the "disable screen off in alt mode" setting somehow.
Yes, I suspect LockMainPower/UnlockMainPower. If I set "Disable LCD off" to 'never', Canon power saving kicks in normally. I intentionally avoided telling about this setting in my previous post, because it can have a very confusing effect, especially on newbies (screen turns off while browsing the CHDK menu, etc.).

It's not clear to me why LockMainPower/UnlockMainPower is even executed at CHDK startup, and how it can cause this effect. We should fix this though, I only accidentally discovered that entering/exiting ALT cures the condition.

Does this occur on the g7x?

*

Offline reyalp

  • ******
  • 12074
Re: Porting a camera sx530hs
« Reply #213 on: 01 / June / 2016, 23:40:06 »
Does this occur on the g7x?
Yes, it seems to.

I set CHDK "disable LCD off" to "alt", set canon menu "Power saving" -> "display off" to 30 sec. Power up, switch to rec, just sits there with display on. Enter/exit alt, display turns off after ~30 sec.

I did not have Canon "ECO mode" enabled.
Don't forget what the H stands for.


*

Offline srsa_4c

  • ******
  • 3979
Re: Porting a camera sx530hs
« Reply #214 on: 09 / June / 2016, 16:27:15 »
I'm thinking about enabling the sx520/530 ports in autobuild. There's one known issue, reported in the sx520 thread that no one else was able to reproduce. I don't know if that's supposed to be a showstopper.

*

Offline reyalp

  • ******
  • 12074
Re: Porting a camera sx530hs
« Reply #215 on: 09 / June / 2016, 16:49:18 »
I'm thinking about enabling the sx520/530 ports in autobuild. There's one known issue, reported in the sx520 thread that no one else was able to reproduce. I don't know if that's supposed to be a showstopper.
I wouldn't consider it a showstopper. If it's a real issue, more users will probably give us a better chance of tracking it down.
Don't forget what the H stands for.

*

Offline srsa_4c

  • ******
  • 3979
Re: Porting a camera sx530hs
« Reply #216 on: 09 / June / 2016, 20:36:37 »
I have enabled the ports in trunk autobuild.

The movie AF (lock) related stuff is not available in official builds, it will be added later.

Reports about bugs and other issues are still welcome.

It's possible to add support for the 100a firmware version, but we need somebody with that camera. It won't happen by itself.

Re: Porting a camera sx530hs
« Reply #217 on: 09 / June / 2016, 21:28:59 »
Awesome! This is amazing!


Re: Porting a camera sx530hs
« Reply #218 on: 30 / June / 2016, 08:13:45 »
Hi guys.. Question here...

When i use stick and select stable (default) it download a firmware in folder title "sx530hs-100c" does that mean its the correct firmware/build n i can go ahead and install it without doing all that manual downloading and renaming that was required?

Sent from my SGH-T999 using Tapatalk


Re: Porting a camera sx530hs
« Reply #219 on: 30 / June / 2016, 08:18:34 »
When i use stick and select stable (default) it download a firmware in folder title "sx530hs-100c" does that mean its the correct firmware/build n i can go ahead and install it without doing all that manual downloading and renaming that was required?
Yes.
Ported :   A1200    SD940   G10    Powershot N    G16

 

Related Topics