supplierdeeply

RAW producing garbled DNGs

  • 9 Replies
  • 1359 Views
RAW producing garbled DNGs
« on: 28 / June / 2015, 18:02:57 »
Advertisements
RAW shooting used to work on my Canon ELPH, but now, even with a new, clean install of 1.3 or 1.4, it produces garbled DNGs. See attached DNG converted to JPG.

Re: RAW producing garbled DNGs
« Reply #1 on: 28 / June / 2015, 18:11:42 »
Which ELPH do you have?  There are many.

It would also be handy if you would post the original DNG file.
Ported :   A1200    SD940   G10    Powershot N    G16

Re: RAW producing garbled DNGs
« Reply #2 on: 28 / June / 2015, 18:33:24 »
ELPH 110HS
Incidentally I have tried the various releases and currently I am using ixus125_elph110hs-101a-1.4.0-4175-full_ALPHA.zip

Where can I upload a 24MB file to?
« Last Edit: 28 / June / 2015, 18:37:28 by faru »

Re: RAW producing garbled DNGs
« Reply #3 on: 28 / June / 2015, 18:36:38 »
www.box.com ?   Although 24M sounds a bit big for a DNG file...
« Last Edit: 28 / June / 2015, 18:38:11 by waterwingz »
Ported :   A1200    SD940   G10    Powershot N    G16


Re: RAW producing garbled DNGs
« Reply #4 on: 28 / June / 2015, 18:44:06 »
BOTH the DNG and the JPG were damaged in this case.   usually  it is just the DNG.

https://www.dropbox.com/s/8k4pvkqmjv79kct/CRW_0771.DNG?dl=0
https://www.dropbox.com/s/mst26ra5dzgj59e/IMG_0771.JPG?dl=0

 DNG files are always about 24 megs.  this is a 16 megapixel camera.


[email protected] 1 x  staff    24M Jun 28 15:23 CRW_0768.DNG
-rwxrwxrwx  1 x  staff    24M Jun 28  2015 CRW_0769.DNG
-rwxrwxrwx  1 x  staff    24M Jun 28  2015 CRW_0770.DNG
-rwxrwxrwx  1 x  staff    24M Jun 28  2015 CRW_0771.DNG
-rwxrwxrwx  1 x  staff   2.9M Jun 28 15:22 IMG_0766.JPG
-rwxrwxrwx  1 x  staff   2.9M Jun 28 15:22 IMG_0767.JPG
[email protected] 1 x  staff   2.8M Jun 28 15:23 IMG_0768.JPG
-rwxrwxrwx  1 x  staff   2.3M Jun 28  2015 IMG_0769.JPG
-rwxrwxrwx  1 x  staff   3.8M Jun 28  2015 IMG_0770.JPG
-rwxrwxrwx  1 x  staff   3.7M Jun 28  2015 IMG_0771.JPG
« Last Edit: 28 / June / 2015, 18:45:59 by faru »

*

Offline reyalp

  • ******
  • 11271
Re: RAW producing garbled DNGs
« Reply #5 on: 28 / June / 2015, 18:53:19 »
What mode are you shooting in? Many recent cameras produce garbled raws in AUTO mode. Some other modes may also have problems. P mode generally works.
Don't forget what the H stands for.

Re: RAW producing garbled DNGs
« Reply #6 on: 28 / June / 2015, 18:55:10 »
Yea - the DNG's from my G10 (14.7 megapixel) are a 22.5M.  Never noticed that before.

The exif header info in your DNG looks normal even though the picture is corrupted.   

I'll leave this to reyalp to decide if something in RAW handling has changed enough that maybe really large sensors are having timing issues?

Meanwhile, I can find an older build for you if you want to revert somewhat.
Ported :   A1200    SD940   G10    Powershot N    G16

*

Offline reyalp

  • ******
  • 11271
Re: RAW producing garbled DNGs
« Reply #7 on: 28 / June / 2015, 19:02:40 »
Issues with raw were previously reported in this port, and not resolved http://chdk.setepontos.com/index.php?topic=8085.msg115195#msg115195 because the person who complained did not provide further information.
Don't forget what the H stands for.


Re: RAW producing garbled DNGs
« Reply #8 on: 29 / June / 2015, 00:14:51 »
What mode are you shooting in? Many recent cameras produce garbled raws in AUTO mode. Some other modes may also have problems. P mode generally works.

I have good news. Auto mode was enabled and is the reason why the ELPH 110HS was producing bad RAWs. The alternatives to Auto in this P&S camera are about 10 different modes (there are no aperture- or shutter-priority modes). These consist of P, portrait, B&W, soft-skin, long-exposure, and others. Portrait works. Long-exposure works. I believe earlier today P mode did not produce viable CRWs, but I will retest and report on that later.

This explains why RAWs worked one day, then mysteriously stopped working and continued to not work even after reinstalling CHDK.

What doesn't make sense is why JPEGs would be getting corrupted in Auto mode...

Also  in case the timing issue has to do with the SD card write speed  I would note that the problem occurs with multiple SD cards including my speed 10 card  and my HCI card.
Thanks.
« Last Edit: 29 / June / 2015, 00:34:40 by faru »

*

Offline reyalp

  • ******
  • 11271
Re: RAW producing garbled DNGs
« Reply #9 on: 29 / June / 2015, 02:04:32 »
I believe earlier today P mode did not produce viable CRWs, but I will retest and report on that later.
Please do, AFAIK all other cameras that suffer from an issue like this work in P mode.

Also please check continuous mode, it's possible that the raw buffer address is wrong some of the time.
Quote
What doesn't make sense is why JPEGs would be getting corrupted in Auto mode...
Having DNG enabled in Auto could corrupt memory related to the jpeg process.
Don't forget what the H stands for.

 

Related Topics