SX60HS Porting - page 86 - DryOS Development - CHDK Forum supplierdeeply

SX60HS Porting

  • 915 Replies
  • 204583 Views
Re: SX60HS Porting
« Reply #850 on: 17 / April / 2018, 13:55:55 »
Advertisements
Quote
No, sx60hs-100h-prealpha-svn5010-v2 was not lucky. again a clean black screen, no reaction.
Never underestimate the foolishness of rushing...I completely forgot one of the tasks filewrite.c which would cause the boot sequence to fail badly....see v3 attached below.  @megazaic : again thank you for your patience!

Re: SX60HS Porting
« Reply #851 on: 17 / April / 2018, 15:03:28 »
sx60hs-100h-prealpha-svn5010-v3
yesss!  8)
have logo from v3.
from power-off go to preview mode, from power-off go to shoot mode (with long press 'On/Off').
from preview go to shoot normally, from shoot to preview hangs and turns off.
can not get photo - focused, then hangs and turns off.

how i can enter to CHDK config?  no button turns on the '<ALT>'. or is it too early?  ;)
« Last Edit: 17 / April / 2018, 15:06:36 by megazaic »

Re: SX60HS Porting
« Reply #852 on: 17 / April / 2018, 15:19:14 »
 :D yay!
Quote
how i can enter to CHDK config?  no button turns on the '<ALT>'. or is it too early?
Try turning it on by holding the play button.  This will boot in preview mode.  After the splash screen clears, press the play button one more time, this should produce ALT at the bottom of the screen which means you are CHDK mode. If you cannot get into ALT by pressing the Play key, try the WIFI key at the bottom of the camera next to the menu key, or possibly the Video button. Pressing MENU at this point should put you into the CHDK menus.

Quote
from shoot to preview hangs and turns off.
can not get photo - focused, then hangs and turns off.
Sounds like "half press" in shoot crashes it...I'll review the code more. In the meantime:

If the camera crashes, the next time you boot, go into CHDK mode, Miscellaneous, Debug Parameters, save ROM crash log.  This will produce a file in the top directory of the SD card called romlog.txt which you can post here for debugging purposes.

« Last Edit: 17 / April / 2018, 15:21:15 by 62ndidiot »

Re: SX60HS Porting
« Reply #853 on: 17 / April / 2018, 15:50:46 »
I think the viewport buffer needs correction.  Try this please.


Re: SX60HS Porting
« Reply #854 on: 17 / April / 2018, 15:56:13 »
Try turning it on by holding the play button.
every time, when i press Play button, i have 'hangs and turns off'. probably, this is the enter, but incorrect.
'half press' is work, a can many times move zoom and get focus. but 'full press' do 'hangs and turns off'.
btw, i can record video, see 'calc...' on the screen, tnen '0000 KB/s -00:00:01'
WiFi button open WiFi menu, all othen buttn have standard functions.
still not have <ALT> and CHDK mode.

with sx60hs-100h-prealpha-svn5010-v4 not see any changes
« Last Edit: 17 / April / 2018, 15:59:53 by megazaic »

Re: SX60HS Porting
« Reply #855 on: 17 / April / 2018, 16:05:02 »
Quote
btw, i can record video, see 'calc...' on the screen, tnen '0000 KB/s -00:00:01'
hmmmm sounds like I may not have  eliminated all the experimental movie features from the gui...
That could be a problem.
I'll have to investigate some more...its conceivable that this prevents ALT from showing up. Maybe check the menu button brings up the CANON menu after attempting ALT.  It'll be a couple of hours before I can look at this and do something.

FWIW, the same build boots on my 100f and behaves well, entering ALT by pressing Play.  Video record displays the "calc..."...which I think is a remanent of some other stuff. 
So the immediate problem is to get your camera into Alt mode....



« Last Edit: 17 / April / 2018, 17:35:53 by 62ndidiot »

Re: SX60HS Porting
« Reply #856 on: 17 / April / 2018, 17:33:04 »
Quote
btw, i can record video, see 'calc...' on the screen, tnen '0000 KB/s -00:00:01
I think this is just because you inherited my menu settings to display this.....

Quote
every time, when i press Play button, i have 'hangs and turns off'.
If you press play too slowly ( a little bit longer) you will turn off the camera (it doesn't take much of a press to do this).  Just a really quick little press to get ALT

Re: SX60HS Porting
« Reply #857 on: 17 / April / 2018, 18:42:25 »


Re: SX60HS Porting
« Reply #858 on: 17 / April / 2018, 18:54:48 »
?? sorry could not see preview on my phone....the message looked blank
« Last Edit: 17 / April / 2018, 19:13:33 by 62ndidiot »

Re: SX60HS Porting
« Reply #859 on: 17 / April / 2018, 18:59:56 »
??
1) half-press / full press effect,
2) effect of "really quick little press Play"

 

Related Topics