SX60HS Porting - page 41 - DryOS Development - CHDK Forum  

SX60HS Porting

  • 915 Replies
  • 300575 Views
Re: SX60HS Porting
« Reply #400 on: 22 / May / 2016, 14:19:48 »
Advertisements
Thanks srsa, I compared sx530HS and see the same logic.  I implemented this logic, and I think it suppresses darkframe even on the first shot. The first shot is a little longer than the second shot, but not double length. On a 15 second exposure the first shot takes about 15 + 9 seconds, on the second 15+3 seconds before ready for the next.  Any ideas what could be going on in the first to make it a bit longer?

Tried moving the override earlier in capt-seq, still works the same.
« Last Edit: 22 / May / 2016, 14:37:23 by 62ndidiot »

*

Offline srsa_4c

  • ******
  • 4447
Re: SX60HS Porting
« Reply #401 on: 22 / May / 2016, 15:02:32 »
The first shot is a little longer than the second shot, but not double length. On a 15 second exposure the first shot takes about 15 + 9 seconds, on the second 15+3 seconds before ready for the next.  Any ideas what could be going on in the first to make it a bit longer?
No idea.
You could try writing other values to 0x1e858 (up to 13), but I don't know about their effect.

Re: SX60HS Porting
« Reply #402 on: 22 / May / 2016, 15:06:17 »
Hello Everyone,

I've just tested the latest for 100b and here are my findings:
1. Persistent menu issues disappeared... works fine now... I also noticed that when you do back from a 2nd level sub-menu, all the menu disappears. - No need to re-exit the 1st level menu... I think it's very good this way.
2. The flickering that everyone was talking about, but which wasn't present on the previous build I tested is now present... but it's not much of a problem. It does blink but not too fast.
3. I managed to crash it by going into 'Enhanced photo op' using the right button, instead of set, and again pressing the right button (to change the override settings) and crash. - Did that twice... doesn't crash when using the set button to enter the 'enhanced photo op' - Romlog attached.

All in all I'm much more happier now with my SX60, thanks to you guys :-) if i had to choose only one of the cams (sx50 or Sx60) for a trip, I always took the sx50 because of the timelapsing capabilities... now, it's so much more flexible... I can't thank you enough!

Re: SX60HS Porting
« Reply #403 on: 22 / May / 2016, 16:36:32 »
Hi Reuben, thanks for testing. It looks like the attached romlog is from a few days ago (May 16), maybe try generating it again.
Whoops my mistake, download renamed it.

This crash doesn't happen on my 100f cam.
Looks like a wrong stub for GetFocusLensSubjectDistanceFromLens, I'll correct and re-attach here.

Attached, hope you have time to try.
« Last Edit: 22 / May / 2016, 18:08:29 by 62ndidiot »


Re: SX60HS Porting
« Reply #404 on: 23 / May / 2016, 11:40:36 »
Well done 62ndidiot... no longer crashes when i do this right right combo... i will keep testing - will come back when it crashes :p but will keep monitoring the exchanges here!
Thanks again!

Re: SX60HS Porting
« Reply #405 on: 23 / May / 2016, 13:12:32 »
Good morning reyalp, srsa_4c.  I'm attaching an SVN diff below to commit to the repository. It includes all the new code for 100b. Both 100b and 100f are updated to include exp_drv and filewrite, as well as darkframe control.
« Last Edit: 24 / May / 2016, 00:29:05 by 62ndidiot »

Re: SX60HS Porting
« Reply #406 on: 24 / May / 2016, 11:59:42 »
« Last Edit: 26 / October / 2016, 13:14:52 by 62ndidiot »

Re: SX60HS Porting
« Reply #407 on: 24 / May / 2016, 12:01:12 »
« Last Edit: 26 / October / 2016, 13:13:31 by 62ndidiot »


*

Offline reyalp

  • ******
  • 13673
Re: SX60HS Porting
« Reply #408 on: 24 / May / 2016, 13:00:30 »
Good morning reyalp, srsa_4c.  I'm attaching an SVN diff below to commit to the repository. It includes all the new code for 100b. Both 100b and 100f are updated to include exp_drv and filewrite, as well as darkframe control.
Great work :)
Haven't had a chance to look through it yet, but I'll try to get this in tonight if no one beats me to it.
Don't forget what the H stands for.

*

Offline reyalp

  • ******
  • 13673
Re: SX60HS Porting
« Reply #409 on: 25 / May / 2016, 00:50:10 »
The filewrite.c files appear to be missing from the patch.

Also, if you can work from an up to date svn working copy, that would be helpful. 100b was added in 4620, and your patch is from 4619, so all the 100b files are added in the patch. Before you update, I'd suggest copying your current tree sx60hs platform tree somewhere else. (edit: mistake on my part, see following posts)

I didn't see any other problems.
« Last Edit: 25 / May / 2016, 16:36:23 by reyalp »
Don't forget what the H stands for.

 

Related Topics