SX60HS Porting - page 46 - DryOS Development - CHDK Forum

SX60HS Porting

  • 915 Replies
  • 280770 Views
Re: SX60HS Porting
« Reply #450 on: 07 / July / 2016, 00:12:34 »
Advertisements
@vasanthtcs
 Here are links depending on your firmware version:

100f:
https://chdk.setepontos.com/index.php?topic=12532.msg128721#msg128721

100b:
https://chdk.setepontos.com/index.php?topic=12532.msg128722#msg128722

If you have the incorrect version, it will not boot. If you use the firmware update method of boot, please only use it to make the SD card bootable (because in DIGIC6 many things don't work correctly in this mode). After you make the SD card bootable, take the card out and move the writelock slider to LOCK, re-insert and reboot...you should then have CHDK running on your SX60HS :)

If you encounter problems or crashes please post them here so they can be fixed.
Thanks!

Re: SX60HS Porting
« Reply #451 on: 07 / July / 2016, 00:43:24 »
@vasanthtcs
 Here are links depending on your firmware version:

100f:
https://chdk.setepontos.com/index.php?topic=12532.msg128721#msg128721

100b:
https://chdk.setepontos.com/index.php?topic=12532.msg128722#msg128722

If you have the incorrect version, it will not boot. If you use the firmware update method of boot, please only use it to make the SD card bootable (because in DIGIC6 many things don't work correctly in this mode). After you make the SD card bootable, take the card out and move the writelock slider to LOCK, re-insert and reboot...you should then have CHDK running on your SX60HS :)

If you encounter problems or crashes please post them here so they can be fixed.
Thanks!

Thank you so much for getting the info for me. Truly appreciate your time.

*

Offline reyalp

  • ******
  • 13443
Re: SX60HS Porting
« Reply #452 on: 09 / July / 2016, 23:14:01 »
I finally got around to testing g7x for the orientation issue reported by gile2004

Booted with card unlocked, took one still shot in horizontal orientation.
Rebooted, ran "firm update"
Camera boots and the picture alternates between portrait and landscape faster than once per second
Attempting the read the orientation sensor propcase value over chdkptp resulted in "ERROR: compile error" :blink: (really means that starting the script failed somehow, but not clear what)
Using the on screen prop display shows the value alternating between 0 and 90

This seems consistent with a hardware initialization problem.

Conclusion: I would highly recommend against using "firm update" for regular use on D6 ports until these issues are resolved.
Don't forget what the H stands for.

Re: SX60HS Porting
« Reply #453 on: 10 / July / 2016, 01:01:30 »
Thanks for more testing. Boot by firmware update method is NOT preferred.


*

Offline reyalp

  • ******
  • 13443
Re: SX60HS Porting
« Reply #454 on: 12 / July / 2016, 21:39:06 »
motion detection discussion split to https://chdk.setepontos.com/index.php?topic=12918.0
Don't forget what the H stands for.

Re: SX60HS Porting
« Reply #455 on: 03 / August / 2016, 18:06:32 »
I never had  courage to try chdk on my S5IS- too scared of damaging the camera!
Then damaged the camera anyway and had no choice but to replace it - with SX50. Took my courage + new camera + chdk to the wildnerness and discovered a whole new world of dark skies, long exposures and time lapse - I was totally blown away, and became hooked on chdk. Then I wrecked the SX50, and here I am now with my SX60 100f and chdk 1.5.0-4631 successfully loaded - so thank you, thank you to all the guys who went before and all those working on this SX60 port - you are truly amazing.

I have two problems: after pressing ON/OFF button, chdk loads via write locked bootable SD card, but

1) the menus are very small  and I find hard to read - ALT menu is only 1/2 as wide as the LCD screen - is there perhaps a chdk option to increase the size? (I looked but couldn't find anything), and then also

(2) after entering ALT mode, changing settings in Enhanced Photo Operations (menus are all steady - no flickering), exiting ALT mode, entering record mode via shutter 1/2 press, I find chdk batt % and temp displays are now flickering rapidly. Returning to ALT mode, all the chdk menus are also now flickering rapidly so that I can't read the choices or make any selections.

Any tests I can do and report on that might help someone work out a fix?

Re: SX60HS Porting
« Reply #456 on: 03 / August / 2016, 20:09:38 »
Any tests I can do and report on that might help someone work out a fix?
The SX60 is one of the newer Canon cameras using the DIGIC6 chipset.  This chipset is quite different than those previously supported by CHDK. The video problems you see are well known and there is currently no solution.  I know it's no consolation but at the moment, you should probably be happy that anything works at all with your SX60. Stay tuned - things will eventually improve - just not quickly.
Ported :   A1200    SD940   G10    Powershot N    G16

*

Offline reyalp

  • ******
  • 13443
Re: SX60HS Porting
« Reply #457 on: 03 / August / 2016, 21:14:20 »
1) the menus are very small  and I find hard to read - ALT menu is only 1/2 as wide as the LCD screen - is there perhaps a chdk option to increase the size? (I looked but couldn't find anything), and then also
You can use a larger font, in chdk settings->menu settings->language & fonts

I use Menu-A20.rbf on g7x.

Quote
(2) after entering ALT mode, changing settings in Enhanced Photo Operations (menus are all steady - no flickering), exiting ALT mode, entering record mode via shutter 1/2 press, I find chdk batt % and temp displays are now flickering rapidly. Returning to ALT mode, all the chdk menus are also now flickering rapidly so that I can't read the choices or make any selections.
This may depend on Canon settings, or what shooting mode you are in.
Don't forget what the H stands for.


Re: SX60HS Porting
« Reply #458 on: 04 / August / 2016, 18:53:47 »
waterwingz: I am indeed happy - just getting chdk loaded was a triumph for this aging tech-challenged brain, and I will surely stay tuned, as I have been since iax started the thread Aug '15.

reyalp: tks - I tried Menu-A20.rbf - a 100% improvement on the default font. I have subsequently found it possible to make menu selections despite the flickering syndrome - so tks again.

The flicker was evident in both Auto and Manual modes. But I noticed a very strange thing: when camera is kept dead steady, the flicker stops - thereafter if the camera is moved the flicker recommences immediately - keep camera steady and the flicker stops etc. - seems like a useless bit of information which won't help solve the problem, but thought to mention it anyway.

SX60HS Porting
« Reply #459 on: 04 / August / 2016, 19:20:15 »
As I think you've noticed, doing as much CHDK setup via its menus in playback mode (rather than shooting mode) makes things a lot easier.  This is the case with all cameras - not just the new DIGIC6 models.
Ported :   A1200    SD940   G10    Powershot N    G16

 

Related Topics