EOS M3 porting - page 26 - DryOS Development - CHDK Forum  

EOS M3 porting

  • 722 Replies
  • 335855 Views
Re: EOS M3 porting
« Reply #250 on: 23 / January / 2017, 16:36:17 »
Advertisements
Awesome that worked!  Thank you very much.


Re: EOS M3 porting
« Reply #251 on: 26 / January / 2017, 21:15:51 »
i'm new eos m3 user
wanted run ML but site told me to run chdk
my firmware before was 110a and downgraded to 101a
why nothing happen even i follow this instruction?

I would proceed as follows:
- Using EOSCard to make the SD card bootable.
- Copy the content of CHDK-M3-101a-r32 to the SD card
- Set SD card to the locked position
- Turn on the camera


i need press playback button ?

*

Offline Ant

  • *****
  • 509
Re: EOS M3 porting
« Reply #252 on: 27 / January / 2017, 00:43:57 »
i need press playback button ?
You need to read my post on previous page and CHDK FAQ/Wiki.

*

Offline c_joerg

  • *****
  • 1231
Re: EOS M3 porting
« Reply #253 on: 27 / January / 2017, 02:14:41 »
i'm new eos m3 user
wanted run ML but site told me to run chdk
my firmware before was 110a and downgraded to 101a
why nothing happen even i follow this instruction?
- Copy the content of CHDK-M3-101a-r32 to the SD card
- Using EOSCard to make the SD card bootable.
I think the order is wrong. I think you have first the copy and then make the card bootable or?
M100 100a, M3 121a, G9x II (1.00c), 2*G1x (101a,100e), S110 (103a), SX50 (100c), SX230 (101a), S45,
Flickr https://www.flickr.com/photos/136329431@N06/albums
YouTube https://www.youtube.com/channel/UCrTH0tHy9OYTVDzWIvXEMlw/videos?shelf_id=0&view=0&sort=dd


Re: EOS M3 porting
« Reply #254 on: 27 / January / 2017, 02:26:36 »
there's nothing wrong with order,
my eos m3 finally can boot chdk by change partition of sdcard. my sdcard 32gb unfortunately fat/fat16 max size is 2048KB/2GB so i separate sdcard into 2 partition. < 2gb for fat/fat16 and rest unallocated partition. (CHDK FAQ/Wiki)
any config for auto run/keep script when sdcard switch (unlock)? my rest unallocated partition become useless because can't use that
« Last Edit: 27 / January / 2017, 02:28:35 by gozex »

*

Offline Ant

  • *****
  • 509
Re: EOS M3 porting
« Reply #255 on: 27 / January / 2017, 04:30:22 »
On M3 CHDK works fine with FAT32 and 32GB SDHC.
IIRC, I had problems only after installing GRUB on SD card.
Maybe you need to wipe out the first megabyte of your SD card(including MBR and partition table) and then format it.
« Last Edit: 27 / January / 2017, 04:34:20 by Ant »

Re: EOS M3 porting
« Reply #256 on: 27 / January / 2017, 18:44:31 »
i'm new eos m3 user
wanted run ML but site told me to run chdk
my firmware before was 110a and downgraded to 101a
why nothing happen even i follow this instruction?
- Copy the content of CHDK-M3-101a-r32 to the SD card
- Using EOSCard to make the SD card bootable.
I think the order is wrong. I think you have first the copy and then make the card bootable or?
My Guess is your problem could be "..Using EOSCard to make the SD card bootable..."
Are you suing the latest version of EOSCard. ??
Also, for me, EOSCard can report differing results depending on how its used.

See Re: EOS M3 porting « Reply #161 on: 11/November/2016
Edit #1 Using Acid (Automatic Camera Identifier) to Identify the M3 version.
https://chdk.setepontos.com/index.php?action=dlattach;topic=12542.0;attach=13536;image
https://chdk.setepontos.com/index.php?action=dlattach;topic=12542.0;attach=13538;image

The method I use is to:-

a/ Low Level format with Canons M3 Low Level format menu option.
b/ Then use EOSCard just to set the "For_Script Disk" and save.
c/ Then use EOSCard just to report on SD-Card status.
d/ Then Use another CHDK (post 2011) capable camera, or CHDK Utility, to set the SD-Card as "Bootable"
c/ Then Copy the required version of the M3 to the SD-Card.
e/ Re-use EOSCard just to report on SD-Card status.
f/ Re-try the SD-Card in your M3.

My M3-101a is faulty so, some times it works OK, and other times when experimenting with a
new version of CHDK for My M3-101a then the M3 just does "Something" and then crashes.

H-H
« Last Edit: 27 / January / 2017, 19:42:15 by Hardware_Hacker »

Re: EOS M3 porting
« Reply #257 on: 27 / January / 2017, 22:40:30 »
My Guess is your problem could be "..Using EOSCard to make the SD card bootable..."
...

d/ Then Use another CHDK (post 2011) capable camera, or CHDK Utility, to set the SD-Card as "Bootable"
There have been several people who have recently had trouble getting EOScard to work. I suspect it fails to write properly to the SD card due to O/S permission errors but does not report the failure.   It's a very old utility so using it with anything more modern that WinXP may very well fail.

Using a bootable SD card configured in a recent camera - or the STICK utility for unofficial builds (  STICKX ) is highly recommended.
Ported :   A1200    SD940   G10    Powershot N    G16


Re: EOS M3 porting
« Reply #258 on: 27 / January / 2017, 23:18:45 »
My Guess is your problem could be "..Using EOSCard to make the SD card bootable..."
...

d/ Then Use another CHDK (post 2011) capable camera, or CHDK Utility, to set the SD-Card as "Bootable"
.. It's a very old utility so using it with anything more modern that WinXP may very well fail...
I am using Win-10 "Core" (i.e. the free home edition's) and EOSCARD (ver 1v40) works very well
as dose many of the older WinXP programs the previousy refused to work at all.

EOSCard is very useful for just observing what actually happening in regard to the SD-Card.

I have just completed pre-paring 50 SD-Cards for use with CHDK and used it to confirm the
results and found a few mistakes on my part.

H-H
« Last Edit: 27 / January / 2017, 23:22:37 by Hardware_Hacker »

*

Offline c_joerg

  • *****
  • 1231
Re: EOS M3 porting
« Reply #259 on: 31 / January / 2017, 06:20:46 »
I have run rawopint on my own M3.  :)
The following changes were happens to the run which I posted here.
https://chdk.setepontos.com/index.php?topic=12542.80

It looks like, that I got a correct focal length. I used the EF-M 22
Code: [Select]
fl:22000 efl:35200
I got valid temperature values from optic, senor and battery.

I don’t got the error

Code: [Select]
tv 361 != cam 576
anymore. Does this mean, propcases for Tv is now correct?

But I still got

Code: [Select]
sv 411 != cam 480
As @reyalp describes in Reply #81, the propcases for Sv is still wrong.
I’ll try to do some investigation as he describes in Reply #81

M100 100a, M3 121a, G9x II (1.00c), 2*G1x (101a,100e), S110 (103a), SX50 (100c), SX230 (101a), S45,
Flickr https://www.flickr.com/photos/136329431@N06/albums
YouTube https://www.youtube.com/channel/UCrTH0tHy9OYTVDzWIvXEMlw/videos?shelf_id=0&view=0&sort=dd

 

Related Topics