EOS M3 porting - page 29 - DryOS Development - CHDK Forum supplierdeeply

EOS M3 porting

  • 722 Replies
  • 335889 Views
*

Offline reyalp

  • ******
  • 13792
Re: EOS M3 porting
« Reply #280 on: 07 / February / 2017, 17:06:16 »
Advertisements
But why I got on my S110 and G1x on ISO100 sv96=411 and on the M3 sv96=480?
That's a question for Canon engineers ;)

Powershots have two different ISO values: "Market" ISO shown in the display, the "real" ISO used elsewhere. The offset between these values varies between models. On cameras like G7X and M3 the "real" and "market" values are the same.

Because it was long time ago, when CAM_SENSOR_BITS_PER_PIXEL was not corrected.
The blacklevel value should be measured. On cameras with native raw, you can probably get it from a Canon raw file, but it's a good idea to check that the average raw value of a dark frame is close to the defined blacklevel value.
Don't forget what the H stands for.

*

Offline c_joerg

  • *****
  • 1231
Re: EOS M3 porting
« Reply #281 on: 08 / February / 2017, 08:25:23 »
On cameras like G7X and M3 the "real" and "market" values are the same.
OK, I remember the discussion which we had on G7x with the 2/3 stops….

The blacklevel value should be measured. On cameras with native raw, you can probably get it from a Canon raw file

I did the following with a Canon RAW File
Code: [Select]
exiftool -h img_0001.cr2I got
Code: [Select]
<tr><td>Per Channel Black Level</td><td>2048 2048 2048 2048</td></tr>
So it looks like that the M3 has the same black_level:2047 like the M10…

but it's a good idea to check that the average raw value of a dark frame is close to the defined blacklevel value.
Not sure how to do this…


M100 100a, M3 121a, G9x II (1.00c), 2*G1x (101a,100e), S110 (103a), SX50 (100c), SX230 (101a), S45,
Flickr https://www.flickr.com/photos/136329431@N06/albums
YouTube https://www.youtube.com/channel/UCrTH0tHy9OYTVDzWIvXEMlw/videos?shelf_id=0&view=0&sort=dd

*

Offline c_joerg

  • *****
  • 1231
Re: EOS M3 porting
« Reply #282 on: 09 / February / 2017, 13:58:39 »
I had a crash while making a black picture in M Mode. I had to take the battery off.
What is the GK.LOG?
M100 100a, M3 121a, G9x II (1.00c), 2*G1x (101a,100e), S110 (103a), SX50 (100c), SX230 (101a), S45,
Flickr https://www.flickr.com/photos/136329431@N06/albums
YouTube https://www.youtube.com/channel/UCrTH0tHy9OYTVDzWIvXEMlw/videos?shelf_id=0&view=0&sort=dd

*

Offline Ant

  • *****
  • 509
Re: EOS M3 porting
« Reply #283 on: 09 / February / 2017, 14:07:37 »
How many times you had a crash?
I guess GK is "Graphic Kernel"


*

Offline c_joerg

  • *****
  • 1231
Re: EOS M3 porting
« Reply #284 on: 09 / February / 2017, 14:18:19 »
How many times you had a crash?
Just one time. The camera didn’t make a photo.
After the crash, I changed Tv and Av. Then I could not reproduce it because I can’t remember the values when it crashed…
M100 100a, M3 121a, G9x II (1.00c), 2*G1x (101a,100e), S110 (103a), SX50 (100c), SX230 (101a), S45,
Flickr https://www.flickr.com/photos/136329431@N06/albums
YouTube https://www.youtube.com/channel/UCrTH0tHy9OYTVDzWIvXEMlw/videos?shelf_id=0&view=0&sort=dd

*

Offline c_joerg

  • *****
  • 1231
Re: EOS M3 porting
« Reply #285 on: 10 / February / 2017, 12:07:36 »
I analyzed a black and a white (overexposed) RAW file with
Code: [Select]
Dcraw64 -4 -D -T black.cr2The mean of the black was 2048 and of the white 16383.
So, it looks like, the black level is 2048 like the M10.
But what has to be changed? Just the  CAM_BLACK_LEVEL to 2048 (or 2047)?

M100 100a, M3 121a, G9x II (1.00c), 2*G1x (101a,100e), S110 (103a), SX50 (100c), SX230 (101a), S45,
Flickr https://www.flickr.com/photos/136329431@N06/albums
YouTube https://www.youtube.com/channel/UCrTH0tHy9OYTVDzWIvXEMlw/videos?shelf_id=0&view=0&sort=dd

*

Offline Ant

  • *****
  • 509
Re: EOS M3 porting
« Reply #286 on: 10 / February / 2017, 13:23:49 »
Compiled with CAM_BLACK_LEVEL 2047
Is there significant difference?
« Last Edit: 10 / February / 2017, 14:10:19 by Ant »

*

Offline c_joerg

  • *****
  • 1231
Re: EOS M3 porting
« Reply #287 on: 10 / February / 2017, 13:58:21 »
Compiled with CAM_BLACK_LEVEL 2047
Is there significant difference?

Hmm, the log still says black_level=511. Did you really change it?

Picture, made with rawopint are a little bit underexposed with the M3. The mean of pictures is around 108. On my other cams around 128. So I think it have to do with the wrong black_level.
M100 100a, M3 121a, G9x II (1.00c), 2*G1x (101a,100e), S110 (103a), SX50 (100c), SX230 (101a), S45,
Flickr https://www.flickr.com/photos/136329431@N06/albums
YouTube https://www.youtube.com/channel/UCrTH0tHy9OYTVDzWIvXEMlw/videos?shelf_id=0&view=0&sort=dd


*

Offline Ant

  • *****
  • 509
Re: EOS M3 porting
« Reply #288 on: 10 / February / 2017, 14:09:15 »
I uploaded wrong file.
Here is correct one.

*

Offline c_joerg

  • *****
  • 1231
Re: EOS M3 porting
« Reply #289 on: 10 / February / 2017, 14:30:18 »
The black level is now 2047…
But now the pictures are much higher than neutral. The mean is around 200. Not sure what’s wrong. May be
@reyalp can look in the log file….

M100 100a, M3 121a, G9x II (1.00c), 2*G1x (101a,100e), S110 (103a), SX50 (100c), SX230 (101a), S45,
Flickr https://www.flickr.com/photos/136329431@N06/albums
YouTube https://www.youtube.com/channel/UCrTH0tHy9OYTVDzWIvXEMlw/videos?shelf_id=0&view=0&sort=dd

 

Related Topics