EOS M3 porting - page 70 - DryOS Development - CHDK Forum

EOS M3 porting

  • 696 Replies
  • 278923 Views
*

Offline Caefix

  • *****
  • 517
  • Sorry, busy deleting test shots...
Re: EOS M3 porting
« Reply #690 on: 25 / June / 2021, 14:22:13 »
Advertisements
 :-X (1.21a, Ximr build)
md grid fits perfect in 3:2, other aspect ratios need adjustment.
Values of the lower half are spooky ...
Edit: Ximr build only ...
« Last Edit: 25 / June / 2021, 15:34:52 by Caefix »
All lifetime is a loan from eternity.

*

Online reyalp

  • ******
  • 13290
Re: EOS M3 porting
« Reply #691 on: 25 / June / 2021, 17:31:15 »
md grid fits perfect in 3:2, other aspect ratios need adjustment.
I can confirm this happens on other ximr builds when the aspect ratio isn't the native LCD aspect.

Quote
Values of the lower half are spooky ...
Can you clarify what you mean by "spooky"? Does MD trigger when there is no motion?
Don't forget what the H stands for.

*

Online philmoz

  • *****
  • 3325
    • Photos
Re: EOS M3 porting
« Reply #692 on: 26 / June / 2021, 02:57:13 »
md grid fits perfect in 3:2, other aspect ratios need adjustment.
Edit: Ximr build only ...


I have checked in a fix for this in the ximr branch and updated the build images on Google Drive.

CHDK ports:
  sx30is (1.00c, 1.00h, 1.00l, 1.00n & 1.00p)
  g12 (1.00c, 1.00e, 1.00f & 1.00g)
  sx130is (1.01d & 1.01f)
  ixus310hs (1.00a & 1.01a)
  sx40hs (1.00d, 1.00g & 1.00i)
  g1x (1.00e, 1.00f & 1.00g)
  g5x (1.00c, 1.01a, 1.01b)
  g7x2 (1.01a, 1.01b, 1.10b)

*

Offline Caefix

  • *****
  • 517
  • Sorry, busy deleting test shots...
Re: EOS M3 porting
« Reply #693 on: 26 / June / 2021, 11:07:36 »
Can you clarify what you mean by "spooky"? Does MD trigger when there is no motion?
Yes, even with the lenshood.

 :o Ahje, the charger is dead, no LED, no charching, spare bat at 40%...
The cam is more robust, recently it crashed from good 1/2 meter on asphalt, on the  flashside corner. Flash opened, lenscap jumped around, cam with 18-55 IS STM bounced back in a loop and landed on the bottom. NO damage at all. Flash and AF beem still working.
The reason was, that the bag´s hook wasn´t hooked right, when I took it out of the rucksack.
Please don´t repeat to confirm that...

Edit: No AF-beam at MD-tune.bas ...
« Last Edit: 26 / June / 2021, 13:05:48 by Caefix »
All lifetime is a loan from eternity.


*

Online reyalp

  • ******
  • 13290
Re: EOS M3 porting
« Reply #694 on: 26 / June / 2021, 16:57:32 »
Can you clarify what you mean by "spooky"? Does MD trigger when there is no motion?
Yes, even with the lenshood.
Found a bug, should be fixed in ximr build 5973. This likely explains some of the issues @pigeonhill had with histograms (but the current svn ximr and trunk have other histogram bugs unfixed).


Quote
The cam is more robust, recently it crashed from good 1/2 meter on asphalt, on the  flashside corner. Flash opened, lenscap jumped around, cam with 18-55 IS STM bounced back in a loop and landed on the bottom. NO damage at all. Flash and AF beem still working.
The reason was, that the bag´s hook wasn´t hooked right, when I took it out of the rucksack.
Please don´t repeat to confirm that...
:o  :(  Better than my g7x that took flight, I guess.
Quote
Edit: No AF-beam at MD-tune.bas ...
Does chdkptp =set_led(1,1) turn it on?

It could maybe be affected if the canon firmware thinks something is in the hot shoe, or Canon flash or AF assist settings.
Don't forget what the H stands for.

*

Offline Caefix

  • *****
  • 517
  • Sorry, busy deleting test shots...
Re: EOS M3 porting
« Reply #695 on: 28 / June / 2021, 11:53:04 »
Quote
Edit: No AF-beam at MD-tune.bas ...
Does chdkptp =set_led(1,1) turn it on?

It could maybe be affected if the canon firmware thinks something is in the hot shoe, or Canon flash or AF assist settings.
set_led performs fine in Lua, ubasic & chdkptp, but no beem in MD-tune.bas loop ...  ??? (last Bat now 22%)
Edit: ximr build only...
:o  :(  Better than my g7x that took flight, I guess.
Edit3: Independently it happens that booting to <Rec> tells since bat ~20% "Charge Bat", while booting to <Play> & switching to <Rec> still works. (now 11%)

Edit4: I think, that platform_camera.h needs from M100:
Code: [Select]
    #undef  CAM_CIRCLE_OF_CONFUSION
    #define CAM_CIRCLE_OF_CONFUSION             19  // CoC value for camera/sensor (see http://www.dofmaster.com/digital_coc.html)
Edit2: REally not the best moment to drop cam that way. Noise shocked family...
« Last Edit: 29 / June / 2021, 15:44:09 by Caefix »
All lifetime is a loan from eternity.

*

Offline Caefix

  • *****
  • 517
  • Sorry, busy deleting test shots...
Re: EOS M3 porting
« Reply #696 on: 07 / July / 2021, 13:52:12 »
 ;) Ximr notes: Temp. set to Bat seems to display 60°C too much or ~triple value.
 Histogram looks all right now.
Edit: Now Bat=-4°C   :haha :blink:
:o Ahje, the charger is dead, no LED, no charching, ...
The cam is more robust, recently it crashed from good 1/2 meter on asphalt,
Scene remetered: ~80cm crash. Luckily neither display nor glass touched the ground.
The charger is okay, too, but does not recognize 3rd party Bonacell-akku.
Edit2: md_tune.bas works fine now.  :)
« Last Edit: 07 / July / 2021, 15:44:52 by Caefix »
All lifetime is a loan from eternity.

 

Related Topics