EOS M3 porting - page 72 - DryOS Development - CHDK Forum  

EOS M3 porting

  • 722 Replies
  • 335865 Views
*

Offline Mlapse

  • *****
  • 528
  • S95 S110
Re: EOS M3 porting
« Reply #710 on: 23 / July / 2022, 10:17:50 »
Advertisements
i took a break from script writing, because i got a new, old cam :)
it's a M3 with 121a firmware and 18-55 lens...the one that's least used it appears.
running latest CHDK 1.6

while playing around with it i found at least one thing...all others things could be due to me, i'll keep that to myself until i know more ;)
when using an interval script it works, however, if i use SUIx, the script automatically shuts down because it believes the card is full after the first image is taken
i'm not sure, but think i pinned it down to:
Code: [Select]
get_jpg_count()
it seems to always return 1

fyi i did see 14G in the CHDK OSD...for a 16GB card.
that appears right according to salesmen.
« Last Edit: 23 / July / 2022, 11:17:28 by Mlapse »
frustration is a key ingredient in progress

*

Offline c_joerg

  • *****
  • 1231
Re: EOS M3 porting
« Reply #711 on: 23 / July / 2022, 11:58:01 »
i'm not sure, but think i pinned it down to:
Code: [Select]
get_jpg_count()
it seems to always return 1

On CHDKPTP I get always 0.
I've never noticed this because none of my scripts use get_jpg_count().
I use get_free_disk_space().
M100 100a, M3 121a, G9x II (1.00c), 2*G1x (101a,100e), S110 (103a), SX50 (100c), SX230 (101a), S45,
Flickr https://www.flickr.com/photos/136329431@N06/albums
YouTube https://www.youtube.com/channel/UCrTH0tHy9OYTVDzWIvXEMlw/videos?shelf_id=0&view=0&sort=dd

*

Offline Mlapse

  • *****
  • 528
  • S95 S110
Re: EOS M3 porting
« Reply #712 on: 23 / July / 2022, 12:05:07 »
you're right it's 0...and sure i can use get_free_disk_space(), but i thought i'd mention that there appears something wrong in the get_jpg_count() since i did not see it in this thread yet.
« Last Edit: 23 / July / 2022, 12:07:22 by Mlapse »
frustration is a key ingredient in progress

*

Offline srsa_4c

  • ******
  • 4450
Re: EOS M3 porting
« Reply #713 on: 23 / July / 2022, 12:23:21 »
but i thought i'd mention that there appears something wrong in the get_jpg_count() since i did not see it in this thread yet.
Nothing is wrong, it's the way it works. The value returned by that function comes from a string that the firmware uses for display purposes. On M10, I need to enter rec mode to get the value.


*

Offline Mlapse

  • *****
  • 528
  • S95 S110
Re: EOS M3 porting
« Reply #714 on: 23 / July / 2022, 13:41:59 »
i noticed it when it was in record mode.
frustration is a key ingredient in progress

*

Offline c_joerg

  • *****
  • 1231
Re: EOS M3 porting
« Reply #715 on: 23 / July / 2022, 13:46:26 »
On M10, I need to enter rec mode to get the value.

I also used rec on the m3 and get 0
M100 100a, M3 121a, G9x II (1.00c), 2*G1x (101a,100e), S110 (103a), SX50 (100c), SX230 (101a), S45,
Flickr https://www.flickr.com/photos/136329431@N06/albums
YouTube https://www.youtube.com/channel/UCrTH0tHy9OYTVDzWIvXEMlw/videos?shelf_id=0&view=0&sort=dd

*

Offline Mlapse

  • *****
  • 528
  • S95 S110
Re: EOS M3 porting
« Reply #716 on: 23 / July / 2022, 13:53:00 »
sorry for stirring something that was going unnoticed without fuss  :-[
frustration is a key ingredient in progress

*

Offline srsa_4c

  • ******
  • 4450
Re: EOS M3 porting
« Reply #717 on: 23 / July / 2022, 14:41:43 »
sorry for stirring something that was going unnoticed without fuss  :-[
OK, I apologize. I was assuming you see the uninitialized behaviour. This really looks like a bug, the port is not using the address that is found by the sigfinder.


*

Offline Mlapse

  • *****
  • 528
  • S95 S110
Re: EOS M3 porting
« Reply #718 on: 23 / July / 2022, 14:55:49 »
no problem, i can come up with something i haven't checked thoroughly instantly... and you may bash me for that :)

i had some calculations with get_day_seconds() that turned out as if they were calculated with floating point, but i assume that's not possible...so i have to check what actually happened.
« Last Edit: 23 / July / 2022, 15:03:11 by Mlapse »
frustration is a key ingredient in progress

*

Offline c_joerg

  • *****
  • 1231
Re: EOS M3 porting
« Reply #719 on: 08 / October / 2022, 13:51:42 »
What is that M3 Firmware    : 1.00 rev 4.00
We have no port for that or?
M100 100a, M3 121a, G9x II (1.00c), 2*G1x (101a,100e), S110 (103a), SX50 (100c), SX230 (101a), S45,
Flickr https://www.flickr.com/photos/136329431@N06/albums
YouTube https://www.youtube.com/channel/UCrTH0tHy9OYTVDzWIvXEMlw/videos?shelf_id=0&view=0&sort=dd

 

Related Topics