EOS M3 porting - page 12 - DryOS Development - CHDK Forum supplierdeeply

EOS M3 porting

  • 746 Replies
  • 400370 Views
Re: EOS M3 porting
« Reply #110 on: 27 / July / 2016, 04:22:05 »
Advertisements
Ant would you say it's safeish to install it on my personal M3? on a scale of 1-10 how safe?

*

Offline Ant

  • *****
  • 509
Re: EOS M3 porting
« Reply #111 on: 27 / July / 2016, 05:20:04 »

Re: EOS M3 porting
« Reply #112 on: 27 / July / 2016, 05:55:20 »
Huh, I was under the impression that the PS.FI2 was required to get CHDK working, and that file is not present in the zip you attached. What do I do, it's not booting (I'm a total noob if you couldn't tell)

*

Offline Ant

  • *****
  • 509
Re: EOS M3 porting
« Reply #113 on: 27 / July / 2016, 06:11:14 »
There is no *.FI2 available at this moment because I am using DISKBOOT.BIN method and special software that makes SDcard bootable.

Read FAQ and Wiki. http://chdk.wikia.com/wiki/Prepare_your_SD_card


*

Offline Ant

  • *****
  • 509
Re: EOS M3 porting
« Reply #114 on: 14 / August / 2016, 18:04:53 »
Tried to use FI2 method to run CHDK: camera crashes during startup somewhere after CreateTask_spytask() . Display does not turn on.

Code: [Select]
ASSERT!! Accelerometer.c Line 1054
Occured Time  2016:08:15 01:00:11
Task ID: 15335455
Task name: Acceleromete4
SP: 0x0069F334
StackDump:
0x00000000
0x00000000
0xFC1F3BBC
0x0000041E
0x00000009
0xFC1F3BBC
0x0000041E
0x19980218
0x19980218
0x19980218
0x19980218
0x19980218
0xBFE155C5
0x00009CA8
0x0000803C
0x19980218
0xFC1F3AAD
0x19980218
0x19980218
0x19980218
0x19980218
0x19980218
0x19980218
0x19980218
0x19980218
0x19980218
0x00682D5C
0x0000803C
0x19980218
0x19980218
0x19980218
0x19980218
0x19980218
0x19980218
0xBFE11735
0x19980218
0x19980218
0x19980218
0x19980218
0x00000408
ShootConDump:
0f 0f 0f 0f 0f 0f 0f 0f 0f 0f
CameraConDump:
12 0f 0f 0f 0f 0f 0f 0f 0f 0f

It looks like first start after closing  battery cover, but camera freezes for a few minutes before crash.
« Last Edit: 14 / August / 2016, 18:11:39 by Ant »

*

Offline reyalp

  • ******
  • 14087
Re: EOS M3 porting
« Reply #115 on: 14 / August / 2016, 18:47:40 »
FWIW, all digic 6 ports so far have unresolved issues with the "firm update" boot. SX280, SX60 and G7X boot but some shooting modes crash, and the orientation sensor freaks out.
Don't forget what the H stands for.

*

Offline Ant

  • *****
  • 509
Re: EOS M3 porting
« Reply #116 on: 22 / August / 2016, 15:46:03 »
Motion detection seems to be working.
Now I'm trying to adapt "edge  overlay" to Digic6.
https://app.assembla.com/spaces/chdk-m3/subversion/commits/16
In live state it works to slow(less than 1 fps). And without edge filter I'm getting strange result:

« Last Edit: 22 / August / 2016, 15:48:25 by Ant »

Re: EOS M3 porting
« Reply #117 on: 22 / August / 2016, 16:19:05 »
Quote
Now I'm trying to adapt "edge  overlay" to Digic6.
https://app.assembla.com/spaces/chdk-m3/subversion/commits/16
In live state it works to slow(less than 1 fps). And without edge filter I'm getting strange result:

Probably you will need to change the Sobel (calc_edge_overlay) edge detection and average_filter_row code to not use UYVYYY but instead use UYVY.  In edgeoverlay.c, I see you have adjusted some dimension (viewport, #of bytes per pixel etc) but you need to modify the code to reference the correct Y values. You can see for example:
Code: [Select]
       // convolve vert (first Y of next pixel)
            conv2 = *(ptrh1 + x + 1) * ( 1) +
                    *(ptrh1 + x + 3) * ( 2) +
                    *(ptrh1 + x + 4) * ( 1) +

                    *(ptrh3 + x + 1) * (-1) +
                    *(ptrh3 + x + 3) * (-2) +
                    *(ptrh3 + x + 4) * (-1);
            if  (conv2 < 0)     // abs()
I think the code is referencing uYvYYY (bytes 1,3,4,5,7,9) and will need to be changed.
Basically, change to only use odd numbered bytes. 3x3 matrices
X+ 1, 3, 5.  You won't have the complication of needing to have differently arranged groups of three in Digic 6

« Last Edit: 22 / August / 2016, 23:29:07 by 62ndidiot »


Re: EOS M3 porting
« Reply #118 on: 23 / August / 2016, 02:43:46 »
EOS M3-101a complex test results are below.
(**** Firmware creation completed successfully)

Note 1:- Ant uses a Fixed CHDK version.

Note 2:- H-H uses Variable CHDK version's:-
And also there is other minor version differences.

Note 3:- H-H uses Win-10v586 PE as a "Standard" test platform.
Note 4:- Each Eos-M3 has a "Unique" LibUSB driver.

a/ EOS M3-101a #1 1v5-4660-full Revision 10, original, by Ant. (17-07-2016)
b/ EOS M3-101a #1 1v5-4676-full Revision 14, original, by Ant. (22-07-2016)

The Eos-M3-101a, Camera under test, #1 is also slightly faulty.
The Eos-M3-100d Cameras, #0 & #2 are Ok, but are still UN-ported.
All are tested with a 22mm f2 STM Canon EF-M Lense.
At this stage a, non-chipped, and non-canon EF-* lenses don't work.

The complex test results are attached as a series of screen shots.
Best viewed from top to bottom and left to right.

They are also colour coded:-
Light Gray for some technical details.
Green for stuff that appears to work Ok.
Orange for stuff that appears to not work.
Red for stuff that appears to fail.

Note 5:- I thought build 1v5-4676 wouldn't work, but I decided to test it "As Is".

To Do:- Try to fix some compile errors and some other stuff try again.

i.e. "..failed to get CreateTask args..", "..duplicate name..", "..missing..", etc.

H-H

Continued in next Post #119
« Last Edit: 23 / August / 2016, 02:48:25 by Hardware_Hacker »

Re: EOS M3 porting
« Reply #119 on: 23 / August / 2016, 02:44:47 »
Continued from Post #118

EOS M3-101a complex test results are below.
(**** Firmware creation completed successfully)

Note 1:- Ant uses a Fixed CHDK version.

Note 2:- H-H uses Variable CHDK version's:-
And also there is other minor version differences.

Note 3:- H-H uses Win-10v586 PE as a "Standard" test platform.
Note 4:- Each Eos-M3 has a "Unique" LibUSB driver.

a/ EOS M3-101a #1 1v5-4660-full Revision 10, original, by Ant. (17-07-2016)
b/ EOS M3-101a #1 1v5-4676-full Revision 14, original, by Ant. (22-07-2016)

The Eos-M3-101a, Camera under test, #1 is also slightly faulty.
The Eos-M3-100d Cameras, #0 & #2 are Ok, but are still UN-ported.
All are tested with a 22mm f2 STM Canon EF-M Lense.
At this stage a, non-chipped, and non-canon EF-* lenses don't work.

The complex test results are attached as a series of screen shots.
Best viewed from top to bottom and left to right.

They are also colour coded:-
Light Gray for some technical details.
Green for stuff that appears to work Ok.
Orange for stuff that appears to not work.
Red for stuff that appears to fail.

Note 5:- I thought build 1v5-4676 wouldn't work, but I decided to test it "As Is".

To Do:- Try to fix some compile errors and some other stuff try again.

i.e. "..failed to get CreateTask args..", "..duplicate name..", "..missing..", etc.

H-H
« Last Edit: 23 / August / 2016, 02:48:48 by Hardware_Hacker »

 

Related Topics


SimplePortal 2.3.6 © 2008-2014, SimplePortal