EOS M3 porting - page 32 - DryOS Development - CHDK Forum supplierdeeply

EOS M3 porting

  • 618 Replies
  • 223497 Views
Re: EOS M3 porting
« Reply #310 on: 13 / March / 2017, 14:42:50 »
Advertisements
It's modified LP-E12 battery without thermistor contact (LP-E12 is slightly shorter).

And that fits? How did you do this?
But you must confirm the use with the camera or?
M100 100a, M3 101a, 2*G1x (101a,100e), S110 (103a), SX50 (100c), SX230 (101a), S45,
Flickr https://www.flickr.com/photos/136329431@N06/albums
YouTube https://www.youtube.com/channel/UCrTH0tHy9OYTVDzWIvXEMlw/videos?shelf_id=0&view=0&sort=dd

*

Offline Ant

  • ****
  • 432
Re: EOS M3 porting
« Reply #311 on: 13 / March / 2017, 15:43:17 »
There were reasons in 2015 to do this modification.
Now I can only confirm that you should buy third party LP-E17.

*

Offline Ant

  • ****
  • 432
Re: EOS M3 porting
« Reply #312 on: 28 / March / 2017, 18:26:15 »
I've checked the newest firmware 1.2.0:
IS related bugs are still present, but rollback to previous fw is still available...

Re: EOS M3 porting
« Reply #313 on: 30 / March / 2017, 07:34:16 »
but rollback to previous fw is still available...

good to know...  :)
M100 100a, M3 101a, 2*G1x (101a,100e), S110 (103a), SX50 (100c), SX230 (101a), S45,
Flickr https://www.flickr.com/photos/136329431@N06/albums
YouTube https://www.youtube.com/channel/UCrTH0tHy9OYTVDzWIvXEMlw/videos?shelf_id=0&view=0&sort=dd


*

Offline reyalp

  • ******
  • 12444
Re: EOS M3 porting
« Reply #314 on: 11 / April / 2017, 22:31:41 »
I split the discussion of benchmarks and the sd card info function: https://chdk.setepontos.com/index.php?topic=13089.0
Don't forget what the H stands for.

*

Offline srsa_4c

  • ******
  • 4150
Re: EOS M3 porting
« Reply #315 on: 14 / April / 2017, 07:18:49 »
Can somebody with this camera check whether CHDK exposure overrides remain effective after the shutter is held halfway down for a few seconds?
On the M10, they are getting overridden by the Canon firmware in all shooting modes except M. That means, when CHDK overrides are set, they are reflected on the Canon overlay for a few moments after a half press, then the exposure parameters return to Canon calculated values.

When that happens, I get these entries in the camera log:
Code: [Select]
00034020: UI:ShootSeqToUI:0x00003157:adr:0xfc2a50cb,Para:-64335669
00034030: UI:DSIC:e3,0
00034030: UI:VTMLock
00034070: UI:VTMUnLock

Re: EOS M3 porting
« Reply #316 on: 14 / April / 2017, 13:44:53 »
Can somebody with this camera check whether CHDK exposure overrides remain effective after the shutter is held halfway down for a few seconds?
On the M10, they are getting overridden by the Canon firmware in all shooting modes except M. That means, when CHDK overrides are set, they are reflected on the Canon overlay for a few moments after a half press, then the exposure parameters return to Canon calculated values.

Not sure if I understood it correct. I never work with override before…
I go on the M3 to AV Mode. ISO100, Av=3.5 and the Camera measure 1/6s.
I got to Enhanced Photo Operation => Override Tv ‘ShrtExp’ and set it to 0.001s.
Now the Canon menu shows Tv=1/1000 when I go to half shutter press. The value is not changing. I did it for 15s.
I that what you mean?

Update:
I can reproduce it. But it is only happening, when the cam can’t focus (when I got the red square). When the cam focus correct, it is not changing.

When that happens, I get these entries in the camera log:

ROMLOG.LOG?
This Shows only older stuff..

« Last Edit: 14 / April / 2017, 13:58:19 by c_joerg »
M100 100a, M3 101a, 2*G1x (101a,100e), S110 (103a), SX50 (100c), SX230 (101a), S45,
Flickr https://www.flickr.com/photos/136329431@N06/albums
YouTube https://www.youtube.com/channel/UCrTH0tHy9OYTVDzWIvXEMlw/videos?shelf_id=0&view=0&sort=dd

*

Offline srsa_4c

  • ******
  • 4150
Re: EOS M3 porting
« Reply #317 on: 14 / April / 2017, 13:59:53 »
I go on the M3 to AV Mode. ISO100, Av=3.5 and the Camera measure 1/6s.
I got to Enhanced Photo Operation => Override Tv ‘ShrtExp’ and set it to 0.001s.
Now the Canon menu shows Tv=1/1000 when I go to half shutter press. The value is not changing. I did it for 15s.
I that what you mean?
Yes.
Quote
Update:
I can reproduce it. But it is only happening, when the cam can’t focus (when I got the red square). When the cam focus correct, it is not changing.
Thanks for finding this, I'm experiencing the exact same behaviour.
I had the cam set to MF when I noticed the override issue.

edit:
ROMLOG.LOG?
This Shows only older stuff..
No, I have a script that saves the camera log to file. The romlog also contains this log up to the point where the camera crashed, but the camera log is always active when the camera is on.
« Last Edit: 14 / April / 2017, 14:05:26 by srsa_4c »


Re: EOS M3 porting
« Reply #318 on: 14 / April / 2017, 14:16:17 »
I had the cam set to MF when I noticed the override issue.

Yes, the same happens when I go to MF. Does that means rawopint will not work in MF Mode or with manual lens?

Here is another thing which I only noticed at the M3:

Normally the aperture does not change between the shoots in rawopint (which is at least my other cameras so).
However, with the M3, the shutter is opened and closed with each shot. This is, however, only in single mode. This does not happen in the continuous mode. In continuous mode the aperture remains fixed in the set position.
I mean the mode just one half press and then only full press…
M100 100a, M3 101a, 2*G1x (101a,100e), S110 (103a), SX50 (100c), SX230 (101a), S45,
Flickr https://www.flickr.com/photos/136329431@N06/albums
YouTube https://www.youtube.com/channel/UCrTH0tHy9OYTVDzWIvXEMlw/videos?shelf_id=0&view=0&sort=dd

*

Offline srsa_4c

  • ******
  • 4150
Re: EOS M3 porting
« Reply #319 on: 14 / April / 2017, 14:35:13 »
Yes, the same happens when I go to MF. Does that means rawopint will not work in MF Mode or with manual lens?
I'm not familiar with that script, so I can only give a generic answer.
If you shoot right after focus/exposure has settled, the overrides may work. The longer you wait after half pressing, the more likely that the firmware overrides the CHDK override. The issue happens when
- focusing is set to manual
- auto focus doesn't find focus
- "there's no lens", meaning any manual lens that doesn't communicate with the body

 

Related Topics