EOS M3 porting - page 33 - DryOS Development - CHDK Forum  

EOS M3 porting

  • 663 Replies
  • 234548 Views
Re: EOS M3 porting
« Reply #320 on: 14 / April / 2017, 15:42:03 »
Advertisements
I'm not familiar with that script, so I can only give a generic answer.
If you shoot right after focus/exposure has settled, the overrides may work. The longer you wait after half pressing, the more likely that the firmware overrides the CHDK override. The issue happens when
- focusing is set to manual
- auto focus doesn't find focus
- "there's no lens", meaning any manual lens that doesn't communicate with the body

I try to find out, what rawopint is doing on MF.

But, rawopint doesn’t work at all with m3-101a-1.5.0-4781. The exposure did not changes
I got the error in log file
Code: [Select]
sv 411 != cam 480
I had this problem in the past (Reply #259 ) and I thougt is was fixed in platform_camera.h?
With Ant’s version m3-101a-1.5.0-35 rawopint works fine.

Update:
Also the black_level is wrong in m3-101a-1.5.0-4781
m3-101a-1.5.0-4781 => black_level=511
m3-101a-1.5.0-35    => black_level=2047

« Last Edit: 14 / April / 2017, 16:06:14 by c_joerg »
M100 100a, M3 101a, 2*G1x (101a,100e), S110 (103a), SX50 (100c), SX230 (101a), S45,
Flickr https://www.flickr.com/photos/136329431@N06/albums
YouTube https://www.youtube.com/channel/UCrTH0tHy9OYTVDzWIvXEMlw/videos?shelf_id=0&view=0&sort=dd

*

Offline Ant

  • ****
  • 440
Re: EOS M3 porting
« Reply #321 on: 14 / April / 2017, 17:30:18 »

But, rawopint doesn’t work at all with m3-101a-1.5.0-4781. The exposure did not changes
I got the error in log file
Code: [Select]
sv 411 != cam 480
I had this problem in the past (Reply #259 ) and I thougt is was fixed in platform_camera.h?
With Ant’s version m3-101a-1.5.0-35 rawopint works fine.
There was no commits for M3 in main repository this year...

*

Offline reyalp

  • ******
  • 12601
Re: EOS M3 porting
« Reply #322 on: 14 / April / 2017, 17:33:06 »
I had this problem in the past (Reply #259 ) and I thougt is was fixed in platform_camera.h?
With Ant’s version m3-101a-1.5.0-35 rawopint works fine.
The last real update to the M3 platform in the official CHDK source was on Dec 4. AFAIK, no patches for this port have been submitted since.

Edit:
There was no commits for M3 in main repository this year...
We only make changes if the person doing the port posts a patch.
« Last Edit: 14 / April / 2017, 17:36:08 by reyalp »
Don't forget what the H stands for.

*

Offline Ant

  • ****
  • 440
Re: EOS M3 porting
« Reply #323 on: 14 / April / 2017, 17:40:05 »
Maybe I'll try to generate patches for M3 this weekend.


*

Offline reyalp

  • ******
  • 12601
Re: EOS M3 porting
« Reply #324 on: 15 / April / 2017, 19:28:28 »
Here's a patch for I think is simple_movie_status. It should be 1 while recording or finishing video, zero otherwise.


Don't forget what the H stands for.

*

Offline Ant

  • ****
  • 440
Re: EOS M3 porting
« Reply #325 on: 16 / April / 2017, 02:02:50 »
It should be 1 while recording or finishing video, zero otherwise.
Checked - it works. Can be added to main repository.

*

Offline reyalp

  • ******
  • 12601
Re: EOS M3 porting
« Reply #326 on: 16 / April / 2017, 03:41:11 »
Checked - it works. Can be added to main repository.
Thanks. Done in 4794
Don't forget what the H stands for.

*

Offline Ant

  • ****
  • 440
Re: EOS M3 porting
« Reply #327 on: 16 / April / 2017, 09:47:36 »
Build 4794 for EOS M3 v1.0.1 can be found in attachment


Re: EOS M3 porting
« Reply #328 on: 16 / April / 2017, 13:30:17 »
Build 4794 for EOS M3 v1.0.1 can be found in attachment
Thanks for update. No Errors in rawopint and black level is OK.
I'm not familiar with that script, so I can only give a generic answer.
The issue happens when
- focusing is set to manual
- auto focus doesn't find focus
- "there's no lens", meaning any manual lens that doesn't communicate with the body

I made just 3 short runs with rawopint (around 3*14 pictures)
1) Fast Mode, Auto Focus
2) Fast Mode, Manual Focus
3) Continuous Mode, Manual Focus
I have the camera held on a bright spot (for two shots). Then I kept the camera in a shadow. The exposure follows as I expected. So, there is no different between Auto and MF.
If you shoot right after focus/exposure has settled, the overrides may work. The longer you wait after half pressing, the more likely that the firmware overrides the CHDK override.
I'm not sure how the timing in the script is. Maybe override takes place shortly before the shoot.

M100 100a, M3 101a, 2*G1x (101a,100e), S110 (103a), SX50 (100c), SX230 (101a), S45,
Flickr https://www.flickr.com/photos/136329431@N06/albums
YouTube https://www.youtube.com/channel/UCrTH0tHy9OYTVDzWIvXEMlw/videos?shelf_id=0&view=0&sort=dd

Re: EOS M3 porting
« Reply #329 on: 21 / April / 2017, 13:48:24 »
Hi,
Disclaimer: fairly new to this. I was wondering when there would be an "official" CHDK zip file download available in http://chdk.wikia.com/wiki/M3 ?
I see there are already some available in this porting thread but was just curious when it would become available within M3's CHDK section.
Two years ago I used an SD880 IS running an intervalometer script for aerial photography on a high altitude balloon. Here are some shots from that flight at 115,000 feet: https://m.imgur.com/a/FxoIM
In about two months I'll be launching another high altitude balloon for a STEM program I'm coordinating for a local children's science museum. This time I've upgraded to an M3 after reading that it can run CHDK.
I'm good at following directions with videos and how to articles, but the how-to on the M3 is littered throughout this thread leaving me a little confused.
This weekend I'll be checking my firmware version and proceeding from there. Can someone guide me to the latest CHDK download that successfully runs on the M3?
Is the latest one under reply #230 of this thread?
Any help is greatly appreciated?
 

 

Related Topics